aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-10 08:49:25 +0800
committermiwi <miwi@FreeBSD.org>2007-06-10 08:49:25 +0800
commita702d51c6cc0fa39182473263daa6e8431c27e0e (patch)
tree8f82d32b59ab4fd5ea9f3f30ff5a2697baca3825
parent02482c47def48cff052ed672b25ff8612fd472bb (diff)
downloadfreebsd-ports-gnome-a702d51c6cc0fa39182473263daa6e8431c27e0e.tar.gz
freebsd-ports-gnome-a702d51c6cc0fa39182473263daa6e8431c27e0e.tar.zst
freebsd-ports-gnome-a702d51c6cc0fa39182473263daa6e8431c27e0e.zip
- Update to 3.2.5
PR: 111246 Submitted by: Eric P. Scott <eps+pbug0704@ana.com>
-rw-r--r--print/transfig/Makefile24
-rw-r--r--print/transfig/distinfo6
-rw-r--r--print/transfig/files/patch-ac67
-rw-r--r--print/transfig/files/patch-fig2dev_dev_Imakefile10
-rw-r--r--print/transfig/files/patch-fig2dev_dev_genemf.h13
-rw-r--r--print/transfig/files/patch-fig2dev_dev_gensvg.c21
-rw-r--r--print/transfig/files/patch-fig2dev_dev_readgif.c11
-rw-r--r--print/transfig/files/patch-fig2dev_fig2dev.h14
-rw-r--r--print/transfig/files/patch-transfig_Imakefile8
-rw-r--r--print/transfig/pkg-descr9
10 files changed, 65 insertions, 118 deletions
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index 61396ab1f802..a093f26e28b0 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -6,31 +6,35 @@
#
PORTNAME= transfig
-PORTVERSION= 3.2.4
-PORTREVISION= 2
+PORTVERSION= 3.2.5
CATEGORIES= print
-MASTER_SITES= http://www.xfig.org/xfigdist/ \
- ftp://www-epb.lbl.gov/xfig/%SUBDIR%/
-MASTER_SITE_SUBDIR= . previous_versions
+MASTER_SITES= http://xfig.org/software/xfig/${PORTVERSION}/ \
+ ftp://www-epb.lbl.gov/xfig/
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tools to convert Xfig's .fig files
-USE_GHOSTSCRIPT_RUN= yes
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+USE_GHOSTSCRIPT_RUN= yes
USE_IMAKE= yes
USE_XPM= yes
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1
+MAKE_ARGS+= INSTALLFLAGS="${COPY}" \
+ INSTPGMFLAGS="${STRIP} ${_BINOWNGRP} -m ${BINMODE}" \
+ INSTBINFLAGS="${_BINOWNGRP} -m ${BINMODE}" \
+ INSTDATFLAGS="${_SHROWNGRP} -m ${SHAREMODE}" \
+ INSTMANFLAGS="${_MANOWNGRP} -m ${MANMODE}"
+
pre-everything::
-.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+.if !defined(WITH_GHOSTSCRIPT_AFPL) && !defined(WITH_GHOSTSCRIPT_GNU)
@${ECHO_MSG} ""
@${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GPL one"
+ @${ECHO_MSG} " Or define WITH_GHOSTSCRIPT_GNU=yes to use GNU one"
@${ECHO_MSG} ""
.endif
diff --git a/print/transfig/distinfo b/print/transfig/distinfo
index 26f598077365..8fd0843d8b90 100644
--- a/print/transfig/distinfo
+++ b/print/transfig/distinfo
@@ -1,3 +1,3 @@
-MD5 (transfig.3.2.4.tar.gz) = 742de0f7a3cae74d247bbd0c70dd9dd7
-SHA256 (transfig.3.2.4.tar.gz) = a4b59323d97866de7b72675c11dc33b95bb479a69cae7d83f98ba972a1d54910
-SIZE (transfig.3.2.4.tar.gz) = 326284
+MD5 (transfig.3.2.5.tar.gz) = 3b2cffdd25529ae5877e305f29aae6d1
+SHA256 (transfig.3.2.5.tar.gz) = ea5a5724c8fa1dcb52531c4d44ec8a59830b2dc2da11e561e15240e8dd16d043
+SIZE (transfig.3.2.5.tar.gz) = 394296
diff --git a/print/transfig/files/patch-ac b/print/transfig/files/patch-ac
index 26cb4f835670..5c5ac8ff6263 100644
--- a/print/transfig/files/patch-ac
+++ b/print/transfig/files/patch-ac
@@ -1,6 +1,6 @@
---- fig2dev/Imakefile.orig Fri Dec 20 02:33:44 2002
-+++ fig2dev/Imakefile Wed Jan 8 08:36:50 2003
-@@ -20,13 +20,13 @@
+--- fig2dev/Imakefile.orig Thu Oct 27 09:56:02 2005
++++ fig2dev/Imakefile
+@@ -34,7 +34,7 @@
XCOMM You should point XFIGLIBDIR to the same directory you did when you compiled
XCOMM and installed xfig.
@@ -8,15 +8,8 @@
+XFIGLIBDIR = $(LIBDIR)/xfig
XCOMM ******
- XCOMM If your system has the strerror() function (doesn't have sys_errlist) then
- XCOMM comment out NEED_STRERROR with an XCOMM comment.
-
--NEED_STRERROR = -DNEED_STRERROR
-+XCOMM NEED_STRERROR = -DNEED_STRERROR
-
- XCOMM The following probably only applies to Windows 9x/NT:
- XCOMM If your system can open files in text and binary modes and has the
-@@ -39,7 +39,7 @@
+ XCOMM If your system doesn't have the strerror() function (has sys_errlist) then
+@@ -53,7 +53,7 @@
XCOMM inline functions. With the "INLINE" keyword, you should notice that
XCOMM the display will be a bit faster in complex figures
@@ -25,23 +18,19 @@
XCOMM ****************
XCOMM Change RGB if necessary, to point to your rgb.txt color database
-@@ -60,8 +60,8 @@
- XCOMM are in different places
+@@ -74,9 +74,9 @@
+ XCOMM file are in different places
#ifdef USEPNG
-PNGLIBDIR = $(USRLIBDIR)
--PNGINC = -I/usr/include/X11
+PNGLIBDIR = ${LOCALBASE}/lib
+ ZLIBDIR = $(USRLIBDIR)
+-PNGINC = -I/usr/include/X11
+PNGINC = -I${LOCALBASE}/include/libpng
#endif
XCOMM ****************
-@@ -73,11 +73,11 @@
- XCOMM Change XPMINC if necessary to point to the include file for xpm (xpm.h)
- XCOMM
-
--XCOMM #define USEXPM
-+#define USEXPM
+@@ -92,7 +92,7 @@
#ifdef USEXPM
XPMLIBDIR = $(USRLIBDIR)
@@ -50,44 +39,16 @@
#endif
XCOMM ****************
-@@ -126,23 +126,23 @@
+@@ -141,7 +141,7 @@
#ifdef I18N
I18N_DEFS = -DI18N
-FIG2DEV_LIBDIR = /usr/local/lib/fig2dev
+FIG2DEV_LIBDIR = $(LIBDIR)/fig2dev
- I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR=\\\"$(FIG2DEV_LIBDIR)\\\"
-
- install::
- [ -d $(DESTDIR)$(FIG2DEV_LIBDIR) ] || mkdir $(DESTDIR)$(FIG2DEV_LIBDIR)
-- $(INSTALL) -c dev/japanese.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
-+ $(INSTALL) $(INSTALLFLAGS) $(INSTDATFLAGS) dev/japanese.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
- ( cd $(DESTDIR)$(FIG2DEV_LIBDIR); \
- rm -f ja.ps ja_JP.ps ja_JP.ujis.ps ja_JP.eucJP.ps ja_JP.EUC.ps; \
- $(LN) japanese.ps ja.ps; $(LN) japanese.ps ja_JP.ps; \
- $(LN) japanese.ps ja_JP.ujis.ps; $(LN) japanese.ps ja_JP.eucJP.ps; \
- $(LN) japanese.ps ja_JP.EUC.ps )
-- $(INSTALL) -c dev/korean.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
-+ $(INSTALL) $(INSTALLFLAGS) $(INSTDATFLAGS) dev/korean.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
- ( cd $(DESTDIR)$(FIG2DEV_LIBDIR); \
- rm -f ko.ps ko_KR.ps ko_KR.eucKR.ps ko_KR.EUC.ps; \
- $(LN) korean.ps ko.ps; $(LN) korean.ps ko_KR.ps; \
- $(LN) korean.ps ko_KR.eucKR.ps; $(LN) korean.ps ko_KR.EUC.ps )
-- $(INSTALL) -c dev/cs_CZ.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
-+ $(INSTALL) $(INSTALLFLAGS) $(INSTDATFLAGS) dev/cs_CZ.ps $(DESTDIR)$(FIG2DEV_LIBDIR)
- ( cd $(DESTDIR)$(FIG2DEV_LIBDIR); \
- rm -f hr_HR.ps hu_HU.ps pl_PL.ps ro_RO.ps sk_SK.ps sl_SI.ps; \
- $(LN) cs_CZ.ps hr_HR.ps; $(LN) cs_CZ.ps hu_HU.ps; \
-@@ -177,7 +177,7 @@
-
- IMAKE_DEFINES = $(DUSEPNG) $(DUSEXPM)
-
--DEVDEFINES = $(DUSEPNG) $(DUSEXPM) $(XPMINC) $(DDNFSS) $(DDA4) \
-+DEVDEFINES = $(DUSEPNG) $(DUSEXPM) $(PNGINC) $(XPMINC) $(DDNFSS) $(DDA4) \
- $(DDLATEX2E_GRAPHICS) $(DDEPSFIG) $(DDIBMGEC) $(DDDVIPS) $(I18N_DEV_DEFS)
+ I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR=$(FIG2DEV_LIBDIR) -DFIG2DEV_LIBDIR_STR=\\\"$(FIG2DEV_LIBDIR)\\\"
- #define IHaveSubdirs
-@@ -233,7 +233,7 @@
+ #endif /* I18N */
+@@ -229,7 +229,7 @@
else (set -x; $(MKDIRHIER) $(DESTDIR)$(XFIGLIBDIR)/bitmaps ); fi ; \
echo Copying bitmap files for tk to $(DESTDIR)$(XFIGLIBDIR)/bitmaps ; \
for f in * ; do \
diff --git a/print/transfig/files/patch-fig2dev_dev_Imakefile b/print/transfig/files/patch-fig2dev_dev_Imakefile
new file mode 100644
index 000000000000..7f1d9ef2923e
--- /dev/null
+++ b/print/transfig/files/patch-fig2dev_dev_Imakefile
@@ -0,0 +1,10 @@
+--- fig2dev/dev/Imakefile.orig Tue Sep 30 08:48:08 2003
++++ fig2dev/dev/Imakefile
+@@ -23,6 +23,7 @@
+ #ifdef USE_PNG
+ READPNGS=readpng.c
+ READPNGO=readpng.o
++DEPEND_DEFINES=-I${LOCALBASE}/include/libpng DependDefines
+ #endif
+
+ #ifdef USE_XPM
diff --git a/print/transfig/files/patch-fig2dev_dev_genemf.h b/print/transfig/files/patch-fig2dev_dev_genemf.h
deleted file mode 100644
index fae1909d75c4..000000000000
--- a/print/transfig/files/patch-fig2dev_dev_genemf.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- fig2dev/dev/genemf.h.orig Thu Dec 19 07:42:05 2002
-+++ fig2dev/dev/genemf.h Tue Jan 7 20:16:08 2003
-@@ -30,8 +30,10 @@
- #ifndef __USE_MISC
- /* Old compatibility names for C types. */
- typedef unsigned long int ulong;
-+#ifndef __FreeBSD__
- typedef unsigned short int ushort;
- typedef unsigned int uint;
-+#endif
- #endif
-
-
diff --git a/print/transfig/files/patch-fig2dev_dev_gensvg.c b/print/transfig/files/patch-fig2dev_dev_gensvg.c
deleted file mode 100644
index 5bd05c97be8e..000000000000
--- a/print/transfig/files/patch-fig2dev_dev_gensvg.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- fig2dev/dev/gensvg.c.orig Wed Jul 23 16:39:14 2003
-+++ fig2dev/dev/gensvg.c Wed Jul 23 16:39:52 2003
-@@ -692,16 +692,14 @@
- if (t->angle != 0) {
- fprintf (tfp, "<g transform=\"translate(%d,%d) rotate(%d)\" >\n",
- (int) (t->base_x * mag), (int) (t->base_y * mag), degrees (t->angle));
-- fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\"
-- font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
-+ fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\" font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
- rgbColorVal (t->color), family[(int) ceil ((t->font + 1) / 4)],
- (t->font % 2 == 0 ? "normal" : "italic"),
- (t->font % 4 < 2 ? "normal" : "bold"), (int) (ceil (t->size * 12 * mag)),
- anchor[t->type]);
- }
- else
-- fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\"
-- font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
-+ fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\" font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
- (int) (t->base_x * mag), (int) (t->base_y * mag), rgbColorVal (t->color),
- family[(int) ceil ((t->font + 1) / 4)],
- (t->font % 2 == 0 ? "normal" : "italic"),
diff --git a/print/transfig/files/patch-fig2dev_dev_readgif.c b/print/transfig/files/patch-fig2dev_dev_readgif.c
new file mode 100644
index 000000000000..68865cf083f9
--- /dev/null
+++ b/print/transfig/files/patch-fig2dev_dev_readgif.c
@@ -0,0 +1,11 @@
+--- fig2dev/dev/readgif.c.orig Tue Apr 8 14:42:07 2003
++++ fig2dev/dev/readgif.c
+@@ -197,7 +197,7 @@
+ /* make name for temp output file */
+ sprintf(pcxname, "%s/%s%06d.pix", TMPDIR, "xfig-pcx", getpid());
+ /* make command to convert gif to pcx into temp file */
+- sprintf(buf, "giftopnm | ppmtopcx > %s 2> /dev/null", pcxname);
++ sprintf(buf, "giftopnm -quiet | ppmtopcx -quiet > %s", pcxname);
+ if ((giftopcx = popen(buf,"w" )) == 0) {
+ fprintf(stderr,"Cannot open pipe to giftoppm\n");
+ return 0;
diff --git a/print/transfig/files/patch-fig2dev_fig2dev.h b/print/transfig/files/patch-fig2dev_fig2dev.h
index 3f330c164e7e..905831449cea 100644
--- a/print/transfig/files/patch-fig2dev_fig2dev.h
+++ b/print/transfig/files/patch-fig2dev_fig2dev.h
@@ -1,14 +1,6 @@
---- fig2dev/fig2dev.h.orig Thu Dec 19 07:45:28 2002
-+++ fig2dev/fig2dev.h Tue Jan 7 20:08:45 2003
-@@ -22,7 +22,6 @@
- #include <sys/file.h>
- #include <signal.h>
- #include <string.h>
--#include <varargs.h>
- #include <pwd.h>
- #include <errno.h>
- #include <time.h>
-@@ -210,7 +209,7 @@
+--- fig2dev/fig2dev.h.orig Tue Jul 15 09:21:12 2003
++++ fig2dev/fig2dev.h
+@@ -213,7 +213,7 @@
#endif /* MAXPATHLEN */
#endif /* PATH_MAX */
diff --git a/print/transfig/files/patch-transfig_Imakefile b/print/transfig/files/patch-transfig_Imakefile
index 296d2694da02..8f9092efde86 100644
--- a/print/transfig/files/patch-transfig_Imakefile
+++ b/print/transfig/files/patch-transfig_Imakefile
@@ -1,11 +1,11 @@
---- transfig/Imakefile.orig Thu Dec 19 07:44:03 2002
-+++ transfig/Imakefile Fri Jan 10 17:28:18 2003
-@@ -18,7 +18,7 @@
+--- transfig/Imakefile.orig Tue Mar 25 12:52:37 2003
++++ transfig/Imakefile
+@@ -32,7 +32,7 @@
XCOMM \\usepackage{} command for LaTeX2e.
XCOMM The default is to use \\documentstyle{} for LaTeX209.
-XCOMM USELATEX2E = -DLATEX2E
+USELATEX2E = -DLATEX2E
- XCOMM ******* DON'T CHANGE ANYTHIN BELOW THIS POINT *******
+ XCOMM ******* DON'T CHANGE ANYTHING BELOW THIS POINT *******
diff --git a/print/transfig/pkg-descr b/print/transfig/pkg-descr
index 1f0eafe2de09..4deb381e4e82 100644
--- a/print/transfig/pkg-descr
+++ b/print/transfig/pkg-descr
@@ -2,6 +2,9 @@ TransFig is a set of tools for creating TeX documents with graphics
which are portable, in the sense that they can be printed in a wide
variety of environments.
-Drivers currently exist for the following graphics langauges: (E)EPIC
-macros, LaTeX picture environment, PIC, PiCTeX, PostScript, and
-TeXtyl. Fig2dev can be configured with a subset of these drivers
+Drivers currently exist for the following graphics langauges:
+AutoCad slide, BOX, (E)EPIC macros, LaTeX picture environment,
+PIC, PiCTeX, PNG, PostScript, Encapsulated Postscript, GIF,
+IBM-GL, JPEG, PCX, MF (METAFONT), TeXtyl, TIFF, TPIC, XBM (X11
+Bitmap), XPM (X11 Pixmap), and TK (tcl/tk). Fig2dev can be
+configured with a subset of these drivers.