aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-07-19 22:36:00 +0800
committerbapt <bapt@FreeBSD.org>2015-07-19 22:36:00 +0800
commitaa9c9492b02904f1060fef6ac584c7287c211bf5 (patch)
treef169cf3f82bb036a610b94fc037cf9a640b24317
parent018cae3391d74184063aad0c7a8f355463962808 (diff)
downloadfreebsd-ports-gnome-aa9c9492b02904f1060fef6ac584c7287c211bf5.tar.gz
freebsd-ports-gnome-aa9c9492b02904f1060fef6ac584c7287c211bf5.tar.zst
freebsd-ports-gnome-aa9c9492b02904f1060fef6ac584c7287c211bf5.zip
Add 3 new uses
localbase: mostly a non user one which enforce the compiler related flags to lookup in localbase first to find libraries, designed to be used in other USES libarchive: to be used each time one is using libarchive from ports. It is necessary to simplify work for porters dealing with different versions of libarchive from base and different ways libarchive can be linked in base (with libmd and/or libcrypto) only dealing with one libarchive over all the ports tree is easier libedit: enforce using libedit from ports for the same reasons as for libarchive Same things will happen for other base libraries which collides with ports version later.
-rw-r--r--Mk/Uses/libarchive.mk16
-rw-r--r--Mk/Uses/libedit.mk16
-rw-r--r--Mk/Uses/localbase.mk18
3 files changed, 50 insertions, 0 deletions
diff --git a/Mk/Uses/libarchive.mk b/Mk/Uses/libarchive.mk
new file mode 100644
index 000000000000..c2df6b5bbe66
--- /dev/null
+++ b/Mk/Uses/libarchive.mk
@@ -0,0 +1,16 @@
+# $FreeBSD$
+#
+# handle dependency on the libarchive port
+#
+# Feature: libarchive
+# Usage: USES=libarchive
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LIBARCHIVE_MK)
+_INCLUDE_USES_LIBARCHIVE_MK= yes
+.include "${USESDIR}/localbase.mk"
+
+LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
+.endif
diff --git a/Mk/Uses/libedit.mk b/Mk/Uses/libedit.mk
new file mode 100644
index 000000000000..5eb9f3c20248
--- /dev/null
+++ b/Mk/Uses/libedit.mk
@@ -0,0 +1,16 @@
+# $FreeBSD$
+#
+# handle dependency on the libedit port
+#
+# Feature: libedit
+# Usage: USES=libedit
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LIBEDIT_MK)
+_INCLUDE_USES_LIBEDIT_MK= yes
+.include "${USESDIR}/localbase.mk"
+
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
+.endif
diff --git a/Mk/Uses/localbase.mk b/Mk/Uses/localbase.mk
new file mode 100644
index 000000000000..044cfcd11faa
--- /dev/null
+++ b/Mk/Uses/localbase.mk
@@ -0,0 +1,18 @@
+# $FreeBSD$
+#
+# handle enforcing localbase in path
+#
+# Feature: localbase
+# Usage: USES=localbase
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LOCALBASE_MK)
+_INCLUDE_USES_LOCALBASE_MK= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif