aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-02 05:34:19 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-02 05:34:19 +0800
commitab9fe8c4018b15afa9d61f9c391dbe8ed6693426 (patch)
treedb3483a1ac75632a03f6882cde889f98a8f4405e
parent8405285e08d5bea8e7342782af4a0a9690f43425 (diff)
downloadfreebsd-ports-gnome-ab9fe8c4018b15afa9d61f9c391dbe8ed6693426.tar.gz
freebsd-ports-gnome-ab9fe8c4018b15afa9d61f9c391dbe8ed6693426.tar.zst
freebsd-ports-gnome-ab9fe8c4018b15afa9d61f9c391dbe8ed6693426.zip
converters/iconv: unbreak on 12.0 after base r306297
===> ces (all) make[2]: don't know how to make euc-jp.so. Stop Reported by: pkg-fallout
-rw-r--r--converters/iconv/files/patch-ces__Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/converters/iconv/files/patch-ces__Makefile b/converters/iconv/files/patch-ces__Makefile
index 9d6124a84d4a..5c39a6915660 100644
--- a/converters/iconv/files/patch-ces__Makefile
+++ b/converters/iconv/files/patch-ces__Makefile
@@ -9,3 +9,26 @@
INTERNALLIB =
+@@ -27,9 +27,9 @@ ces_builtin.c: ${CHARSETS_C} ${CHARSETS_
+ ${.CURDIR}/../iconv_builtin -mo ${.TARGET} \
+ ${CHARSETS_C} PIC ${CHARSETS_O}
+
+-.SUFFIXES: .so .So
++.SUFFIXES: .so .So .pico
+
+-.So.so:
++.So.so .pico.so:
+ @${LDDESTDIRENV} ${CC} -shared -Wl,-x -o ${.TARGET} \
+ -Wl,-soname,${.TARGET} `lorder ${.ALLSRC} | tsort -q` \
+ ${LDDESTDIR} ${LDADD}
+@@ -41,8 +41,8 @@ beforeinstall:
+ ${INSTALLFLAGS} ${SHLINSTALLFLAGS} ${CHARSETS_SO} \
+ ${DESTDIR}${MODULEDIR}
+
+-CLEANFILES += *.so *.So ces_builtin.c *.lst
++CLEANFILES += *.so *.So *.pico ces_builtin.c *.lst
+
+ .include <bsd.lib.mk>
+
+-.SUFFIXES: .so .So
++.SUFFIXES: .so .So .pico