aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:07:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:07:22 +0800
commitadc68ed10f409cb25460bdd4a84c8216087ec904 (patch)
tree362ec90e94a3bc887e0442d72b2e32a5921d716a
parentcfbb5555b2a6d1b40a60372fa71ab9e6cc194621 (diff)
downloadfreebsd-ports-gnome-adc68ed10f409cb25460bdd4a84c8216087ec904.tar.gz
freebsd-ports-gnome-adc68ed10f409cb25460bdd4a84c8216087ec904.tar.zst
freebsd-ports-gnome-adc68ed10f409cb25460bdd4a84c8216087ec904.zip
- Clarify LICENSE
- Add LICENSE_FILE - Add missing dependency on bash, it installs bash scripts - Fix shebangs - Strip binaries - Fix build with disabled NLS
-rw-r--r--astro/gpsdrive/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 0b634474f38c..4450f86ac0d3 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gpsdrive
PORTVERSION= 2.09
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= astro geography
MASTER_SITES= http://www.gpsdrive.de/packages/ \
LOCAL/beech
@@ -11,11 +11,15 @@ MASTER_SITES= http://www.gpsdrive.de/packages/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= GPS navigation system
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= gmake libtool perl5 pkgconfig
+USES= gmake libtool perl5 pkgconfig shebangfix
+SHEBANG_FILES= src/gpsfetchmap.pl src/geocache2way src/gpssmswatch \
+ src/gpspoint2gpsdrive.pl src/gpsreplay src/wpcvt
USE_GNOME= gtk20
USE_LDCONFIG= yes
@@ -23,12 +27,14 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-garmin
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lgmodule-2.0 -lm
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
.include <bsd.port.options.mk>