aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-11-04 15:26:24 +0800
committerale <ale@FreeBSD.org>2006-11-04 15:26:24 +0800
commitae06834759ea51a830f99c55d73bf227b521e728 (patch)
treefb41581fc9076398a39a8c9a679e1b58bd72cb04
parent01d9ddce3c8ef1d421667261ed40de87ef659c0b (diff)
downloadfreebsd-ports-gnome-ae06834759ea51a830f99c55d73bf227b521e728.tar.gz
freebsd-ports-gnome-ae06834759ea51a830f99c55d73bf227b521e728.tar.zst
freebsd-ports-gnome-ae06834759ea51a830f99c55d73bf227b521e728.zip
Fix connection to ICQ.
Obtained from: KDE SVN repository
-rw-r--r--net-im/kopete/Makefile2
-rw-r--r--net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index a7fbd97fd8a8..df0ae0ca1f1b 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kopete
PORTVERSION= 0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net-im kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/3.5.4/src
diff --git a/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp b/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp
new file mode 100644
index 000000000000..c475926d6372
--- /dev/null
+++ b/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp
@@ -0,0 +1,10 @@
+--- kopete/protocols/oscar/liboscar/client.cpp 2006/08/17 13:37:13
++++ kopete/protocols/oscar/liboscar/client.cpp 2006/10/31 18:48:12
+@@ -340,6 +340,7 @@
+ //we've finished logging in. start the services setup
+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
+ initializeStaticTasks();
++ d->ownStatusTask->go();
+ ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
+ connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
+ ssTask->go( true ); //fire and forget