aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-05-10 15:20:08 +0800
committeryuri <yuri@FreeBSD.org>2018-05-10 15:20:08 +0800
commitb24a6650c730212d9e0ea6c38e7878daa9d0b605 (patch)
treec18ac2aebc01803399aea4aa27278edcfd4275a8
parent643aaa36e010393a79fa94029a48a9e88da0562e (diff)
downloadfreebsd-ports-gnome-b24a6650c730212d9e0ea6c38e7878daa9d0b605.tar.gz
freebsd-ports-gnome-b24a6650c730212d9e0ea6c38e7878daa9d0b605.tar.zst
freebsd-ports-gnome-b24a6650c730212d9e0ea6c38e7878daa9d0b605.zip
math/suitesparse: Unbreak with the option ATLAS=yes
It was an incomplete makefile patching beginning from 5.2.0 update. PR: 210579 227791 Approved by: portmgr (port compliance, infrastructure)
-rw-r--r--math/suitesparse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 1659ee1d1066..863a944b2aa6 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -48,9 +48,9 @@ MAKE_ARGS+= MY_METIS_LIB="-L${LOCALBASE}/lib -lmetis $(LDFLAGS)"
post-patch:
@${RM} -r ${WRKSRC}/metis-5.1.0
@${FIND} -X ${WRKSRC} -type f -name 'Makefile' -or -name '*.mk' | ${XARGS} \
- ${REINPLACE_CMD} -i '' \
+ ${REINPLACE_CMD} \
-e '\|^AR =|s|ar|${AR}|' \
- -e '\|^BLAS =|s|=.*|= ${LDFLAGS} ${BLASLIB}|' \
+ -e '\|^ *BLAS =|s|=.*|= ${LDFLAGS} ${BLASLIB}|' \
-e '\|^CC =|d' \
-e '\|^CFLAGS =|{s|-O[1-9]\{0,1\}||g;s|=|= ${CFLAGS} $${PICFLAG} |;}' \
-e '\|^CHOLMOD_CONFIG =|s|=.*|= ${CHOLMOD_CONFIG}|' \
@@ -67,7 +67,7 @@ post-patch:
-e 's|/usr/local|${LOCALBASE}|g'
@${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
@${FIND} -X ${WRKSRC_SHARED} -type f -name 'Makefile' -or -name '*.mk' | ${XARGS} \
- ${REINPLACE_CMD} -e 's|$$(CFLAGS)|$$(CFLAGS) $$(PICFLAG)|g'
+ ${REINPLACE_CMD} -e 's|$$(CFLAGS)|$$(CFLAGS) $$(PICFLAG)|g'
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} PICFLAG= \