aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-06-29 23:15:08 +0800
committeravilla <avilla@FreeBSD.org>2011-06-29 23:15:08 +0800
commitb2ee12fcaf971ce1d6a0f5252ea6e08c21f9a8d3 (patch)
tree15eee73cc9e7b92bec9974eef93926c71daefc55
parentd679cb8edc996841b1b877aee7b8cc16e8f5113e (diff)
downloadfreebsd-ports-gnome-b2ee12fcaf971ce1d6a0f5252ea6e08c21f9a8d3.tar.gz
freebsd-ports-gnome-b2ee12fcaf971ce1d6a0f5252ea6e08c21f9a8d3.tar.zst
freebsd-ports-gnome-b2ee12fcaf971ce1d6a0f5252ea6e08c21f9a8d3.zip
- Add meta-port for frei0r plugins.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/frei0r-plugins/Makefile42
2 files changed, 43 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bf10c0902135..1310da3c4ef9 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -208,6 +208,7 @@
SUBDIR += freeglut
SUBDIR += freeimage
SUBDIR += frei0r
+ SUBDIR += frei0r-plugins
SUBDIR += frei0r-plugins-gavl
SUBDIR += frei0r-plugins-opencv
SUBDIR += frontline
diff --git a/graphics/frei0r-plugins/Makefile b/graphics/frei0r-plugins/Makefile
new file mode 100644
index 000000000000..3d7772350cbc
--- /dev/null
+++ b/graphics/frei0r-plugins/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: frei0r-plugins
+# Date created: 29 June 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -plugins
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+COMMENT= Frei0r meta-port
+
+RUN_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+
+MASTERDIR= ${.CURDIR}/../frei0r
+NO_BUILD= yes
+PLIST= ${WRKDIR}/PLIST
+
+BUILDING_FREI0R_METAPORT= yes
+
+OPTIONS= GAVL "Install gavl plugins" on \
+ OPENCV "Install OpenCV plugins" on
+
+.include "${MASTERDIR}/Makefile"
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_GAVL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/frei0r-1/rgbparade.so:${PORTSDIR}/graphics/frei0r-plugins-gavl
+.endif
+
+.if !defined(WITHOUT_OPENCV)
+RUN_DEPENDS+= ${LOCALBASE}/lib/frei0r-1/facedetect.so:${PORTSDIR}/graphics/frei0r-plugins-opencv
+.endif
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>