aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-12-12 05:50:01 +0800
committerkris <kris@FreeBSD.org>2004-12-12 05:50:01 +0800
commitb334317f4c0d194fe3f74ca1d110667f70d6ea8b (patch)
tree1c92823df26ffbc4675b30f7c3fd59319e65efdc
parenta8eb4b90a717e90f3143081d8a4d369fcae0c024 (diff)
downloadfreebsd-ports-gnome-b334317f4c0d194fe3f74ca1d110667f70d6ea8b.tar.gz
freebsd-ports-gnome-b334317f4c0d194fe3f74ca1d110667f70d6ea8b.tar.zst
freebsd-ports-gnome-b334317f4c0d194fe3f74ca1d110667f70d6ea8b.zip
BROKEN on 4.x: Does not compile
-rw-r--r--astro/orsa/Makefile8
-rw-r--r--mail/mixmaster/Makefile8
-rw-r--r--math/octave-devel/Makefile4
-rw-r--r--math/octave/Makefile4
-rw-r--r--multimedia/mkvtoolnix/Makefile1
-rw-r--r--science/psi3/Makefile4
-rw-r--r--security/pam_alreadyloggedin/Makefile4
-rw-r--r--sysutils/wmupmon/Makefile8
-rw-r--r--www/mozilla-devel/Makefile4
-rw-r--r--www/seamonkey/Makefile4
-rw-r--r--www/seamonkey2/Makefile4
11 files changed, 50 insertions, 3 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index d1bbfc68792a..78057467654f 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -26,4 +26,10 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/mixmaster/Makefile b/mail/mixmaster/Makefile
index 906909a3971e..c78f7710c32f 100644
--- a/mail/mixmaster/Makefile
+++ b/mail/mixmaster/Makefile
@@ -38,6 +38,12 @@ WRKDIST= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MIXMASTER_FILES= ${WRKDIST}/conf/* ${WRKDIST}/README ${WRKDIR}/allpingers.txt
MIXMASTER_SCRIPTS= ${WRKDIR}/mixmaster-update.pl
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
@${RM} ${WRKSRC}/../conf/mix.cfg.orig
@@ -54,4 +60,4 @@ do-install:
${INSTALL_DATA} ${MIXMASTER_FILES} ${PREFIX}/share/examples/mixmaster
${INSTALL_MAN} ${WRKDIST}/mix.1 ${PREFIX}/man/man1/mixmaster.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index f0e8c59870d1..d76776c4f612 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -24,6 +24,10 @@ USE_PERL5_BUILD=yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if ${PORTOBJFORMAT} == "elf"
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
.else
diff --git a/math/octave/Makefile b/math/octave/Makefile
index f0e8c59870d1..d76776c4f612 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -24,6 +24,10 @@ USE_PERL5_BUILD=yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if ${PORTOBJFORMAT} == "elf"
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
.else
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 3cb716048d15..54cfb0f2416b 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -47,6 +47,7 @@ BROKEN= "Does not compile on sparc64"
.endif
.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
CFLAGS+= -DNO_WSTRING
.endif
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 782ffe00ee31..edaac76e1719 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -41,6 +41,10 @@ CONFIGURE_ARGS= --with-cc=${CC} \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
diff --git a/security/pam_alreadyloggedin/Makefile b/security/pam_alreadyloggedin/Makefile
index 7899b9d2d4cb..c4089d1e7db8 100644
--- a/security/pam_alreadyloggedin/Makefile
+++ b/security/pam_alreadyloggedin/Makefile
@@ -19,6 +19,10 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(NOPROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
diff --git a/sysutils/wmupmon/Makefile b/sysutils/wmupmon/Makefile
index 0763390a61dc..92a348da0614 100644
--- a/sysutils/wmupmon/Makefile
+++ b/sysutils/wmupmon/Makefile
@@ -23,4 +23,10 @@ CONFIGURE_ARGS= --program-prefix=""
MAN1= wmupmon.1
PLIST_FILES= bin/wmupmon
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index cb1eeec7f61a..9bb8bf51cc9f 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -114,6 +114,10 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
BROKEN= "Does not compile on ia64 or alpha"
.endif
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(WITH_CAIRO_RENDER)
LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index cb1eeec7f61a..9bb8bf51cc9f 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -114,6 +114,10 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
BROKEN= "Does not compile on ia64 or alpha"
.endif
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(WITH_CAIRO_RENDER)
LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index cb1eeec7f61a..9bb8bf51cc9f 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -114,6 +114,10 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
BROKEN= "Does not compile on ia64 or alpha"
.endif
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(WITH_CAIRO_RENDER)
LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo