aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-03-19 19:58:53 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-03-19 19:58:53 +0800
commitb35581c5c5a5c36945b2df718bda052d8e65560b (patch)
treeecd374e62be58533c6668170f74a34bb39fcc38a
parentf8631a8c4bdd89b2c41740e4902080d1687ba85a (diff)
downloadfreebsd-ports-gnome-b35581c5c5a5c36945b2df718bda052d8e65560b.tar.gz
freebsd-ports-gnome-b35581c5c5a5c36945b2df718bda052d8e65560b.tar.zst
freebsd-ports-gnome-b35581c5c5a5c36945b2df718bda052d8e65560b.zip
Using PKGREPOSITORY is more correct here since PKGFILE uses it
With hat: portmgr
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 29c2be44b95c..695291c3ddc8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3764,7 +3764,7 @@ do-package: ${TMPPLIST}
_LATE_PKG_ARGS="$${_LATE_PKG_ARGS} -D ${PKGMESSAGE}"; \
fi; \
if ${PKG_CMD} -S ${STAGEDIR} ${PKG_ARGS} ${WRKDIR}/${PKGNAME}${PKG_SUFX}; then \
- if [ -d ${PACKAGES} -a -w ${PACKAGES} ]; then \
+ if [ -d ${PKGREPOSITORY} -a -w ${PKGREPOSITORY} ]; then \
${LN} -f ${WRKDIR}/${PKGNAME}${PKG_SUFX} ${PKGFILE} 2>/dev/null || \
${CP} -af ${WRKDIR}/${PKGNAME}${PKG_SUFX} ${PKGFILE}; \
cd ${.CURDIR} && eval ${MAKE} package-links; \