aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:49:29 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:49:29 +0800
commitb4754decdaee54e05cabf3918e9d97a215e1dc7a (patch)
tree86db8b962bcc64bf864604a8afdec240e5f73f8e
parent3d949ca7e84a5fd798963ae70d2aef60c904d633 (diff)
downloadfreebsd-ports-gnome-b4754decdaee54e05cabf3918e9d97a215e1dc7a.tar.gz
freebsd-ports-gnome-b4754decdaee54e05cabf3918e9d97a215e1dc7a.tar.zst
freebsd-ports-gnome-b4754decdaee54e05cabf3918e9d97a215e1dc7a.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - add license (BSD) - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES PR: 173024 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
-rw-r--r--www/trac-xmlrpc/Makefile20
-rw-r--r--www/trac-xmlrpc/pkg-plist1
2 files changed, 8 insertions, 13 deletions
diff --git a/www/trac-xmlrpc/Makefile b/www/trac-xmlrpc/Makefile
index 3a4960df7ca6..e8b2c1c1d264 100644
--- a/www/trac-xmlrpc/Makefile
+++ b/www/trac-xmlrpc/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-xmlrpc
-# Date created: May 18 2007
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= xmlrpc
PORTVERSION= 1.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= http://shuqun.com/files/ \
LOCAL/glarkin
@@ -17,14 +13,14 @@ DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Provides an xml rpc interface to Trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+LICENSE= BSD
+
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/${PORTNAME}plugin
-NO_BUILD= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracXMLRPC
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/www/trac-xmlrpc/pkg-plist b/www/trac-xmlrpc/pkg-plist
deleted file mode 100644
index 70bae0049e44..000000000000
--- a/www/trac-xmlrpc/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracXMLRPC-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg