aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-25 21:15:14 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-25 21:15:14 +0800
commitb484a9f2d970a4da038f8b1cdd59b94cdb79cd46 (patch)
tree5307e7be7567dc831ccd8ad3f77077abd21cffd7
parent930a614ef8a3a5676e3338761b81f9942a02376d (diff)
downloadfreebsd-ports-gnome-b484a9f2d970a4da038f8b1cdd59b94cdb79cd46.tar.gz
freebsd-ports-gnome-b484a9f2d970a4da038f8b1cdd59b94cdb79cd46.tar.zst
freebsd-ports-gnome-b484a9f2d970a4da038f8b1cdd59b94cdb79cd46.zip
- Unbreak build
- Add LICENSE Approved by: portmgr blanket
-rw-r--r--www/ctemplate/Makefile4
-rw-r--r--www/ctemplate/files/patch-src_h2ap.ll11
-rw-r--r--www/ctemplate/files/patch-src_htpl__driver.h11
3 files changed, 23 insertions, 3 deletions
diff --git a/www/ctemplate/Makefile b/www/ctemplate/Makefile
index e77ac1d66729..48372e4e909e 100644
--- a/www/ctemplate/Makefile
+++ b/www/ctemplate/Makefile
@@ -9,9 +9,7 @@ MASTER_SITES= SF
MAINTAINER= ap@page2rss.com
COMMENT= Template system for C
-BROKEN_aarch64= fails to compile: assigning to char * from incompatible type const char *
-BROKEN_armv6= fails to compile: assigning to char * from incompatible type const char *
-BROKEN_armv7= fails to compile: assigning to char * from incompatible type const char *
+LICENSE= NONE
USES= gmake
GNU_CONFIGURE= yes
diff --git a/www/ctemplate/files/patch-src_h2ap.ll b/www/ctemplate/files/patch-src_h2ap.ll
new file mode 100644
index 000000000000..edb6f1f2b3f2
--- /dev/null
+++ b/www/ctemplate/files/patch-src_h2ap.ll
@@ -0,0 +1,11 @@
+--- src/h2ap.ll.orig 2017-12-21 21:01:19 UTC
++++ src/h2ap.ll
+@@ -37,7 +37,7 @@
+ #include "ff_driver.hh"
+
+ char* tplargs=0;
+-const char* funcname=0;
++char* funcname=0;
+ const char* funcprefix="tpl_";
+ FILE* hout=0;
+
diff --git a/www/ctemplate/files/patch-src_htpl__driver.h b/www/ctemplate/files/patch-src_htpl__driver.h
new file mode 100644
index 000000000000..d04aaa0dc97e
--- /dev/null
+++ b/www/ctemplate/files/patch-src_htpl__driver.h
@@ -0,0 +1,11 @@
+--- src/htpl_driver.h.orig 2008-04-15 23:08:27 UTC
++++ src/htpl_driver.h
+@@ -40,7 +40,7 @@ const char *getprogname(void);
+ #endif
+
+ extern char* tplargs;
+-const extern char* funcname;
++extern char* funcname;
+ extern const char* funcprefix;
+
+ class htpl_driver {