aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-30 00:37:59 +0800
committerrafan <rafan@FreeBSD.org>2008-03-30 00:37:59 +0800
commitb6fabfc58c45e637d71408d43d52468645a919a0 (patch)
tree45b2848908753fbd8f64766987f4cd805bfeb52f
parent1e386c3225332851ac92e5c2a9359caaedabf178 (diff)
downloadfreebsd-ports-gnome-b6fabfc58c45e637d71408d43d52468645a919a0.tar.gz
freebsd-ports-gnome-b6fabfc58c45e637d71408d43d52468645a919a0.tar.zst
freebsd-ports-gnome-b6fabfc58c45e637d71408d43d52468645a919a0.zip
- Update the supported languages list in comment
- All supported language except lua can be found by configure script, so add proper instructions to let configure finds our lua installation. This fixes lua support. Tested by: Vlad GALU <dudu at dudu.ro>
-rw-r--r--devel/swig13/Makefile18
-rw-r--r--devel/swig20/Makefile18
2 files changed, 28 insertions, 8 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 41a13cc6916c..8b1cc1349d4d 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -19,19 +19,29 @@ USE_AUTOTOOLS= autoconf:261:env libtool:15
VER= ${PORTVERSION:R}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# Supported languages: guile perl php4 python ruby tcl ocaml pike java csharp
-# allegrocl modula3 chicken
+# Supported languages: allegrocl c# clisp chicken guile java lua ocaml perl
+# php pike python R ruby tcl
WRKSRC= ${WRKDIR}/${DISTNAME}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC -DPIC"
ALL_TARGET= swig
PLIST_SUB+= VER="${VER}"
+WANT_LUA= yes
+WANT_LUA_VER= 5.0+
+
.include <bsd.port.pre.mk>
+.if ${HAVE_LUA:Mlua-5.*} != ""
+USE_LUA= yes
+LUA_COMPS= lua:build
+CONFIGURE_ARGS+=--with-lua=${LUA_BINDIR}/lua \
+ --with-luaincl=${LUA_INCDIR} \
+ --with-lualib=${LUA_LIBDIR}
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/; \
- s|$$RUBY |${RUBY} |; \
+ ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |; \
s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 41a13cc6916c..8b1cc1349d4d 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -19,19 +19,29 @@ USE_AUTOTOOLS= autoconf:261:env libtool:15
VER= ${PORTVERSION:R}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# Supported languages: guile perl php4 python ruby tcl ocaml pike java csharp
-# allegrocl modula3 chicken
+# Supported languages: allegrocl c# clisp chicken guile java lua ocaml perl
+# php pike python R ruby tcl
WRKSRC= ${WRKDIR}/${DISTNAME}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC -DPIC"
ALL_TARGET= swig
PLIST_SUB+= VER="${VER}"
+WANT_LUA= yes
+WANT_LUA_VER= 5.0+
+
.include <bsd.port.pre.mk>
+.if ${HAVE_LUA:Mlua-5.*} != ""
+USE_LUA= yes
+LUA_COMPS= lua:build
+CONFIGURE_ARGS+=--with-lua=${LUA_BINDIR}/lua \
+ --with-luaincl=${LUA_INCDIR} \
+ --with-lualib=${LUA_LIBDIR}
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/; \
- s|$$RUBY |${RUBY} |; \
+ ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |; \
s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \