aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-01-09 14:05:52 +0800
committerlioux <lioux@FreeBSD.org>2003-01-09 14:05:52 +0800
commitb81845d6f5391d269928654d5173eade169b0fb7 (patch)
tree017398ffdada0fe2a3d2a9a2531c361f18f4d938
parenta36285288d279faf1d8664496feeaf8543fd9ba0 (diff)
downloadfreebsd-ports-gnome-b81845d6f5391d269928654d5173eade169b0fb7.tar.gz
freebsd-ports-gnome-b81845d6f5391d269928654d5173eade169b0fb7.tar.zst
freebsd-ports-gnome-b81845d6f5391d269928654d5173eade169b0fb7.zip
New port ocaml-jabbr version 0.0.20021124: XML Messaging and Presence
Protocol a.k.a. Jabber for Objective Caml
-rw-r--r--net-im/ocaml-jabbr/Makefile54
-rw-r--r--net-im/ocaml-jabbr/distinfo1
-rw-r--r--net-im/ocaml-jabbr/pkg-comment1
-rw-r--r--net-im/ocaml-jabbr/pkg-descr14
-rw-r--r--net-im/ocaml-jabbr/pkg-plist54
-rw-r--r--net/Makefile1
-rw-r--r--net/ocaml-jabbr/Makefile54
-rw-r--r--net/ocaml-jabbr/distinfo1
-rw-r--r--net/ocaml-jabbr/pkg-comment1
-rw-r--r--net/ocaml-jabbr/pkg-descr14
-rw-r--r--net/ocaml-jabbr/pkg-plist54
11 files changed, 249 insertions, 0 deletions
diff --git a/net-im/ocaml-jabbr/Makefile b/net-im/ocaml-jabbr/Makefile
new file mode 100644
index 000000000000..32ef8badbede
--- /dev/null
+++ b/net-im/ocaml-jabbr/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ocaml jabbr
+# Date created: Thu Jan 9 05:59:43 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jabbr
+PORTVERSION= 0.0.${DATE_VERSION}
+CATEGORIES= net
+MASTER_SITES= http://mikelin.mit.edu/xmpp/jabbr/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= jabbr
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
+ ${LOCALBASE}/lib/ocaml/yaxpo.cma:${PORTSDIR}/textproc/ocaml-yaxpo
+
+# depend when building as well
+BUILD_DEPENDS+= ${RUN_DEPENDS}
+
+USE_REINPLACE= yes
+
+DATE_VERSION= 20021124
+
+post-configure:
+# PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|' \
+ ${WRKSRC}/Makefile
+
+post-build:
+.ifndef(NOPORTDOCS)
+ @cd ${WRKSRC} && ${MAKE} doc
+.endif
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp -f |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/ocaml-jabbr/distinfo b/net-im/ocaml-jabbr/distinfo
new file mode 100644
index 000000000000..78ced663b796
--- /dev/null
+++ b/net-im/ocaml-jabbr/distinfo
@@ -0,0 +1 @@
+MD5 (jabbr.tar.gz) = 904e15ceb05681f563894151d819ef07
diff --git a/net-im/ocaml-jabbr/pkg-comment b/net-im/ocaml-jabbr/pkg-comment
new file mode 100644
index 000000000000..6acefa1540ec
--- /dev/null
+++ b/net-im/ocaml-jabbr/pkg-comment
@@ -0,0 +1 @@
+XML Messaging and Presence Protocol a.k.a. Jabber for Objective Caml
diff --git a/net-im/ocaml-jabbr/pkg-descr b/net-im/ocaml-jabbr/pkg-descr
new file mode 100644
index 000000000000..d2b134daabe6
--- /dev/null
+++ b/net-im/ocaml-jabbr/pkg-descr
@@ -0,0 +1,14 @@
+[ excerpt from developer's www site ]
+
+Jabbr is an OCaml library for the XML Messaging and Presence Protocol,
+more commonly known as Jabber, based on my Yaxpo reentrant XML
+parser. Jabbr provides basic XML stream and authentication services
+based on a clean state machine abstraction which imposes minimal
+constraints on the underlying I/O mechanisms used by the driver
+program. It currently does not provide automated support for
+higher-level XMPP abstractions like presence and roster management.
+
+In addition to Yaxpo, Jabbr requires Xavier Leroy's Cryptokit
+library, which provides SHA-1 hash support for authentication.
+
+WWW: http://mikelin.mit.edu/xmpp/jabbr/
diff --git a/net-im/ocaml-jabbr/pkg-plist b/net-im/ocaml-jabbr/pkg-plist
new file mode 100644
index 000000000000..ad02d0cd737d
--- /dev/null
+++ b/net-im/ocaml-jabbr/pkg-plist
@@ -0,0 +1,54 @@
+lib/ocaml/auth.cmi
+lib/ocaml/jabber.cmi
+lib/ocaml/jabber_sync.a
+lib/ocaml/jabber_sync.cma
+lib/ocaml/jabber_sync.cmi
+lib/ocaml/jabber_sync.cmxa
+lib/ocaml/jabbersm.cmi
+lib/ocaml/jabbr.a
+lib/ocaml/jabbr.cma
+lib/ocaml/jabbr.cmxa
+lib/ocaml/xmlstream.cmi
+%%PORTDOCS%%share/doc/jabbr/Auth.auth_machine.html
+%%PORTDOCS%%share/doc/jabbr/Auth.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.iq.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.message.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.packet_base.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.presence.html
+%%PORTDOCS%%share/doc/jabbr/Jabber_sync.html
+%%PORTDOCS%%share/doc/jabbr/Jabber_sync.session.html
+%%PORTDOCS%%share/doc/jabbr/Jabbersm.html
+%%PORTDOCS%%share/doc/jabbr/Jabbersm.state_machine.html
+%%PORTDOCS%%share/doc/jabbr/Jid.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.xml_stream_reader.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.xml_stream_writer.html
+%%PORTDOCS%%share/doc/jabbr/index.html
+%%PORTDOCS%%share/doc/jabbr/index_attributes.html
+%%PORTDOCS%%share/doc/jabbr/index_class_types.html
+%%PORTDOCS%%share/doc/jabbr/index_classes.html
+%%PORTDOCS%%share/doc/jabbr/index_exceptions.html
+%%PORTDOCS%%share/doc/jabbr/index_methods.html
+%%PORTDOCS%%share/doc/jabbr/index_module_types.html
+%%PORTDOCS%%share/doc/jabbr/index_modules.html
+%%PORTDOCS%%share/doc/jabbr/index_types.html
+%%PORTDOCS%%share/doc/jabbr/index_values.html
+%%PORTDOCS%%share/doc/jabbr/style.css
+%%PORTDOCS%%share/doc/jabbr/type_Auth.auth_machine.html
+%%PORTDOCS%%share/doc/jabbr/type_Auth.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.iq.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.message.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.packet_base.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.presence.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber_sync.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber_sync.session.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabbersm.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabbersm.state_machine.html
+%%PORTDOCS%%share/doc/jabbr/type_Jid.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.xml_stream_reader.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.xml_stream_writer.html
+%%PORTDOCS%%@dirrm share/doc/jabbr
+@unexec rmdir %D/lib/ocaml 2>/dev/null || true
diff --git a/net/Makefile b/net/Makefile
index b5ee9afef886..e96451bfe454 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -335,6 +335,7 @@
SUBDIR += nttcp
SUBDIR += nylon
SUBDIR += obnc
+ SUBDIR += ocaml-jabbr
SUBDIR += odsclient
SUBDIR += ohphone
SUBDIR += openam
diff --git a/net/ocaml-jabbr/Makefile b/net/ocaml-jabbr/Makefile
new file mode 100644
index 000000000000..32ef8badbede
--- /dev/null
+++ b/net/ocaml-jabbr/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ocaml jabbr
+# Date created: Thu Jan 9 05:59:43 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jabbr
+PORTVERSION= 0.0.${DATE_VERSION}
+CATEGORIES= net
+MASTER_SITES= http://mikelin.mit.edu/xmpp/jabbr/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= jabbr
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
+ ${LOCALBASE}/lib/ocaml/yaxpo.cma:${PORTSDIR}/textproc/ocaml-yaxpo
+
+# depend when building as well
+BUILD_DEPENDS+= ${RUN_DEPENDS}
+
+USE_REINPLACE= yes
+
+DATE_VERSION= 20021124
+
+post-configure:
+# PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|' \
+ ${WRKSRC}/Makefile
+
+post-build:
+.ifndef(NOPORTDOCS)
+ @cd ${WRKSRC} && ${MAKE} doc
+.endif
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp -f |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ocaml-jabbr/distinfo b/net/ocaml-jabbr/distinfo
new file mode 100644
index 000000000000..78ced663b796
--- /dev/null
+++ b/net/ocaml-jabbr/distinfo
@@ -0,0 +1 @@
+MD5 (jabbr.tar.gz) = 904e15ceb05681f563894151d819ef07
diff --git a/net/ocaml-jabbr/pkg-comment b/net/ocaml-jabbr/pkg-comment
new file mode 100644
index 000000000000..6acefa1540ec
--- /dev/null
+++ b/net/ocaml-jabbr/pkg-comment
@@ -0,0 +1 @@
+XML Messaging and Presence Protocol a.k.a. Jabber for Objective Caml
diff --git a/net/ocaml-jabbr/pkg-descr b/net/ocaml-jabbr/pkg-descr
new file mode 100644
index 000000000000..d2b134daabe6
--- /dev/null
+++ b/net/ocaml-jabbr/pkg-descr
@@ -0,0 +1,14 @@
+[ excerpt from developer's www site ]
+
+Jabbr is an OCaml library for the XML Messaging and Presence Protocol,
+more commonly known as Jabber, based on my Yaxpo reentrant XML
+parser. Jabbr provides basic XML stream and authentication services
+based on a clean state machine abstraction which imposes minimal
+constraints on the underlying I/O mechanisms used by the driver
+program. It currently does not provide automated support for
+higher-level XMPP abstractions like presence and roster management.
+
+In addition to Yaxpo, Jabbr requires Xavier Leroy's Cryptokit
+library, which provides SHA-1 hash support for authentication.
+
+WWW: http://mikelin.mit.edu/xmpp/jabbr/
diff --git a/net/ocaml-jabbr/pkg-plist b/net/ocaml-jabbr/pkg-plist
new file mode 100644
index 000000000000..ad02d0cd737d
--- /dev/null
+++ b/net/ocaml-jabbr/pkg-plist
@@ -0,0 +1,54 @@
+lib/ocaml/auth.cmi
+lib/ocaml/jabber.cmi
+lib/ocaml/jabber_sync.a
+lib/ocaml/jabber_sync.cma
+lib/ocaml/jabber_sync.cmi
+lib/ocaml/jabber_sync.cmxa
+lib/ocaml/jabbersm.cmi
+lib/ocaml/jabbr.a
+lib/ocaml/jabbr.cma
+lib/ocaml/jabbr.cmxa
+lib/ocaml/xmlstream.cmi
+%%PORTDOCS%%share/doc/jabbr/Auth.auth_machine.html
+%%PORTDOCS%%share/doc/jabbr/Auth.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.iq.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.message.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.packet_base.html
+%%PORTDOCS%%share/doc/jabbr/Jabber.presence.html
+%%PORTDOCS%%share/doc/jabbr/Jabber_sync.html
+%%PORTDOCS%%share/doc/jabbr/Jabber_sync.session.html
+%%PORTDOCS%%share/doc/jabbr/Jabbersm.html
+%%PORTDOCS%%share/doc/jabbr/Jabbersm.state_machine.html
+%%PORTDOCS%%share/doc/jabbr/Jid.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.xml_stream_reader.html
+%%PORTDOCS%%share/doc/jabbr/Xmlstream.xml_stream_writer.html
+%%PORTDOCS%%share/doc/jabbr/index.html
+%%PORTDOCS%%share/doc/jabbr/index_attributes.html
+%%PORTDOCS%%share/doc/jabbr/index_class_types.html
+%%PORTDOCS%%share/doc/jabbr/index_classes.html
+%%PORTDOCS%%share/doc/jabbr/index_exceptions.html
+%%PORTDOCS%%share/doc/jabbr/index_methods.html
+%%PORTDOCS%%share/doc/jabbr/index_module_types.html
+%%PORTDOCS%%share/doc/jabbr/index_modules.html
+%%PORTDOCS%%share/doc/jabbr/index_types.html
+%%PORTDOCS%%share/doc/jabbr/index_values.html
+%%PORTDOCS%%share/doc/jabbr/style.css
+%%PORTDOCS%%share/doc/jabbr/type_Auth.auth_machine.html
+%%PORTDOCS%%share/doc/jabbr/type_Auth.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.iq.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.message.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.packet_base.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber.presence.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber_sync.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabber_sync.session.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabbersm.html
+%%PORTDOCS%%share/doc/jabbr/type_Jabbersm.state_machine.html
+%%PORTDOCS%%share/doc/jabbr/type_Jid.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.xml_stream_reader.html
+%%PORTDOCS%%share/doc/jabbr/type_Xmlstream.xml_stream_writer.html
+%%PORTDOCS%%@dirrm share/doc/jabbr
+@unexec rmdir %D/lib/ocaml 2>/dev/null || true