aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-06-22 18:49:16 +0800
committerrobak <robak@FreeBSD.org>2014-06-22 18:49:16 +0800
commitbb7bb5e89f4a56366c3cfc201eea55bdd884ea15 (patch)
tree5346926058c5eff4e2759418ab6a5900d900fcaa
parente7a4eb9e29e66ac9f7798911ff902349859d865e (diff)
downloadfreebsd-ports-gnome-bb7bb5e89f4a56366c3cfc201eea55bdd884ea15.tar.gz
freebsd-ports-gnome-bb7bb5e89f4a56366c3cfc201eea55bdd884ea15.tar.zst
freebsd-ports-gnome-bb7bb5e89f4a56366c3cfc201eea55bdd884ea15.zip
sysutils/tartarus: new port
Tartarus is a new port of wrappers around common unix tools for simplified backup utility, as submitted in PR 191077 with my fixes and testing. PR: 191077 Submitted by: Juraj Lutter Reviewed by: marino (mentor), mat Approved by: marino (mentor)
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/tartarus/Makefile28
-rw-r--r--sysutils/tartarus/distinfo2
-rw-r--r--sysutils/tartarus/pkg-descr14
-rw-r--r--sysutils/tartarus/pkg-plist14
5 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6ff3d729e693..dc1d7a26d360 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -910,6 +910,7 @@
SUBDIR += sysvbanner
SUBDIR += tai64nfrac
SUBDIR += tarsnap
+ SUBDIR += tartarus
SUBDIR += tbku
SUBDIR += tclsyslog
SUBDIR += tcplist
diff --git a/sysutils/tartarus/Makefile b/sysutils/tartarus/Makefile
new file mode 100644
index 000000000000..9004070ca30e
--- /dev/null
+++ b/sysutils/tartarus/Makefile
@@ -0,0 +1,28 @@
+# Created by: Juraj Lutter <otis@sk.FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tartarus
+PORTVERSION= 0.9.8
+CATEGORIES= sysutils
+MASTER_SITES= http://wertarbyte.de/tartarus/ \
+ http://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
+
+MAINTAINER= otis@sk.FreeBSD.org
+COMMENT= Wrappers around common unix tools for simplified backup solution
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+USES= gmake perl5 shebangfix tar:bzip2
+SHEBANG_FILES= ${WRKSRC}/bin/*
+
+do-install:
+ cd ${WRKSRC}/bin; ${INSTALL_SCRIPT} charon charon.ftp charon.local \
+ charon.pipe orpheus tartarus ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/lib; ${COPYTREE_SHARE} Tartarus ${STAGEDIR}${SITE_PERL}
+ cd ${WRKSRC}/man; ${INSTALL_MAN} charon.1 charon.ftp.1 charon.local.1 \
+ charon.pipe.1 tartarus.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/tartarus/distinfo b/sysutils/tartarus/distinfo
new file mode 100644
index 000000000000..a6d54c899ca6
--- /dev/null
+++ b/sysutils/tartarus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tartarus-0.9.8.tar.bz2) = cfd3158974e4c331bebf5b9fbf51eb3f884a71d60eaf2c82e8856a150691bcef
+SIZE (tartarus-0.9.8.tar.bz2) = 28474
diff --git a/sysutils/tartarus/pkg-descr b/sysutils/tartarus/pkg-descr
new file mode 100644
index 000000000000..a3862f8aeba5
--- /dev/null
+++ b/sysutils/tartarus/pkg-descr
@@ -0,0 +1,14 @@
+Tartarus provides a nice wrapper around basic Unix tools such as tar, find and
+curl (well, that's not that basic) to provide a seamless backup solution,
+aimed at automatic gathering and backup.
+
+It has the ability to do full as well as incremental backups and is published
+by Stefan Tomanek under the rules of the GPL.
+
+Instead of relying on single usage backup scripts or complicated command lines,
+tartarus reads its configuration from easily managable configuration files.
+It can store gathered data in regular files, or upload the backup directly (on
+the fly) to an FTP server. For more specific usage scenarios, custom methods
+can also be defined within the config file.
+
+WWW: http://wertarbyte.de/tartarus.shtml
diff --git a/sysutils/tartarus/pkg-plist b/sysutils/tartarus/pkg-plist
new file mode 100644
index 000000000000..2a5f1c10908f
--- /dev/null
+++ b/sysutils/tartarus/pkg-plist
@@ -0,0 +1,14 @@
+bin/charon
+bin/charon.ftp
+bin/charon.local
+bin/charon.pipe
+bin/orpheus
+bin/tartarus
+man/man1/charon.1.gz
+man/man1/charon.ftp.1.gz
+man/man1/charon.local.1.gz
+man/man1/charon.pipe.1.gz
+man/man1/tartarus.1.gz
+%%SITE_PERL%%/Tartarus/Charon/Filter.pm
+@dirrmtry %%SITE_PERL%%/Tartarus/Charon
+@dirrmtry %%SITE_PERL%%/Tartarus