aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-07 14:20:27 +0800
committermiwi <miwi@FreeBSD.org>2009-07-07 14:20:27 +0800
commitbbf09ba10d721209d077291a8f74e48f7745dba6 (patch)
tree3a03ccf28e25f724d6f959f8bcd7a538c609b479
parent97fe6f5ff21519fdfc558129091382303f8e6193 (diff)
downloadfreebsd-ports-gnome-bbf09ba10d721209d077291a8f74e48f7745dba6.tar.gz
freebsd-ports-gnome-bbf09ba10d721209d077291a8f74e48f7745dba6.tar.zst
freebsd-ports-gnome-bbf09ba10d721209d077291a8f74e48f7745dba6.zip
This plugin renders HTML e-mail using the WebKit library.
WWW: http://www.claws-mail.org/plugins.php PR: ports/136381 Submitted by: Pawel Pekala <c0rn at o2.pl>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-fancy/Makefile41
-rw-r--r--mail/claws-mail-fancy/distinfo3
-rw-r--r--mail/claws-mail-fancy/files/patch-fix-double-free-crash12
-rw-r--r--mail/claws-mail-fancy/pkg-descr3
-rw-r--r--mail/claws-mail-fancy/pkg-plist12
6 files changed, 72 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d263e74909cf..58f3157f85b3 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -49,6 +49,7 @@
SUBDIR += claws-mail-att_remover
SUBDIR += claws-mail-attach_warner
SUBDIR += claws-mail-cachesaver
+ SUBDIR += claws-mail-fancy
SUBDIR += claws-mail-fetchinfo
SUBDIR += claws-mail-gtkhtml2_viewer
SUBDIR += claws-mail-mailmbox
diff --git a/mail/claws-mail-fancy/Makefile b/mail/claws-mail-fancy/Makefile
new file mode 100644
index 000000000000..a579c44e5306
--- /dev/null
+++ b/mail/claws-mail-fancy/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: claws-mail-fancy
+# Date created: 2009-07-06
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fancy
+PORTVERSION= 0.9.7
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
+PKGNAMEPREFIX= claws-mail-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Webkit based HTML renderer plugin for claws-mail
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ webkit:${PORTSDIR}/www/webkit-gtk2
+BUILD_DEPENDS= claws-mail>=3.7.2:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.7.2:${PORTSDIR}/mail/claws-mail
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:262
+USE_ICONV= yes
+USE_GNOME= gtk20
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-fancy/distinfo b/mail/claws-mail-fancy/distinfo
new file mode 100644
index 000000000000..eb547d4b8d0a
--- /dev/null
+++ b/mail/claws-mail-fancy/distinfo
@@ -0,0 +1,3 @@
+MD5 (fancy-0.9.7.tar.gz) = 5e3d83ebf097cbd67fcaee4faf2b4fb9
+SHA256 (fancy-0.9.7.tar.gz) = 763abd412b79968be793ae4dca64f3b9cfb451a10c2f7f3cd47b33daf9e0dc00
+SIZE (fancy-0.9.7.tar.gz) = 354959
diff --git a/mail/claws-mail-fancy/files/patch-fix-double-free-crash b/mail/claws-mail-fancy/files/patch-fix-double-free-crash
new file mode 100644
index 000000000000..4c16135257a9
--- /dev/null
+++ b/mail/claws-mail-fancy/files/patch-fix-double-free-crash
@@ -0,0 +1,12 @@
+--- src/fancy_viewer.c.orig 2009-07-06 15:39:11.000000000 +0200
++++ src/fancy_viewer.c 2009-07-06 15:40:33.000000000 +0200
+@@ -275,8 +275,7 @@
+ webkit_web_view_open(viewer->view, "about:blank");
+ debug_print("fancy_clear_viewer\n");
+ viewer->to_load = NULL;
+- if(viewer->cur_link)
+- g_free(viewer->cur_link);
++
+ vadj = gtk_scrolled_window_get_vadjustment(GTK_SCROLLED_WINDOW(viewer->scrollwin));
+ vadj->value = 0.0;
+ g_signal_emit_by_name(G_OBJECT(vadj), "value-changed", 0);
diff --git a/mail/claws-mail-fancy/pkg-descr b/mail/claws-mail-fancy/pkg-descr
new file mode 100644
index 000000000000..72664223a5be
--- /dev/null
+++ b/mail/claws-mail-fancy/pkg-descr
@@ -0,0 +1,3 @@
+This plugin renders HTML e-mail using the WebKit library.
+
+WWW: http://www.claws-mail.org/plugins.php
diff --git a/mail/claws-mail-fancy/pkg-plist b/mail/claws-mail-fancy/pkg-plist
new file mode 100644
index 000000000000..6cc02b6f6a53
--- /dev/null
+++ b/mail/claws-mail-fancy/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+lib/claws-mail/plugins/fancy.so
+lib/claws-mail/plugins/fancy.la
+lib/claws-mail/plugins/fancy.a
+%%NLS%%share/locale/cs/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/es/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/id/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/it/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/fancy.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/fancy.mo