aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2002-01-19 12:28:19 +0800
committersf <sf@FreeBSD.org>2002-01-19 12:28:19 +0800
commitbc23f1f9bb7ca5d7c513763192c9d2f9b06bc22e (patch)
tree3d80a0632da072acbfff79f4e2ee8df4d4edd864
parent521b997b262d3f93023b3bfc858b4caa8df5dfab (diff)
downloadfreebsd-ports-gnome-bc23f1f9bb7ca5d7c513763192c9d2f9b06bc22e.tar.gz
freebsd-ports-gnome-bc23f1f9bb7ca5d7c513763192c9d2f9b06bc22e.tar.zst
freebsd-ports-gnome-bc23f1f9bb7ca5d7c513763192c9d2f9b06bc22e.zip
support CFLAGS/CXXFLAGS properly.
PR: 34026 Submitted by: KATO Tsuguru <tkato@prontomail.com>
-rw-r--r--print/ghostscript-afpl/Makefile3
-rw-r--r--print/ghostscript-gnu/Makefile3
-rw-r--r--print/ghostscript-gpl/Makefile3
-rw-r--r--print/ghostscript7/Makefile3
-rw-r--r--print/ghostscript8/Makefile3
5 files changed, 15 insertions, 0 deletions
diff --git a/print/ghostscript-afpl/Makefile b/print/ghostscript-afpl/Makefile
index 6f4ffd14b8a2..54a6d8820eb3 100644
--- a/print/ghostscript-afpl/Makefile
+++ b/print/ghostscript-afpl/Makefile
@@ -170,6 +170,9 @@ post-patch:
${PERL} -pi -e 's|\. de|\.|g' \
${WRKSRC}/src/unixinst.mak
# for HPinkjet driver
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'
diff --git a/print/ghostscript-gnu/Makefile b/print/ghostscript-gnu/Makefile
index 36ce7d42ddfe..7a0362b68264 100644
--- a/print/ghostscript-gnu/Makefile
+++ b/print/ghostscript-gnu/Makefile
@@ -165,6 +165,9 @@ post-patch:
${PERL} -pi -e 's|^DEVICE_DEVS|#DEVICE_DEVS|g' \
${WRKSRC}/src/unix-gcc.mak
# for HPinkjet driver
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'
diff --git a/print/ghostscript-gpl/Makefile b/print/ghostscript-gpl/Makefile
index 6f4ffd14b8a2..54a6d8820eb3 100644
--- a/print/ghostscript-gpl/Makefile
+++ b/print/ghostscript-gpl/Makefile
@@ -170,6 +170,9 @@ post-patch:
${PERL} -pi -e 's|\. de|\.|g' \
${WRKSRC}/src/unixinst.mak
# for HPinkjet driver
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 36ce7d42ddfe..7a0362b68264 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -165,6 +165,9 @@ post-patch:
${PERL} -pi -e 's|^DEVICE_DEVS|#DEVICE_DEVS|g' \
${WRKSRC}/src/unix-gcc.mak
# for HPinkjet driver
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 6f4ffd14b8a2..54a6d8820eb3 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -170,6 +170,9 @@ post-patch:
${PERL} -pi -e 's|\. de|\.|g' \
${WRKSRC}/src/unixinst.mak
# for HPinkjet driver
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'