aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-10-12 14:44:55 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-10-12 14:44:55 +0800
commitc09e51c5c69197d20c44e534a8eed3c635bfbb6d (patch)
tree04926de2179ccb20e2cd5c7a17991b5f2c7f127a
parent537ae1b42ced8e6a573d32b69d6eea0aab9390e3 (diff)
downloadfreebsd-ports-gnome-c09e51c5c69197d20c44e534a8eed3c635bfbb6d.tar.gz
freebsd-ports-gnome-c09e51c5c69197d20c44e534a8eed3c635bfbb6d.tar.zst
freebsd-ports-gnome-c09e51c5c69197d20c44e534a8eed3c635bfbb6d.zip
Add py-btchip 0.1.21, python communication library for Ledger Hardware
Wallet.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-btchip/Makefile27
-rw-r--r--security/py-btchip/distinfo3
-rw-r--r--security/py-btchip/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bb0973929018..4f476544b844 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -868,6 +868,7 @@
SUBDIR += py-backports.ssl_match_hostname
SUBDIR += py-bcrypt
SUBDIR += py-borg.localrole
+ SUBDIR += py-btchip
SUBDIR += py-cerealizer
SUBDIR += py-certbot
SUBDIR += py-certifi
diff --git a/security/py-btchip/Makefile b/security/py-btchip/Makefile
new file mode 100644
index 000000000000..b24203fd4360
--- /dev/null
+++ b/security/py-btchip/Makefile
@@ -0,0 +1,27 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= btchip
+PORTVERSION= 0.1.21
+DISTVERSIONPREFIX= v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python communication library for Ledger Hardware Wallet
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa \
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= LedgerHQ
+GH_PROJECT= btchip-python
+
+.include <bsd.port.mk>
diff --git a/security/py-btchip/distinfo b/security/py-btchip/distinfo
new file mode 100644
index 000000000000..d0394975120f
--- /dev/null
+++ b/security/py-btchip/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1506542962
+SHA256 (LedgerHQ-btchip-python-v0.1.21_GH0.tar.gz) = 7ec7c07778528df3af06a4302a8b24620e4dbd85d7c3e391d101fd68d971fbd2
+SIZE (LedgerHQ-btchip-python-v0.1.21_GH0.tar.gz) = 33095
diff --git a/security/py-btchip/pkg-descr b/security/py-btchip/pkg-descr
new file mode 100644
index 000000000000..ff8ecdcd643e
--- /dev/null
+++ b/security/py-btchip/pkg-descr
@@ -0,0 +1,3 @@
+Python communication library for Ledger Hardware Wallet.
+
+WWW: https://github.com/LedgerHQ/btchip-python