aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:55:38 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:55:38 +0800
commitc1443a1f0463272d761a5d5be7c962da2c61eda0 (patch)
tree2ce6be7ec6c398917041c67518c79f531974f998
parent8187af230731a4fe354a0a7afd20a454fb1f825e (diff)
downloadfreebsd-ports-gnome-c1443a1f0463272d761a5d5be7c962da2c61eda0.tar.gz
freebsd-ports-gnome-c1443a1f0463272d761a5d5be7c962da2c61eda0.tar.zst
freebsd-ports-gnome-c1443a1f0463272d761a5d5be7c962da2c61eda0.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - remove indefinite article in COMMENT - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES - update WWW PR: 173103 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
-rw-r--r--www/trac-nav/Makefile20
-rw-r--r--www/trac-nav/pkg-descr2
-rw-r--r--www/trac-nav/pkg-plist1
3 files changed, 8 insertions, 15 deletions
diff --git a/www/trac-nav/Makefile b/www/trac-nav/Makefile
index 4c5153aba637..9ab92f6728f3 100644
--- a/www/trac-nav/Makefile
+++ b/www/trac-nav/Makefile
@@ -1,29 +1,23 @@
-# New ports collection makefile for: trac-nav
-# Date created: January 03 2007
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= nav
PORTVERSION= 4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= http://www.gerritbeine.de/download/trac/
PKGNAMEPREFIX= trac-
DISTNAME= trac${PORTNAME}-${PORTVERSION}
MAINTAINER= glarkin@FreeBSD.org
-COMMENT= A fully customizable navigation bar for Trac
+COMMENT= Fully customizable navigation bar for Trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/trac${PORTNAME}
-NO_BUILD= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracNav
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/www/trac-nav/pkg-descr b/www/trac-nav/pkg-descr
index 6175851c26aa..bdcbb1c5b91c 100644
--- a/www/trac-nav/pkg-descr
+++ b/www/trac-nav/pkg-descr
@@ -3,4 +3,4 @@ wiki engine. The contents of the navigation bar is a wiki page itself and can
be edited like any other wiki page. The navigation bar supports hierarchical
ordering of topics.
-WWW: http://trac-hacks.org/wiki/TracNav
+WWW: http://svn.ipd.kit.edu/trac/javaparty/wiki/TracNav
diff --git a/www/trac-nav/pkg-plist b/www/trac-nav/pkg-plist
deleted file mode 100644
index 02facd52a8d7..000000000000
--- a/www/trac-nav/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracNav-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg