aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-03 07:44:55 +0800
committerantoine <antoine@FreeBSD.org>2014-08-03 07:44:55 +0800
commitc1db6439b833f14b00f0de66a9e69bc4463599e9 (patch)
tree34d9b23d3861c7903ab3b2c715cc4b9d98dcc5d0
parent7a359556b13be418c24fcff15c6c8137a2e78590 (diff)
downloadfreebsd-ports-gnome-c1db6439b833f14b00f0de66a9e69bc4463599e9.tar.gz
freebsd-ports-gnome-c1db6439b833f14b00f0de66a9e69bc4463599e9.tar.zst
freebsd-ports-gnome-c1db6439b833f14b00f0de66a9e69bc4463599e9.zip
Mark broken: Fails to link with new libgc
cc -L/usr/local/lib -pthread -Wl,--rpath,/usr/local/lib -L/usr/local/lib -o ecl_min cinit.o c/all_symbols.o -L./ libeclmin.a -leclatomic -lgmp -lgc-threaded -lffi -pthread -lm ;\ fi libeclmin.a(cosh.o): In function `ecl_cosh_long_float': numbers/cosh.o.c:(.text+0x151): warning: coshl has lower than advertised precision libeclmin.a(sinh.o): In function `ecl_sinh_long_float': numbers/sinh.o.c:(.text+0x151): warning: sinhl has lower than advertised precision libeclmin.a(tanh.o): In function `ecl_tanh_long_float': numbers/tanh.o.c:(.text+0x151): warning: tanhl has lower than advertised precision libeclmin.a(alloc_2.o): In function `init_alloc': alloc_2.o.c:(.text+0x614): undefined reference to `GC_start_call_back' libeclmin.a(alloc_2.o): In function `si_gc_stats': alloc_2.o.c:(.text+0xcfb): undefined reference to `GC_print_stats' alloc_2.o.c:(.text+0xdf6): undefined reference to `GC_print_stats' alloc_2.o.c:(.text+0xe30): undefined reference to `GC_print_stats' Reported by: pkg-fallout
-rw-r--r--lang/ecl/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 00e33c6a8e0e..c2fe92c86a59 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/13.5/
MAINTAINER= olgeni@FreeBSD.org
COMMENT= ANSI Common Lisp implementation
+BROKEN= Fails to link with new libgc
+
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
MAKE_JOBS_UNSAFE= yes