aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-09-21 20:17:37 +0800
committermat <mat@FreeBSD.org>2017-09-21 20:17:37 +0800
commitc21ccee62fc330f90fc57a19b1779a9ac70ed728 (patch)
tree0d9fb22560a2710a2025c70a1d896cf581728f23
parentc130949d2ce885008bbf713070d8ea4f42f16e75 (diff)
downloadfreebsd-ports-gnome-c21ccee62fc330f90fc57a19b1779a9ac70ed728.tar.gz
freebsd-ports-gnome-c21ccee62fc330f90fc57a19b1779a9ac70ed728.tar.zst
freebsd-ports-gnome-c21ccee62fc330f90fc57a19b1779a9ac70ed728.zip
Install the apc.php administration script, so that people do not need to
go and search for it. PR: 222473 Submitted by: mat Approved by: maintainer Sponsored by: Absolight
-rw-r--r--devel/pecl-APCu/Makefile7
-rw-r--r--devel/pecl-APCu4/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/pecl-APCu/Makefile b/devel/pecl-APCu/Makefile
index b190f8b5c238..f8c3cb984464 100644
--- a/devel/pecl-APCu/Makefile
+++ b/devel/pecl-APCu/Makefile
@@ -3,6 +3,7 @@
PORTNAME= APCu
PORTVERSION= 5.1.8
+PORTREVISION= 1
CATEGORIES= devel
DISTNAME= ${PORTNAME:tl}-${PORTVERSION}
@@ -17,4 +18,10 @@ IGNORE_WITH_PHP=56
USES= localbase php:pecl
PHP_MODNAME= ${PORTNAME:tl}
+PLIST_FILES= ${DATADIR}/apc.php
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/apc.php ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>
diff --git a/devel/pecl-APCu4/Makefile b/devel/pecl-APCu4/Makefile
index 0751dfbd9c88..59df7b70a2c6 100644
--- a/devel/pecl-APCu4/Makefile
+++ b/devel/pecl-APCu4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= APCu
PORTVERSION= 4.0.11
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMESUFFIX= 4
DISTNAME= ${PORTNAME:tl}-${PORTVERSION}
@@ -20,4 +21,10 @@ IGNORE_WITH_PHP=70 71
USES= localbase php:pecl
PHP_MODNAME= ${PORTNAME:tl}
+PLIST_FILES= ${DATADIR}/apc.php
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/apc.php ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>