aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-08-11 04:55:04 +0800
committertcberner <tcberner@FreeBSD.org>2017-08-11 04:55:04 +0800
commitc319693a570d15fc23b7f278f2010ed04a4517ec (patch)
tree352a5aa644ea42e652adececab99821737587bf3
parente340278431e12c8e51874a0f2e3b304874ed6b6a (diff)
downloadfreebsd-ports-gnome-c319693a570d15fc23b7f278f2010ed04a4517ec.tar.gz
freebsd-ports-gnome-c319693a570d15fc23b7f278f2010ed04a4517ec.tar.zst
freebsd-ports-gnome-c319693a570d15fc23b7f278f2010ed04a4517ec.zip
Fix patch for ar/ld/gcc paths.
* In r447548 the updated patch unfortunately contained the sed'ed values. * Also make the sed call not echo during build again. Reported by: Gleb Popov <6yearold@gmail.com> Approved by: pgj Differential Revision: https://reviews.freebsd.org/D11961
-rw-r--r--lang/ghc/Makefile3
-rw-r--r--lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs6
2 files changed, 5 insertions, 4 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 1ab40a2ca9ac..5b39c08b81d8 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ghc
PORTVERSION= ${GHC_VERSION}
+PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
LOCAL/pgj/:boot
@@ -190,7 +191,7 @@ post-install-script:
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%CC%%|${CC}|; \
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|; \
s|%%AR%%|${AR}|; \
s|%%LD%%|${LD}|' \
${WRKSRC}/libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs
diff --git a/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs b/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
index daf5ea981ba1..18f937335935 100644
--- a/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
+++ b/lang/ghc/files/patch-libraries__Cabal__Cabal__Distribution__Simple__Program__Builtin.hs
@@ -15,13 +15,13 @@
gccProgram = (simpleProgram "gcc") {
- programFindVersion = findProgramVersion "-dumpversion" id
- }
-+ programFindLocation = \v p -> findProgramOnSearchPath v p "cc"
++ programFindLocation = \v p -> findProgramOnSearchPath v p "%%CC%%"
+}
arProgram :: Program
-arProgram = simpleProgram "ar"
+arProgram = (simpleProgram "ar") {
-+ programFindLocation = \v p -> findProgramOnSearchPath v p "ar"
++ programFindLocation = \v p -> findProgramOnSearchPath v p "%%AR%%"
+}
stripProgram :: Program
@@ -32,7 +32,7 @@
ldProgram :: Program
-ldProgram = simpleProgram "ld"
+ldProgram = (simpleProgram "ld") {
-+ programFindLocation = \v p -> findProgramOnSearchPath v p "ld"
++ programFindLocation = \v p -> findProgramOnSearchPath v p "%%LD%%"
+ }
tarProgram :: Program