aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-09-13 21:36:35 +0800
committertz <tz@FreeBSD.org>2017-09-13 21:36:35 +0800
commitc43491c1b4f9386595db25112f601e0e02fd1e40 (patch)
tree1692ad7ec7158e841ad96b5555f37adfbc27f82f
parent98e39c1eec6ba3ff3b1ae817c7811307ae2bf2d8 (diff)
downloadfreebsd-ports-gnome-c43491c1b4f9386595db25112f601e0e02fd1e40.tar.gz
freebsd-ports-gnome-c43491c1b4f9386595db25112f601e0e02fd1e40.tar.zst
freebsd-ports-gnome-c43491c1b4f9386595db25112f601e0e02fd1e40.zip
devel/gitlab-shell: Update from 5.0.4 to 5.1.1
Changelog: https://gitlab.com/gitlab-org/gitlab-shell/blob/v5.0.4/CHANGELOG This port now depends on lang/go
-rw-r--r--devel/gitlab-shell/Makefile14
-rw-r--r--devel/gitlab-shell/distinfo6
-rw-r--r--devel/gitlab-shell/pkg-plist21
3 files changed, 30 insertions, 11 deletions
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index 0b94a6f7937a..4f58b9adea84 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gitlab-shell
-PORTVERSION= 5.0.4
+PORTVERSION= 5.1.1
CATEGORIES= devel
MASTER_SITES= https://gitlab.com/gitlab-org/${PORTNAME}/repository/archive.tar.gz?ref=v${PORTVERSION}&dummy=/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -10,7 +10,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= tz@FreeBSD.org
COMMENT= GitLab Shell handles git commands for GitLab
-BUILD_DEPENDS= gem:devel/ruby-gems
+BUILD_DEPENDS= gem:devel/ruby-gems \
+ go>=1.5.3:lang/go
USERS= git
GROUPS= git
@@ -24,9 +25,18 @@ post-extract:
post-patch:
${MV} ${WRKSRC}/config.yml.example ${WRKSRC}/config.yml.sample
+pre-install:
+ ${WRKSRC}/bin/compile
+ ${RM} -rf ${WRKSRC}/go
+ ${RM} -rf ${WRKSRC}/go_build
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
@${MKDIR} ${STAGEDIR}/var/log/gitlab-shell
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly-upload-pack
+ ${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly-receive-pack
+
.include <bsd.port.mk>
diff --git a/devel/gitlab-shell/distinfo b/devel/gitlab-shell/distinfo
index 0029db5c4795..80b1578ae079 100644
--- a/devel/gitlab-shell/distinfo
+++ b/devel/gitlab-shell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499074793
-SHA256 (gitlab-shell-v5.0.4.tar.gz) = 9947c9cf7e7f2e1c2af696cf4610c6e2ad256dcae42e95cc0c8dc387ad5d07e3
-SIZE (gitlab-shell-v5.0.4.tar.gz) = 626142
+TIMESTAMP = 1502873044
+SHA256 (gitlab-shell-v5.1.1.tar.gz) = 33a4b79b0b06ad935a4bcf1ad41ab88882eb31b349cca007f1e60f3eb5826a06
+SIZE (gitlab-shell-v5.1.1.tar.gz) = 688960
diff --git a/devel/gitlab-shell/pkg-plist b/devel/gitlab-shell/pkg-plist
index 2db863804342..fc84fdbad175 100644
--- a/devel/gitlab-shell/pkg-plist
+++ b/devel/gitlab-shell/pkg-plist
@@ -1,8 +1,10 @@
+%%DATADIR%%/.codeclimate.yml
%%DATADIR%%/.gitignore
%%DATADIR%%/.gitlab-ci.yml
%%DATADIR%%/.rspec
%%DATADIR%%/.rubocop.yml
%%DATADIR%%/CHANGELOG
+%%DATADIR%%/CONTRIBUTING.md
%%DATADIR%%/Gemfile
%%DATADIR%%/Gemfile.lock
%%DATADIR%%/Guardfile
@@ -12,7 +14,10 @@
%%DATADIR%%/VERSION
@(,,555) %%DATADIR%%/bin/authorized_keys
@(,,555) %%DATADIR%%/bin/check
+@(,,555) %%DATADIR%%/bin/compile
@(,,555) %%DATADIR%%/bin/create-hooks
+@(,,555) %%DATADIR%%/bin/gitaly-upload-pack
+@(,,555) %%DATADIR%%/bin/gitaly-receive-pack
@(,,555) %%DATADIR%%/bin/gitlab-keys
@(,,555) %%DATADIR%%/bin/gitlab-projects
@(,,555) %%DATADIR%%/bin/gitlab-shell
@@ -23,7 +28,6 @@
@(,,555) %%DATADIR%%/hooks/update
%%DATADIR%%/lib/gitlab_access.rb
%%DATADIR%%/lib/gitlab_access_status.rb
-%%DATADIR%%/lib/gitlab_authorized_keys.rb
%%DATADIR%%/lib/gitlab_config.rb
%%DATADIR%%/lib/gitlab_custom_hook.rb
%%DATADIR%%/lib/gitlab_init.rb
@@ -77,19 +81,24 @@
%%DATADIR%%/spec/vcr_cassettes/broadcast_message-none.yml
%%DATADIR%%/spec/vcr_cassettes/broadcast_message-ok.yml
%%DATADIR%%/spec/vcr_cassettes/check-ok.yml
-%%DATADIR%%/spec/vcr_cassettes/denied-pull.yml
-%%DATADIR%%/spec/vcr_cassettes/denied-push-with-user.yml
-%%DATADIR%%/spec/vcr_cassettes/denied-push.yml
%%DATADIR%%/spec/vcr_cassettes/discover-ok.yml
-%%DATADIR%%/spec/vcr_cassettes/http-access-disabled.yml
+%%DATADIR%%/spec/vcr_cassettes/http-pull-disabled.yml
+%%DATADIR%%/spec/vcr_cassettes/http-push-disabled.yml
%%DATADIR%%/spec/vcr_cassettes/lfs-authenticate-ok.yml
%%DATADIR%%/spec/vcr_cassettes/notify-post-receive.yml
-%%DATADIR%%/spec/vcr_cassettes/ssh-access-disabled.yml
%%DATADIR%%/spec/vcr_cassettes/ssh-key-not-found.yml
%%DATADIR%%/spec/vcr_cassettes/ssh-key-not-implemented.yml
%%DATADIR%%/spec/vcr_cassettes/ssh-key-ok.yml
+%%DATADIR%%/spec/vcr_cassettes/ssh-pull-disabled.yml
+%%DATADIR%%/spec/vcr_cassettes/ssh-pull-project-denied.yml
+%%DATADIR%%/spec/vcr_cassettes/ssh-push-disabled.yml
+%%DATADIR%%/spec/vcr_cassettes/ssh-push-project-denied-with-user.yml
+%%DATADIR%%/spec/vcr_cassettes/ssh-push-project-denied.yml
%%DATADIR%%/spec/vcr_cassettes/two-factor-recovery-codes-fail.yml
%%DATADIR%%/spec/vcr_cassettes/two-factor-recovery-codes.yml
+%%DATADIR%%/support/go-format
+%%DATADIR%%/support/go-test
+%%DATADIR%%/support/go_build.rb
%%DATADIR%%/support/rewrite-hooks.sh
%%DATADIR%%/support/truncate_repositories.sh
@dir(git,,755) /var/log/gitlab-shell
class='insertions'>+15 * Add dependency to OpenSSL.ume2003-05-031-0/+5 * Specify full path of perl explicitly.ume2003-04-291-1/+2 * add mirror sites.ume2003-04-241-1/+2 * portlintume2003-04-241-2/+2 * Oops, correct usage of LIB_DEPENDS introduced by previous commit.ume2003-04-181-5/+4 * - Add WITH_BDB_VER for choosing version of Berkeley DB. For example,ume2003-04-183-3/+31 * fix build on alpha by fixing prototype conflict.ume2003-04-081-0/+18 * Add Cyrus IMAPd 2.2.0-ALPHA after repo copy.ume2003-03-2920-168/+568 * Use REINPLACE_CMD.ume2003-03-241-9/+6 * De-pkg-comment.ume2003-02-212-1/+1 * Update to 2.1.12.ume2003-02-046-26/+30 * Unbreak build on the system where db4 is installed.ume2003-01-311-4/+13 * Add CYRUS_USER and CYRUS_GROUP options to be able to configureume2003-01-304-16/+44 * better workaround against PF_LOCAL.ume2003-01-222-26/+16 * Wrongly removed lib/sasl/Cyrus.conf instead of lib/sasl2/Cyrus.confume2003-01-171-5/+5 * - Use PERL_LEVEL to distinguish installed perl version.ume2003-01-024-5/+58 * Update to 2.1.11.ume2002-12-052-4/+4 * Update to 2.1.10.ume2002-11-162-4/+4 * Update to cyrus-imapd-2.1.9.ume2002-09-022-4/+4 * Update to 2.1.8.ume2002-08-292-5/+5 * BerkeleyDB cleanup - stage 2ade2002-08-231-2/+2 * Update to 2.1.7.ume2002-08-224-34/+7 * cyradm didn't show password prompt correctly.ume2002-08-172-0/+13 * Update an IPv6 patch to 20020817.ume2002-08-172-2/+2 * It seems getpeername() returns with no error but doesn't fill structume2002-08-161-3/+5 * Add cyrus-imapd-2.1.5 after repo. copy.ume2002-08-0814-122/+379 * moving saslv1 includes files to make it easier to add saslv2ume2002-07-291-1/+1 * Make this port add shell to cyrus user.ume2002-05-263-51/+33 * Add USE_PERL5=yes.ume2002-05-191-0/+1 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-291-7/+7 * Update IPv6 patch.ume2002-01-192-3/+3 * Sync with reality in comment. We can choose `sasldb' also.ume2002-01-181-1/+1 * Back out the db3 port update because some of these dependent ports hadknu2001-08-011-1/+2 * Update to 2.0.16.ume2001-07-292-6/+7 * Reflect databases/db3's shlib version bump from 2 to 3.knu2001-07-251-2/+2 * Update IPv6 support patch to 20010711 version.ume2001-07-122-3/+3 * - Install more html docs.ume2001-07-092-5/+14 * Update to cyrus-imapd 2.0.15.ume2001-07-083-16/+4 * Update to 2.0.14.ume2001-05-314-90/+16 * The configuration files should be preserved at deinstallume2001-05-221-2/+4 * Fix a bug that imaps didn't work correctly.ume2001-05-072-1/+86 * When bind() was fail, master did core dump.ume2001-05-062-2/+3 * Update to 2.0.13.ume2001-04-293-5/+5 * Add missing items into pkg-plist.ume2001-04-222-2/+11 * Since imapd.conf is installed into ${PREFIX}/etc, mkimap shouldume2001-04-133-3/+10 * Add missing patch that does chown to cyrus spool directory.ume2001-04-071-0/+29 * Since spool location is configurable by user, prevent making spoolume2001-04-074-18/+15 * Add missing Perl library into pkg-plist.ume2001-04-072-1/+15 * Use -U option of ps instead of odd path checking.ume2001-03-222-2/+2 * killall doesn't have -u option under FreeBSD 3.Xume2001-03-162-1/+3 * Add cyrus-imapd 2.0.12, the cyrus mail server, supporting POP3 andume2001-03-1325-235/+222 * Spaces->tabs in the mail category.olgeni2001-02-05