aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-02-14 22:58:17 +0800
committermiwi <miwi@FreeBSD.org>2016-02-14 22:58:17 +0800
commitc6bf35fce5dd414c9d3a5971fd50c236576b9bea (patch)
treeaef93c12c21e80a57e93b5aaf258f6a24c6e691b
parent8f8a1e3ef926de679873d9fb12f65e3cf6840577 (diff)
downloadfreebsd-ports-gnome-c6bf35fce5dd414c9d3a5971fd50c236576b9bea.tar.gz
freebsd-ports-gnome-c6bf35fce5dd414c9d3a5971fd50c236576b9bea.tar.zst
freebsd-ports-gnome-c6bf35fce5dd414c9d3a5971fd50c236576b9bea.zip
- Update to 1.10.1
Changelog: http://pear.php.net/package/PEAR/download/1.10.0 http://pear.php.net/package/PEAR/download/1.10.1
-rw-r--r--Mk/Uses/pear.mk1
-rw-r--r--devel/pear/Makefile14
-rw-r--r--devel/pear/distinfo4
-rw-r--r--devel/pear/files/patch-go-pear39
-rw-r--r--devel/pear/pkg-plist77
5 files changed, 67 insertions, 68 deletions
diff --git a/Mk/Uses/pear.mk b/Mk/Uses/pear.mk
index d4904a25bff1..6d70b7bcae1a 100644
--- a/Mk/Uses/pear.mk
+++ b/Mk/Uses/pear.mk
@@ -136,6 +136,7 @@ do-auto-install:
# Clean up orphans re-generated by pear-install
.for R in .channels .depdb .depdblock .filemap .lock .registry
@${RM} -rf ${STAGEDIR}${PREFIX}/${LPEARDIR}/${R}
+ @${RM} -rf ${STAGEDIR}/${R}
.endfor
.endif
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index 5fbf5278650f..bde125d6affd 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -2,20 +2,22 @@
# $FreeBSD$
PORTNAME= pear
-PORTVERSION= 1.9.4
-PORTREVISION= 3
+PORTVERSION= 1.10.1
CATEGORIES= devel
-MASTER_SITES= http://miwibox.org/distfiles/
+MASTER_SITES= http://mirror.miwibox.org/
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR framework for PHP
+LICENSE= PHP301
+
USES= cpe tar:bzip2
CPE_VENDOR= php
NO_BUILD= yes
+NO_ARCH= yes
WANT_PHP_CLI= yes
-USE_PHP= pcre xml
+USE_PHP= pcre xml zlib
USE_PHP_BUILD= yes
PEARDIR= ${PREFIX}/share/pear
@@ -29,9 +31,7 @@ post-patch:
@cd ${WRKSRC}/go-pear-bundle/tmp/PEAR-${PORTVERSION} && ${PATCH} -s -p0 < ${FILESDIR}/extra-patch-PEAR-Config.php
@${RM} ${WRKSRC}/go-pear-bundle/tmp/PEAR-${PORTVERSION}/PEAR/Config.php.orig
@${MD5} -q ${WRKSRC}/go-pear-bundle/tmp/PEAR-${PORTVERSION}/PEAR/Config.php > ${WRKSRC}/Config.php.md5
- @${REINPLACE_CMD} -E -e "s|(file md5sum=\").*(\" name=\"PEAR/Config.php\" role=\"php\")|\1`${CAT} ${WRKSRC}/Config.php.md5`\2|g" \
- ${WRKSRC}/go-pear-bundle/tmp/package2.xml ${WRKSRC}/go-pear-bundle/package2.xml
- @cd ${WRKSRC}/go-pear-bundle/tmp && ${TAR} -cf ../PEAR-${PORTVERSION}.tar package2.xml PEAR-${PORTVERSION} package.xml
+ @cd ${WRKSRC}/go-pear-bundle/tmp && ${TAR} -cf ../PEAR-${PORTVERSION}.tar PEAR-${PORTVERSION} package.xml
do-install:
@cd ${WRKSRC} && ${SETENV} DESTDIR=${STAGEDIR} ${LOCALBASE}/bin/php -q ./go-pear
diff --git a/devel/pear/distinfo b/devel/pear/distinfo
index 8db8b94837d5..9124502ea859 100644
--- a/devel/pear/distinfo
+++ b/devel/pear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pear-1.9.4.tar.bz2) = dbff7047b70035e9b65adf8e0beaf834db2e1bf161f526bd4d87e204fd47b604
-SIZE (pear-1.9.4.tar.bz2) = 322695
+SHA256 (pear-1.10.1.tar.bz2) = 1e90ba461f3bbfdde49c4bee5e028fcd3291e92653a2227dbbcdb378ae31c1be
+SIZE (pear-1.10.1.tar.bz2) = 318856
diff --git a/devel/pear/files/patch-go-pear b/devel/pear/files/patch-go-pear
index d1c4ddddc9a7..dbc59251d56f 100644
--- a/devel/pear/files/patch-go-pear
+++ b/devel/pear/files/patch-go-pear
@@ -1,5 +1,5 @@
---- ./go-pear.orig 2013-07-18 07:18:00.000000000 +0000
-+++ ./go-pear 2014-02-07 08:08:36.000000000 +0000
+--- go-pear.orig 2013-07-18 07:18:00 UTC
++++ go-pear
@@ -57,6 +57,8 @@
define('WIN32GUI', !WEBINSTALLER && WINDOWS && $sapi_name=='cli' && which('cscript'));
@@ -72,7 +72,7 @@
if (!WEBINSTALLER) {
$msg = "The following PEAR packages are bundled with PHP: " .
implode(', ', array_keys($pfc_packages));
-@@ -571,17 +573,17 @@
+@@ -571,17 +573,19 @@
$install_optional_packages = array();
print "\n";
}
@@ -82,6 +82,8 @@
# Download
####
++dl('xml.so');
++
if (function_exists('set_include_path')) {
- set_include_path($ptmp);
+ set_include_path($ptmp . PATH_SEPARATOR . "%%BUNDLEDIR%%");
@@ -94,7 +96,7 @@
if (!extension_loaded('zlib') && !WEBINSTALLER) { // In Web context we could be in multithread env which makes dl() end up with a fatal error.
if (WINDOWS) {
@dl('php_zlib.dll');
-@@ -606,18 +608,19 @@
+@@ -606,18 +610,19 @@
if (!$have_gzip) {
print "Downloading uncompressed packages\n";
};
@@ -116,7 +118,7 @@
}
// gopear_bundle usage
-@@ -645,19 +648,21 @@
+@@ -645,19 +650,21 @@
// Bootstrap needed ?
$nobootstrap = false;
@@ -140,7 +142,7 @@
}
include_once 'PEAR.php';
print "ok\n";
-@@ -691,6 +696,7 @@
+@@ -691,6 +698,7 @@
// Extract needed ?
$noextract = false;
@@ -148,7 +150,7 @@
if (is_dir($php_dir)) {
$noextract = @include_once 'PEAR/Registry.php';
-@@ -701,6 +707,7 @@
+@@ -701,6 +709,7 @@
}
}
}
@@ -156,7 +158,16 @@
if ($noextract) {
print('Using previously installed installer ... ');
-@@ -747,12 +754,7 @@
+@@ -722,7 +731,7 @@
+ displayHTMLProgress($progress += round(19 / count($bootstrap_pkgs)));
+
+ $fullpkg = substr($tarball, 0, strrpos($tarball, '.'));
+- $tar = &new Archive_Tar($tarball, $have_gzip);
++ $tar = new Archive_Tar($tarball, $have_gzip);
+ if (!$tar->extractModify($ptmp, $fullpkg)) {
+ bail("Extraction for $fullpkg failed!\n");
+ }
+@@ -747,12 +756,7 @@
include_once "PEAR/Command.php";
include_once "PEAR/Registry.php";
@@ -170,7 +181,7 @@
$config->set('preferred_state', 'stable');
foreach ($config_vars as $var) {
-@@ -765,7 +767,7 @@
+@@ -765,7 +769,7 @@
$config->set('http_proxy', $http_proxy);
$config->store();
@@ -179,7 +190,7 @@
PEAR_Command::setFrontendType('CLI');
PEAR::staticPushErrorHandling(PEAR_ERROR_DIE); //fail silently
-@@ -787,6 +789,11 @@
+@@ -787,6 +791,11 @@
} else {
$options = array('onlyreqdeps' => true);
}
@@ -191,7 +202,7 @@
if ($registry->packageExists($pkg) || $registry->packageExists($pkg_basename)) {
print(str_pad("Package: $pkg", max(50,9+strlen($pkg)+4), '.').' already installed ... ok'."\n");
displayHTMLProgress($progress += round(50 / count($to_install)));
-@@ -821,7 +828,7 @@
+@@ -821,7 +830,7 @@
// Base installation finished
@@ -200,7 +211,7 @@
ini_restore("include_path");
if (!WEBINSTALLER) {
-@@ -980,6 +987,7 @@
+@@ -980,6 +989,7 @@
if (WINDOWS && !WEBINSTALLER) {
win32CreateRegEnv();
}
@@ -208,7 +219,7 @@
// Set of functions following
/**
* Parse the given dirname
-@@ -1418,19 +1426,17 @@
+@@ -1418,19 +1428,17 @@
}
} else {
if ($_prefix === null) {
@@ -233,7 +244,7 @@
// check if the user has installed PHP with PHP or GNU layout
if (@is_dir("$prefix/lib/php/.registry")) {
$php_dir = '$prefix/lib/php';
-@@ -1442,6 +1448,7 @@
+@@ -1442,6 +1450,7 @@
} elseif (@is_dir("$prefix/share/php/.registry")) {
$php_dir = '$prefix/share/php';
}
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
index 6f2212cec409..acf7380127a4 100644
--- a/devel/pear/pkg-plist
+++ b/devel/pear/pkg-plist
@@ -2,31 +2,12 @@ bin/pear
bin/peardev
bin/pecl
@sample etc/pear.conf.sample
-%%DOCSDIR%%/Archive_Tar/docs/Archive_Tar.txt
-%%DOCSDIR%%/PEAR/INSTALL
-%%DOCSDIR%%/PEAR/LICENSE
-%%DOCSDIR%%/PEAR/README
-%%DOCSDIR%%/Structures_Graph/docs/generate.sh
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/Structures_Graph.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/Structures_Graph_Manipulator_AcyclicTest.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/Structures_Graph_Manipulator_TopologicalSorter.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/Structures_Graph_Node.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/_Structures_Graph_Manipulator_AcyclicTest_php.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/_Structures_Graph_Manipulator_TopologicalSorter_php.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/_Structures_Graph_Node_php.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/_Structures_Graph_php.html
-%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/tutorial_Structures_Graph.pkg.html
-%%DOCSDIR%%/Structures_Graph/docs/html/classtrees_Structures_Graph.html
-%%DOCSDIR%%/Structures_Graph/docs/html/elementindex.html
-%%DOCSDIR%%/Structures_Graph/docs/html/elementindex_Structures_Graph.html
-%%DOCSDIR%%/Structures_Graph/docs/html/errors.html
-%%DOCSDIR%%/Structures_Graph/docs/html/index.html
-%%DOCSDIR%%/Structures_Graph/docs/html/li_Structures_Graph.html
-%%DOCSDIR%%/Structures_Graph/docs/html/media/banner.css
-%%DOCSDIR%%/Structures_Graph/docs/html/media/stylesheet.css
-%%DOCSDIR%%/Structures_Graph/docs/html/packages.html
-%%DOCSDIR%%/Structures_Graph/docs/html/todolist.html
-%%DOCSDIR%%/Structures_Graph/docs/tutorials/Structures_Graph/Structures_Graph.pkg
+%%PORTDOCS%%%%DOCSDIR%%/Archive_Tar/docs/Archive_Tar.txt
+%%PORTDOCS%%%%DOCSDIR%%/PEAR/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/PEAR/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/PEAR/README.rst
+%%PORTDOCS%%%%DOCSDIR%%/Structures_Graph/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/Structures_Graph/docs/tutorials/Structures_Graph/Structures_Graph.pkg
%%DATADIR%%/.channels/.alias/pear.txt
%%DATADIR%%/.channels/.alias/pecl.txt
%%DATADIR%%/.channels/.alias/phpdocs.txt
@@ -45,10 +26,12 @@ bin/pecl
%%DATADIR%%/Archive/Tar.php
%%DATADIR%%/Console/Getopt.php
%%DATADIR%%/OS/Guess.php
+%%DATADIR%%/PEAR.php
%%DATADIR%%/PEAR/Autoloader.php
%%DATADIR%%/PEAR/Builder.php
-%%DATADIR%%/PEAR/ChannelFile/Parser.php
%%DATADIR%%/PEAR/ChannelFile.php
+%%DATADIR%%/PEAR/ChannelFile/Parser.php
+%%DATADIR%%/PEAR/Command.php
%%DATADIR%%/PEAR/Command/Auth.php
%%DATADIR%%/PEAR/Command/Auth.xml
%%DATADIR%%/PEAR/Command/Build.php
@@ -72,19 +55,20 @@ bin/pecl
%%DATADIR%%/PEAR/Command/Remote.xml
%%DATADIR%%/PEAR/Command/Test.php
%%DATADIR%%/PEAR/Command/Test.xml
-%%DATADIR%%/PEAR/Command.php
%%DATADIR%%/PEAR/Common.php
%%DATADIR%%/PEAR/Config.php
%%DATADIR%%/PEAR/Dependency2.php
%%DATADIR%%/PEAR/DependencyDB.php
-%%DATADIR%%/PEAR/Downloader/Package.php
%%DATADIR%%/PEAR/Downloader.php
+%%DATADIR%%/PEAR/Downloader/Package.php
%%DATADIR%%/PEAR/ErrorStack.php
%%DATADIR%%/PEAR/Exception.php
-%%DATADIR%%/PEAR/Frontend/CLI.php
%%DATADIR%%/PEAR/Frontend.php
-%%DATADIR%%/PEAR/Installer/Role/Cfg.xml
+%%DATADIR%%/PEAR/Frontend/CLI.php
+%%DATADIR%%/PEAR/Installer.php
+%%DATADIR%%/PEAR/Installer/Role.php
%%DATADIR%%/PEAR/Installer/Role/Cfg.php
+%%DATADIR%%/PEAR/Installer/Role/Cfg.xml
%%DATADIR%%/PEAR/Installer/Role/Common.php
%%DATADIR%%/PEAR/Installer/Role/Data.php
%%DATADIR%%/PEAR/Installer/Role/Data.xml
@@ -92,6 +76,8 @@ bin/pecl
%%DATADIR%%/PEAR/Installer/Role/Doc.xml
%%DATADIR%%/PEAR/Installer/Role/Ext.php
%%DATADIR%%/PEAR/Installer/Role/Ext.xml
+%%DATADIR%%/PEAR/Installer/Role/Man.php
+%%DATADIR%%/PEAR/Installer/Role/Man.xml
%%DATADIR%%/PEAR/Installer/Role/Php.php
%%DATADIR%%/PEAR/Installer/Role/Php.xml
%%DATADIR%%/PEAR/Installer/Role/Script.php
@@ -102,51 +88,52 @@ bin/pecl
%%DATADIR%%/PEAR/Installer/Role/Test.xml
%%DATADIR%%/PEAR/Installer/Role/Www.php
%%DATADIR%%/PEAR/Installer/Role/Www.xml
-%%DATADIR%%/PEAR/Installer/Role.php
-%%DATADIR%%/PEAR/Installer.php
+%%DATADIR%%/PEAR/PackageFile.php
%%DATADIR%%/PEAR/PackageFile/Generator/v1.php
%%DATADIR%%/PEAR/PackageFile/Generator/v2.php
%%DATADIR%%/PEAR/PackageFile/Parser/v1.php
%%DATADIR%%/PEAR/PackageFile/Parser/v2.php
%%DATADIR%%/PEAR/PackageFile/v1.php
+%%DATADIR%%/PEAR/PackageFile/v2.php
%%DATADIR%%/PEAR/PackageFile/v2/Validator.php
%%DATADIR%%/PEAR/PackageFile/v2/rw.php
-%%DATADIR%%/PEAR/PackageFile/v2.php
-%%DATADIR%%/PEAR/PackageFile.php
%%DATADIR%%/PEAR/Packager.php
+%%DATADIR%%/PEAR/REST.php
%%DATADIR%%/PEAR/REST/10.php
%%DATADIR%%/PEAR/REST/11.php
%%DATADIR%%/PEAR/REST/13.php
-%%DATADIR%%/PEAR/FixPHP5PEARWarnings.php
-%%DATADIR%%/PEAR/REST.php
%%DATADIR%%/PEAR/Registry.php
%%DATADIR%%/PEAR/RunTest.php
%%DATADIR%%/PEAR/Task/Common.php
-%%DATADIR%%/PEAR/Task/Postinstallscript/rw.php
%%DATADIR%%/PEAR/Task/Postinstallscript.php
-%%DATADIR%%/PEAR/Task/Replace/rw.php
+%%DATADIR%%/PEAR/Task/Postinstallscript/rw.php
%%DATADIR%%/PEAR/Task/Replace.php
-%%DATADIR%%/PEAR/Task/Unixeol/rw.php
+%%DATADIR%%/PEAR/Task/Replace/rw.php
%%DATADIR%%/PEAR/Task/Unixeol.php
-%%DATADIR%%/PEAR/Task/Windowseol/rw.php
+%%DATADIR%%/PEAR/Task/Unixeol/rw.php
%%DATADIR%%/PEAR/Task/Windowseol.php
+%%DATADIR%%/PEAR/Task/Windowseol/rw.php
%%DATADIR%%/PEAR/Validate.php
%%DATADIR%%/PEAR/Validator/PECL.php
%%DATADIR%%/PEAR/XMLParser.php
-%%DATADIR%%/PEAR.php
-%%DATADIR%%/PEAR5.php
+%%DATADIR%%/Structures/Graph.php
%%DATADIR%%/Structures/Graph/Manipulator/AcyclicTest.php
%%DATADIR%%/Structures/Graph/Manipulator/TopologicalSorter.php
%%DATADIR%%/Structures/Graph/Node.php
-%%DATADIR%%/Structures/Graph.php
%%DATADIR%%/System.php
%%DATADIR%%/data/PEAR/package.dtd
%%DATADIR%%/data/PEAR/template.spec
-%%DATADIR%%/data/Structures_Graph/LICENSE
%%DATADIR%%/pearcmd.php
%%DATADIR%%/peclcmd.php
+%%DATADIR%%/tests/Console_Getopt/tests/001-getopt.phpt
+%%DATADIR%%/tests/Console_Getopt/tests/bug10557.phpt
+%%DATADIR%%/tests/Console_Getopt/tests/bug11068.phpt
+%%DATADIR%%/tests/Console_Getopt/tests/bug13140.phpt
+%%DATADIR%%/tests/Structures_Graph/tests/AcyclicTestTest.php
%%DATADIR%%/tests/Structures_Graph/tests/AllTests.php
-%%DATADIR%%/tests/Structures_Graph/tests/testCase/BasicGraph.php
+%%DATADIR%%/tests/Structures_Graph/tests/BasicGraphTest.php
+%%DATADIR%%/tests/Structures_Graph/tests/TopologicalSorterTest.php
+%%DATADIR%%/tests/Structures_Graph/tests/helper.inc
@rmtry share/pear/.depdb
@rmtry share/pear/.depdblock
@rmtry share/pear/.filemap