aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-20 18:12:00 +0800
committerbapt <bapt@FreeBSD.org>2011-09-20 18:12:00 +0800
commitcb4dec256c89d7192f16c2caeb7b02f572d44978 (patch)
treee6cd890dfba649aeec9076925fb4376841c9d1bc
parent4ac197ec60ceadaf4bdb18ccf755b5ac0cd17711 (diff)
downloadfreebsd-ports-gnome-cb4dec256c89d7192f16c2caeb7b02f572d44978.tar.gz
freebsd-ports-gnome-cb4dec256c89d7192f16c2caeb7b02f572d44978.tar.zst
freebsd-ports-gnome-cb4dec256c89d7192f16c2caeb7b02f572d44978.zip
Log::Dispatchouli is a thin layer above Log::Dispatch and meant to
make it dead simple to add logging to a program without having to think much about categories, facilities, levels, or things like that. It is meant to make logging just configurable enough that you can find the logs you want and just easy enough that you will actually log things. WWW: http://search.cpan.org/dist/Log-Dispatchouli/ Submitted by: Geraud CONTINSOUZAS <geraud@gcu.info> (by private mail)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Dispatchouli/Makefile33
-rw-r--r--devel/p5-Log-Dispatchouli/distinfo2
-rw-r--r--devel/p5-Log-Dispatchouli/pkg-descr8
-rw-r--r--devel/p5-Log-Dispatchouli/pkg-plist8
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 38180573f8b8..3b916f866c50 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1924,6 +1924,7 @@
SUBDIR += p5-Log-Dispatch-Perl
SUBDIR += p5-Log-Dispatch-Screen-Color
SUBDIR += p5-Log-Dispatch-Scribe
+ SUBDIR += p5-Log-Dispatchouli
SUBDIR += p5-Log-Handler
SUBDIR += p5-Log-Log4perl
SUBDIR += p5-Log-Log4perl-Appender-RabbitMQ
diff --git a/devel/p5-Log-Dispatchouli/Makefile b/devel/p5-Log-Dispatchouli/Makefile
new file mode 100644
index 000000000000..fb6aaa436d21
--- /dev/null
+++ b/devel/p5-Log-Dispatchouli/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: devel/p5-Log-Dispatchouli
+# Date created: 2011-09-19
+# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatchouli
+PORTVERSION= 2.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= Log events to an array (reference)
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Dispatch-Array>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Array \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Sub-Exporter-GlobExporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter-GlobExporter \
+ p5-String-Flogger>=0:${PORTSDIR}/textproc/p5-String-Flogger
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatchouli.3 \
+ Log::Dispatchouli::Global.3 \
+ Log::Dispatchouli::Proxy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Dispatchouli/distinfo b/devel/p5-Log-Dispatchouli/distinfo
new file mode 100644
index 000000000000..e5d0c50a56e6
--- /dev/null
+++ b/devel/p5-Log-Dispatchouli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Log-Dispatchouli-2.005.tar.gz) = e3d9e7219bc52d3c7bed241cb2f259eee5b9edde1d60e093d75423167555a519
+SIZE (Log-Dispatchouli-2.005.tar.gz) = 22449
diff --git a/devel/p5-Log-Dispatchouli/pkg-descr b/devel/p5-Log-Dispatchouli/pkg-descr
new file mode 100644
index 000000000000..755f3dabda81
--- /dev/null
+++ b/devel/p5-Log-Dispatchouli/pkg-descr
@@ -0,0 +1,8 @@
+Log::Dispatchouli is a thin layer above Log::Dispatch and meant to
+make it dead simple to add logging to a program without having to
+think much about categories, facilities, levels, or things like that.
+It is meant to make logging just configurable enough that you can find
+the logs you want and just easy enough that you will actually log
+things.
+
+WWW: http://search.cpan.org/dist/Log-Dispatchouli/
diff --git a/devel/p5-Log-Dispatchouli/pkg-plist b/devel/p5-Log-Dispatchouli/pkg-plist
new file mode 100644
index 000000000000..5380411c1db0
--- /dev/null
+++ b/devel/p5-Log-Dispatchouli/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Log/Dispatchouli.pm
+%%SITE_PERL%%/Log/Dispatchouli/Global.pm
+%%SITE_PERL%%/Log/Dispatchouli/Proxy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatchouli/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatchouli
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
+@dirrmtry %%SITE_PERL%%/Log/Dispatchouli
+@dirrmtry %%SITE_PERL%%/Log