aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-05-11 18:57:38 +0800
committerpi <pi@FreeBSD.org>2018-05-11 18:57:38 +0800
commitcb67544b08b63ff4a3fbb5f0f76b1ab4e3298bcc (patch)
treed426a26ec6a29ed255efa68bae6ed8ded9f5b570
parent9c365c190a81f93a39e3fb0b84ae31d36c66a66d (diff)
downloadfreebsd-ports-gnome-cb67544b08b63ff4a3fbb5f0f76b1ab4e3298bcc.tar.gz
freebsd-ports-gnome-cb67544b08b63ff4a3fbb5f0f76b1ab4e3298bcc.tar.zst
freebsd-ports-gnome-cb67544b08b63ff4a3fbb5f0f76b1ab4e3298bcc.zip
New port: security/p5-Bytes-Random-Secure-Tiny
A tiny Perl extension to generate cryptographically-secure random bytes. It provides random bytes from a cryptographically secure random number generator (ISAAC), seeded from strong entropy sources on a wide variety of platforms. It does so without external dependencies (except on Windows), and has a minimal but useful user interface patterned after the module Bytes::Random::Secure. WWW: http://search.cpan.org/dist/Bytes-Random-Secure-Tiny/
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Bytes-Random-Secure-Tiny/Makefile24
-rw-r--r--security/p5-Bytes-Random-Secure-Tiny/distinfo3
-rw-r--r--security/p5-Bytes-Random-Secure-Tiny/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ccf06e4be05e..e0c9838fe505 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -531,6 +531,7 @@
SUBDIR += p5-Authen-TypeKey
SUBDIR += p5-Business-PayPal-EWP
SUBDIR += p5-Bytes-Random-Secure
+ SUBDIR += p5-Bytes-Random-Secure-Tiny
SUBDIR += p5-CACertOrg-CA
SUBDIR += p5-CSP
SUBDIR += p5-Cisco-Hash
diff --git a/security/p5-Bytes-Random-Secure-Tiny/Makefile b/security/p5-Bytes-Random-Secure-Tiny/Makefile
new file mode 100644
index 000000000000..8907b15a5769
--- /dev/null
+++ b/security/p5-Bytes-Random-Secure-Tiny/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Bytes-Random-Secure-Tiny
+PORTVERSION= 1.008
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Generate cryptographically-secure random bytes
+
+LICENSE= ART20
+
+USES= perl5
+USE_PERL5= configure
+
+PLIST_FILES= ${SITE_PERL_REL}/Bytes/Random/Secure/Tiny.pm \
+ ${SITE_PERL_REL}/Bytes/Random/Secure/Tiny.pod \
+ ${SITE_MAN3_REL}/Bytes::Random::Secure::Tiny.3.gz
+
+pre-install:
+ ${RM} ${WRKSRC}/blib/lib/Bytes/Random/Secure/README.pod
+
+.include <bsd.port.mk>
diff --git a/security/p5-Bytes-Random-Secure-Tiny/distinfo b/security/p5-Bytes-Random-Secure-Tiny/distinfo
new file mode 100644
index 000000000000..9b22adfc6c4e
--- /dev/null
+++ b/security/p5-Bytes-Random-Secure-Tiny/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526035786
+SHA256 (Bytes-Random-Secure-Tiny-1.008.tar.gz) = 26ad5e38b5e05c44aa3427d4b3f8d7af697364551b3e2562c883d65d663b394a
+SIZE (Bytes-Random-Secure-Tiny-1.008.tar.gz) = 28312
diff --git a/security/p5-Bytes-Random-Secure-Tiny/pkg-descr b/security/p5-Bytes-Random-Secure-Tiny/pkg-descr
new file mode 100644
index 000000000000..a223786d75c8
--- /dev/null
+++ b/security/p5-Bytes-Random-Secure-Tiny/pkg-descr
@@ -0,0 +1,9 @@
+A tiny Perl extension to generate cryptographically-secure random bytes.
+
+It provides random bytes from a cryptographically secure random
+number generator (ISAAC), seeded from strong entropy sources on a
+wide variety of platforms. It does so without external dependencies
+(except on Windows), and has a minimal but useful user interface
+patterned after the module Bytes::Random::Secure.
+
+WWW: http://search.cpan.org/dist/Bytes-Random-Secure-Tiny/