aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-11-05 18:34:25 +0800
committerale <ale@FreeBSD.org>2012-11-05 18:34:25 +0800
commitcf8b547227977608204bf15c368713e9330bd6ec (patch)
treec4f1b4c051a9339f3cccddc9f286bd71955891f8
parentb426798607adde5c716f9855dfa160617a26aa38 (diff)
downloadfreebsd-ports-gnome-cf8b547227977608204bf15c368713e9330bd6ec.tar.gz
freebsd-ports-gnome-cf8b547227977608204bf15c368713e9330bd6ec.tar.zst
freebsd-ports-gnome-cf8b547227977608204bf15c368713e9330bd6ec.zip
Update to 2.0.1 release.
Feature safe: yes
-rw-r--r--security/oath-toolkit/Makefile11
-rw-r--r--security/oath-toolkit/distinfo4
-rw-r--r--security/oath-toolkit/pkg-plist5
3 files changed, 15 insertions, 5 deletions
diff --git a/security/oath-toolkit/Makefile b/security/oath-toolkit/Makefile
index bcf8cdba53cf..5a85346ec916 100644
--- a/security/oath-toolkit/Makefile
+++ b/security/oath-toolkit/Makefile
@@ -1,7 +1,8 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
PORTNAME= oath-toolkit
-PORTVERSION= 2.0.0
+PORTVERSION= 2.0.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -11,6 +12,7 @@ COMMENT= Library, tools, and PAM module for OATH authentication
USE_GMAKE= yes
USE_GNOME= gnomehack
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -36,7 +38,8 @@ PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPSKC}
-LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2 \
+ xmlsec1:${PORTSDIR}/security/xmlsec1
CONFIGURE_ARG+=--with-xml-prefix=${LOCALBASE}
@@ -76,14 +79,16 @@ MAN3+= pskc_build_xml.3 pskc_check_version.3 pskc_done.3 \
pskc_get_key_policy_startdate.3 \
pskc_get_key_profileid.3 pskc_get_key_reference.3 \
pskc_get_key_userid.3 pskc_get_keypackage.3 \
+ pskc_get_signed_p.3 \
pskc_get_version.3 pskc_global_done.3 \
pskc_global_init.3 pskc_global_log.3 \
pskc_init.3 pskc_keyusage2str.3 pskc_output.3 \
pskc_parse_from_memory.3 pskc_pinusagemode2str.3 \
+ pskc_sign_x509.3 \
pskc_str2keyusage.3 pskc_str2pinusagemode.3 \
pskc_str2valueformat.3 pskc_strerror.3 \
pskc_strerror_name.3 pskc_validate.3 \
- pskc_valueformat2str.3
+ pskc_valueformat2str.3 pskc_verify_x509crt.3
PLIST_SUB+= PSKC=""
.else
diff --git a/security/oath-toolkit/distinfo b/security/oath-toolkit/distinfo
index 5ab4c87622cd..ccf0458fd7e7 100644
--- a/security/oath-toolkit/distinfo
+++ b/security/oath-toolkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oath-toolkit-2.0.0.tar.gz) = 027a9767d9dd49b8285a5a65b637114e2fdd60feda1f622d5a73d26fc33b667f
-SIZE (oath-toolkit-2.0.0.tar.gz) = 3841020
+SHA256 (oath-toolkit-2.0.1.tar.gz) = d267055979a3d41e36fb36f193aa9e43832d64e1555b4d2efc6d28083ac40988
+SIZE (oath-toolkit-2.0.1.tar.gz) = 3926095
diff --git a/security/oath-toolkit/pkg-plist b/security/oath-toolkit/pkg-plist
index 2db0a0f0e16b..d902ec02681b 100644
--- a/security/oath-toolkit/pkg-plist
+++ b/security/oath-toolkit/pkg-plist
@@ -21,6 +21,11 @@ lib/security/pam_oath.la
lib/security/pam_oath.so
libdata/pkgconfig/liboath.pc
%%PSKC%%libdata/pkgconfig/libpskc.pc
+%%PSKC%%share/xml/pskc/catalog-pskc.xml
+%%PSKC%%share/xml/pskc/pskc-schema.xsd
+%%PSKC%%share/xml/pskc/xenc-schema.xsd
+%%PSKC%%share/xml/pskc/xmldsig-core-schema.xsd
@dirrm include/liboath
%%PSKC%%@dirrm include/pskc
@dirrmtry lib/security
+%%PSKC%%@dirrm share/xml/pskc