aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2006-06-06 21:47:15 +0800
committerlbr <lbr@FreeBSD.org>2006-06-06 21:47:15 +0800
commitd477c4c5d03410fa8780f91594ae5b95e0246d41 (patch)
tree2dfc70b747954ae5f291470b3ce8d8634882965e
parenta9af81284954eba584b776712abbcf909f977523 (diff)
downloadfreebsd-ports-gnome-d477c4c5d03410fa8780f91594ae5b95e0246d41.tar.gz
freebsd-ports-gnome-d477c4c5d03410fa8780f91594ae5b95e0246d41.tar.zst
freebsd-ports-gnome-d477c4c5d03410fa8780f91594ae5b95e0246d41.zip
Add p5-Catalyst-View-HTML-Template-Compiled 0.08,
HTML::Template::Compiled View Class. PR: ports/98564 Submitted by: Zach Thompson <hideo@lastamericanempire.com> Approved by: erwin (mentor)
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-View-HTML-Template-Compiled/Makefile34
-rw-r--r--www/p5-Catalyst-View-HTML-Template-Compiled/distinfo3
-rw-r--r--www/p5-Catalyst-View-HTML-Template-Compiled/pkg-descr3
-rw-r--r--www/p5-Catalyst-View-HTML-Template-Compiled/pkg-plist14
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9cc2b9c4f54a..c16a6ad18ee9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -559,6 +559,7 @@
SUBDIR += p5-Catalyst-Plugin-XMLRPC
SUBDIR += p5-Catalyst-View-GraphViz
SUBDIR += p5-Catalyst-View-HTML-Template
+ SUBDIR += p5-Catalyst-View-HTML-Template-Compiled
SUBDIR += p5-Catalyst-View-JSON
SUBDIR += p5-Catalyst-View-Mason
SUBDIR += p5-Catalyst-View-TT
diff --git a/www/p5-Catalyst-View-HTML-Template-Compiled/Makefile b/www/p5-Catalyst-View-HTML-Template-Compiled/Makefile
new file mode 100644
index 000000000000..3da1a7661210
--- /dev/null
+++ b/www/p5-Catalyst-View-HTML-Template-Compiled/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: www/p5-Catalyst-View-HTML-Template-Compiled
+# Date created: 05 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-HTML-Template-Compiled
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= HTML::Template::Compiled View Class
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Template/Compiled.pm:${PORTSDIR}/www/p5-HTML-Template-Compiled \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::HTML::Template::Compiled.3 \
+ Catalyst::View::HTML::Template::Compiled.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-View-HTML-Template-Compiled/distinfo b/www/p5-Catalyst-View-HTML-Template-Compiled/distinfo
new file mode 100644
index 000000000000..7aa2f9df8681
--- /dev/null
+++ b/www/p5-Catalyst-View-HTML-Template-Compiled/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-HTML-Template-Compiled-0.08.tar.gz) = 0398ee0c3c448825174f17b073b36df6
+SHA256 (Catalyst-View-HTML-Template-Compiled-0.08.tar.gz) = 3179a09b4f673283fa55ed01f29cea8412120180b5261780ea22299fda0c9132
+SIZE (Catalyst-View-HTML-Template-Compiled-0.08.tar.gz) = 3842
diff --git a/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-descr b/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-descr
new file mode 100644
index 000000000000..4797a3cf2876
--- /dev/null
+++ b/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-descr
@@ -0,0 +1,3 @@
+HTML::Template::Compiled view class for Catalyst
+
+WWW: http://search.cpan.org/dist/Catalyst-View-HTML-Template-Compiled/
diff --git a/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-plist b/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-plist
new file mode 100644
index 000000000000..c1b905958684
--- /dev/null
+++ b/www/p5-Catalyst-View-HTML-Template-Compiled/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Catalyst/Helper/View/HTML/Template/Compiled.pm
+%%SITE_PERL%%/Catalyst/View/HTML/Template/Compiled.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/HTML/Template/Compiled/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/HTML/Template/Compiled
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/HTML/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View/HTML/Template
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View/HTML
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper
+@dirrmtry %%SITE_PERL%%/Catalyst/View/HTML/Template
+@dirrmtry %%SITE_PERL%%/Catalyst/View/HTML
+@dirrmtry %%SITE_PERL%%/Catalyst/View