aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-04-12 05:21:24 +0800
committerkwm <kwm@FreeBSD.org>2015-04-12 05:21:24 +0800
commitd4b0726ce94628a6ab1d88174b2a0da0a6cfb97e (patch)
treed0e93016c9a8b24518398d333e163d973b8c5a42
parent88392de46e5d6982cd157c99cd39fb5a8bbbcbfc (diff)
downloadfreebsd-ports-gnome-d4b0726ce94628a6ab1d88174b2a0da0a6cfb97e.tar.gz
freebsd-ports-gnome-d4b0726ce94628a6ab1d88174b2a0da0a6cfb97e.tar.zst
freebsd-ports-gnome-d4b0726ce94628a6ab1d88174b2a0da0a6cfb97e.zip
Fix "amd64" hardcode in java library path lookup and regen the
.class file which configure uses to figure out java setting. In theory this should fix other archs too if java ever gets ported. Annoyed by: pkg-fallout mails
-rw-r--r--databases/libgda5/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/databases/libgda5/Makefile b/databases/libgda5/Makefile
index da148ab40947..54c5b6bd3347 100644
--- a/databases/libgda5/Makefile
+++ b/databases/libgda5/Makefile
@@ -107,6 +107,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|<db\.h>|<db${BDB_VER}/db.h>|' \
${WRKSRC}/providers/bdb/gda-bdb-provider.c \
${WRKSRC}/providers/bdb/gda-bdb-test.c
+ @${REINPLACE_CMD} -e 's|lib/amd64|lib/${ARCH}|g' \
+ ${WRKSRC}/getsp.java
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/javac getsp.java
.if ${LIBGDA5_SLAVE}!="no"
@${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} \
-e 's|$$(top_builddir)/libgda/libgda-5.0.la|-lgda-5.0|g' \