aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-05-08 23:38:53 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-05-08 23:38:53 +0800
commitd685593f0ed932df73331cb284681f4c769a6812 (patch)
tree7eebb5f3fde4b7fd6e8d96ceda449fe38ada98d1
parentba52663214ec07446bd50f230e3cba84b5723c8a (diff)
downloadfreebsd-ports-gnome-d685593f0ed932df73331cb284681f4c769a6812.tar.gz
freebsd-ports-gnome-d685593f0ed932df73331cb284681f4c769a6812.tar.zst
freebsd-ports-gnome-d685593f0ed932df73331cb284681f4c769a6812.zip
- USE_APACHE=yes is deprecated
- Convert to AP_FAST_BUILD/AP_GENPLIST - Fix NOPORTEXAMPLES - Bump PORTREVISION PR: ports/133642 Approved by: maintainer timeout (30 days) Submitted by: me
-rw-r--r--www/mod_auth_pam/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/www/mod_auth_pam/Makefile b/www/mod_auth_pam/Makefile
index c010ee2176a0..27c7900c1c17 100644
--- a/www/mod_auth_pam/Makefile
+++ b/www/mod_auth_pam/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_auth_pam
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/ \
http://atreides.freenix.no/~anders/
@@ -14,23 +15,27 @@ MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= Allows users to use PAM modules for user authentication
-USE_APACHE= yes
+USE_APACHE= 1.3
-.include <bsd.port.pre.mk>
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
-do-build:
- @cd ${WRKSRC} && \
- ${APXS} -c -lpam mod_auth_pam.c
+AP_LIB= -lpam
-do-install:
- ${APXS} -i -A -n auth_pam ${WRKSRC}/mod_auth_pam.so
+PORTDOCS= configure.txt faq.txt
+PORTEXAMPLES= dot-htaccess httpd-
+
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} -p -m 0755 ${DOCSDIR}/samples
+ ${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/configure.txt ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/faq.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/samples/dot-htaccess ${DOCSDIR}/samples/
- ${INSTALL_DATA} ${WRKSRC}/samples/httpd- ${DOCSDIR}/samples/httpd
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/samples/dot-htaccess ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/samples/httpd- ${EXAMPLESDIR}/
.endif
${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>