aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-05-31 01:02:42 +0800
committermi <mi@FreeBSD.org>2015-05-31 01:02:42 +0800
commitd75ab8e4cba1a24a6aa0067f77b78d085c76bf51 (patch)
tree01df9519c21e27c285de292381b2cb9a58ee9bc3
parentaeca15a1f3c0b9a75de13503e9df70ab3d61ed54 (diff)
downloadfreebsd-ports-gnome-d75ab8e4cba1a24a6aa0067f77b78d085c76bf51.tar.gz
freebsd-ports-gnome-d75ab8e4cba1a24a6aa0067f77b78d085c76bf51.tar.zst
freebsd-ports-gnome-d75ab8e4cba1a24a6aa0067f77b78d085c76bf51.zip
Do not automatically run tests post-build.
Remove dependency on memchan -- the package is only needed for testing. This will avoid the tcllib->critcil->tcl-trf->tcl-memchan->tcllib circular dependency discussed in PR: 200498
-rw-r--r--devel/tcl-trf/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index f701e7692179..c1474d90eb41 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -12,8 +12,6 @@ DISTNAME= trf${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
COMMENT= Data conversion, digests, compression, error-correction for Tcl
-BUILD_DEPENDS= ${LOCALBASE}/lib/Memchan2.3/pkgIndex.tcl:${PORTSDIR}/devel/tcl-memchan
-
ALL_TARGET= all
USES+= tcl tar:bzip2
@@ -60,7 +58,12 @@ do-install:
${INSTALL_MAN} $$m ${STAGEDIR}${MANNPREFIX}/man/mann/ ;\
done
-check regression-test post-build test:
+check regression-test test:
+ @if ! ${PKG_BIN} info --quiet tcl-memchan; then \
+ ${PRINTF} "*****************\n%s\n*****************\n" \
+ "devel/tcl-memchan must be installed for the tests to work"; \
+ exit 1; \
+ fi
cd ${WRKSRC}/tests && ${SETENV} TCLLIBPATH="${WRKSRC}" ${TCLSH} all
.include <bsd.port.pre.mk>