aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-01-10 02:45:14 +0800
committerantoine <antoine@FreeBSD.org>2017-01-10 02:45:14 +0800
commitd7f41137e679e935385c4fde46a9d03a65278783 (patch)
tree6dcbb8aefa05522fb5b3746e1e96ec6f644a69db
parent6ed09be3865048dc35030e512a5f40db34c3bc17 (diff)
downloadfreebsd-ports-gnome-d7f41137e679e935385c4fde46a9d03a65278783.tar.gz
freebsd-ports-gnome-d7f41137e679e935385c4fde46a9d03a65278783.tar.zst
freebsd-ports-gnome-d7f41137e679e935385c4fde46a9d03a65278783.zip
New port: devel/py-testpath
Test utilities for Python code working with files and commands. WWW: https://github.com/jupyter/testpath
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-testpath/Makefile35
-rw-r--r--devel/py-testpath/distinfo3
-rw-r--r--devel/py-testpath/files/setup.py13
-rw-r--r--devel/py-testpath/pkg-descr3
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2846e8ebca46..3f22bfb2b771 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4664,6 +4664,7 @@
SUBDIR += py-termstyle
SUBDIR += py-testgears
SUBDIR += py-testoob
+ SUBDIR += py-testpath
SUBDIR += py-testtools
SUBDIR += py-tgMochiKit
SUBDIR += py-thrift
diff --git a/devel/py-testpath/Makefile b/devel/py-testpath/Makefile
new file mode 100644
index 000000000000..b1d9aa8bb61c
--- /dev/null
+++ b/devel/py-testpath/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= testpath
+PORTVERSION= 0.3
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Test utilities for Python code working with files and commands
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= jupyter
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib>=0:devel/py-pathlib
+.endif
+
+post-extract:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-testpath/distinfo b/devel/py-testpath/distinfo
new file mode 100644
index 000000000000..335dfebeb5f4
--- /dev/null
+++ b/devel/py-testpath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483907649
+SHA256 (jupyter-testpath-0.3_GH0.tar.gz) = 01cc3cd59a59d42b238252774b9ebfc9d2af1d0d9bac81d7801409f570b1cda5
+SIZE (jupyter-testpath-0.3_GH0.tar.gz) = 91250
diff --git a/devel/py-testpath/files/setup.py b/devel/py-testpath/files/setup.py
new file mode 100644
index 000000000000..9fc1264e4599
--- /dev/null
+++ b/devel/py-testpath/files/setup.py
@@ -0,0 +1,13 @@
+
+from setuptools import setup, find_packages
+
+setup(
+ name='testpath',
+ version='0.3',
+ description='Test utilities for Python code working with files and commands',
+ url='https://github.com/jupyter/testpath',
+ author='The Jupyter Development Team',
+ license='MIT',
+ long_description='Test utilities for Python code working with files and commands',
+ packages=find_packages(exclude=['tests'])
+)
diff --git a/devel/py-testpath/pkg-descr b/devel/py-testpath/pkg-descr
new file mode 100644
index 000000000000..f9720054a860
--- /dev/null
+++ b/devel/py-testpath/pkg-descr
@@ -0,0 +1,3 @@
+Test utilities for Python code working with files and commands.
+
+WWW: https://github.com/jupyter/testpath