aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-12-07 00:14:27 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-12-07 00:14:27 +0800
commitd82451323dc5e8eba0cbda27b57861e406230aa9 (patch)
treea98027f23e7a47f0d9c78f1d0db5ca35cb576d12
parent75d94cb56bb047e199c3032c216a9d85e51ca08b (diff)
downloadfreebsd-ports-gnome-d82451323dc5e8eba0cbda27b57861e406230aa9.tar.gz
freebsd-ports-gnome-d82451323dc5e8eba0cbda27b57861e406230aa9.tar.zst
freebsd-ports-gnome-d82451323dc5e8eba0cbda27b57861e406230aa9.zip
- Fix build on 8.x
With hat: portmgr
-rw-r--r--ports-mgmt/pkg-devel/files/patch-libpkg__Makefile14
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__Makefile14
2 files changed, 28 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-devel/files/patch-libpkg__Makefile b/ports-mgmt/pkg-devel/files/patch-libpkg__Makefile
new file mode 100644
index 000000000000..8cd27109f71b
--- /dev/null
+++ b/ports-mgmt/pkg-devel/files/patch-libpkg__Makefile
@@ -0,0 +1,14 @@
+--- ./libpkg/Makefile.orig 2013-12-06 10:09:09.945131112 -0600
++++ ./libpkg/Makefile 2013-12-06 10:10:36.944131558 -0600
+@@ -255,3 +255,11 @@
+ sed -e "s,__PREFIX__,${PREFIX},g" \
+ -e "s,__VERSION__,${PKGVERSION},g" \
+ ${.IMPSRC} > ${.TARGET}
++
++# Workaround 8.3/8.4 bug
++OSVERSION!= /sbin/sysctl -n kern.osreldate
++
++.if ${OSVERSION} < 901000
++.c.o:
++ ${CC} ${STATIC_CFLAGS} ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
++.endif
diff --git a/ports-mgmt/pkg/files/patch-libpkg__Makefile b/ports-mgmt/pkg/files/patch-libpkg__Makefile
new file mode 100644
index 000000000000..8cd27109f71b
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__Makefile
@@ -0,0 +1,14 @@
+--- ./libpkg/Makefile.orig 2013-12-06 10:09:09.945131112 -0600
++++ ./libpkg/Makefile 2013-12-06 10:10:36.944131558 -0600
+@@ -255,3 +255,11 @@
+ sed -e "s,__PREFIX__,${PREFIX},g" \
+ -e "s,__VERSION__,${PKGVERSION},g" \
+ ${.IMPSRC} > ${.TARGET}
++
++# Workaround 8.3/8.4 bug
++OSVERSION!= /sbin/sysctl -n kern.osreldate
++
++.if ${OSVERSION} < 901000
++.c.o:
++ ${CC} ${STATIC_CFLAGS} ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
++.endif