aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-05-08 23:47:15 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-05-08 23:47:15 +0800
commitd8481bd550bc0ad9c5ff4917d265c2071826df63 (patch)
tree370e21025bf184ba258b4606eb3c8173f3c32ce6
parentd68b4bd7ca13f146581f71db04c65ed8dc2c144f (diff)
downloadfreebsd-ports-gnome-d8481bd550bc0ad9c5ff4917d265c2071826df63.tar.gz
freebsd-ports-gnome-d8481bd550bc0ad9c5ff4917d265c2071826df63.tar.zst
freebsd-ports-gnome-d8481bd550bc0ad9c5ff4917d265c2071826df63.zip
- USE_APACHE=yes is deprecated
- Convert to AP_FAST_BUILD/AP_GENPLIST PR: ports/133647 Approved by: maintainer timeout (30 days) Submitted by: me
-rw-r--r--www/mod_extract_forwarded/Makefile20
-rw-r--r--www/mod_extract_forwarded/pkg-plist6
-rw-r--r--www/mod_extract_forwarded_ap13/Makefile20
-rw-r--r--www/mod_extract_forwarded_ap13/pkg-plist6
4 files changed, 20 insertions, 32 deletions
diff --git a/www/mod_extract_forwarded/Makefile b/www/mod_extract_forwarded/Makefile
index f5c06506c7a0..8951f2336da1 100644
--- a/www/mod_extract_forwarded/Makefile
+++ b/www/mod_extract_forwarded/Makefile
@@ -8,25 +8,25 @@
PORTNAME= mod_extract_forwarded
PORTVERSION= 1.4
CATEGORIES= www
-MASTER_SITES= http://web.warhound.org/mod_extract_forwarded/ \
+MASTER_SITES= http://web.warhound.org/${PORTNAME}/ \
http://atreides.freenix.no/~anders/
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module that can make proxied requests appear with client IP
-USE_APACHE= yes
+USE_APACHE= 1.3
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-DOCS= doc.html README
-do-build:
- cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+PORTDOCS= doc.html README
-do-install:
- cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so
+post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}
+ ${MKDIR} ${DOCSDIR}/
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
.endif
${CAT} ${PKGMESSAGE}
diff --git a/www/mod_extract_forwarded/pkg-plist b/www/mod_extract_forwarded/pkg-plist
deleted file mode 100644
index 012a5a22a315..000000000000
--- a/www/mod_extract_forwarded/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-libexec/apache/mod_extract_forwarded.so
-@exec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
-@unexec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
-%%PORTDOCS%%share/doc/mod_extract_forwarded/doc.html
-%%PORTDOCS%%share/doc/mod_extract_forwarded/README
-%%PORTDOCS%%@dirrm share/doc/mod_extract_forwarded
diff --git a/www/mod_extract_forwarded_ap13/Makefile b/www/mod_extract_forwarded_ap13/Makefile
index f5c06506c7a0..8951f2336da1 100644
--- a/www/mod_extract_forwarded_ap13/Makefile
+++ b/www/mod_extract_forwarded_ap13/Makefile
@@ -8,25 +8,25 @@
PORTNAME= mod_extract_forwarded
PORTVERSION= 1.4
CATEGORIES= www
-MASTER_SITES= http://web.warhound.org/mod_extract_forwarded/ \
+MASTER_SITES= http://web.warhound.org/${PORTNAME}/ \
http://atreides.freenix.no/~anders/
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module that can make proxied requests appear with client IP
-USE_APACHE= yes
+USE_APACHE= 1.3
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-DOCS= doc.html README
-do-build:
- cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+PORTDOCS= doc.html README
-do-install:
- cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so
+post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}
+ ${MKDIR} ${DOCSDIR}/
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
.endif
${CAT} ${PKGMESSAGE}
diff --git a/www/mod_extract_forwarded_ap13/pkg-plist b/www/mod_extract_forwarded_ap13/pkg-plist
deleted file mode 100644
index 012a5a22a315..000000000000
--- a/www/mod_extract_forwarded_ap13/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-libexec/apache/mod_extract_forwarded.so
-@exec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
-@unexec %D/sbin/apxs -e -A -n extract_forwarded %D/%F
-%%PORTDOCS%%share/doc/mod_extract_forwarded/doc.html
-%%PORTDOCS%%share/doc/mod_extract_forwarded/README
-%%PORTDOCS%%@dirrm share/doc/mod_extract_forwarded