aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 13:26:09 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 13:26:09 +0800
commitd967fe50b8483a58d85a9f31dc0100d2fd0cb930 (patch)
tree683f1300b5375158bec0c56414a0b1a0e21882d5
parentfe5f4526f7c2ef14b2e1c8703eb5899764793dcf (diff)
downloadfreebsd-ports-gnome-d967fe50b8483a58d85a9f31dc0100d2fd0cb930.tar.gz
freebsd-ports-gnome-d967fe50b8483a58d85a9f31dc0100d2fd0cb930.tar.zst
freebsd-ports-gnome-d967fe50b8483a58d85a9f31dc0100d2fd0cb930.zip
games/frobtads: unbreak with clang 4.0
tads3/vmtz.cpp:1987:30: error: ordered comparison between pointer and zero ('vmtz_trans *' and 'int') result->set(tcur > 0 ? tcur - 1 : tcur); ~~~~ ^ ~ PR: 216357 Reported by: antoine (via exp-run) Submitted by: kaiwang27@gmail.com (maintainer)
-rw-r--r--games/frobtads/Makefile1
-rw-r--r--games/frobtads/files/patch-tads3_vmtz.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/frobtads/Makefile b/games/frobtads/Makefile
index 454eaaef1b84..8d7c4c4e0b42 100644
--- a/games/frobtads/Makefile
+++ b/games/frobtads/Makefile
@@ -3,6 +3,7 @@
PORTNAME= frobtads
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= games lang
MASTER_SITES= http://www.tads.org/${PORTNAME}/ \
http://www.ifarchive.org/if-archive/programming/tads3/source/
diff --git a/games/frobtads/files/patch-tads3_vmtz.cpp b/games/frobtads/files/patch-tads3_vmtz.cpp
new file mode 100644
index 000000000000..b75a5ad54629
--- /dev/null
+++ b/games/frobtads/files/patch-tads3_vmtz.cpp
@@ -0,0 +1,11 @@
+--- tads3/vmtz.cpp.orig 2013-05-17 19:46:51 UTC
++++ tads3/vmtz.cpp
+@@ -1984,7 +1984,7 @@ void CVmTimeZone::query(vmtzquery *resul
+ * the transition in terms of the local time that was in effect
+ * up until that moment
+ */
+- result->set(tcur > 0 ? tcur - 1 : tcur);
++ result->set(cur > 0 ? tcur - 1 : tcur);
+ return;
+ }
+ }