aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-24 00:45:35 +0800
committerbapt <bapt@FreeBSD.org>2014-09-24 00:45:35 +0800
commitd9d0423b4f035aed62096cedbca8d218206d6f65 (patch)
tree7bca8025361a679ac757241a16b366bc0766debf
parent1e6952bbb33c8148c39252655033f15a60d85e86 (diff)
downloadfreebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.tar.gz
freebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.tar.zst
freebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.zip
Convert to USES=pear
-rw-r--r--mail/pear-Contact_Vcard_Build/Makefile9
-rw-r--r--mail/pear-Contact_Vcard_Parse/Makefile9
-rw-r--r--mail/pear-MIME_Type/Makefile13
-rw-r--r--mail/pear-Mail/Makefile13
-rw-r--r--mail/pear-Mail_Mbox/Makefile9
-rw-r--r--mail/pear-Mail_Mime/Makefile9
-rw-r--r--mail/pear-Mail_Queue/Makefile19
-rw-r--r--mail/pear-Mail_mimeDecode/Makefile12
-rw-r--r--mail/pear-Net_Cyrus/Makefile6
-rw-r--r--mail/pear-Net_IMAP/Makefile6
-rw-r--r--mail/pear-Net_LMTP/Makefile6
-rw-r--r--math/pear-Math_BigInteger/Makefile9
-rw-r--r--math/pear-Math_Combinatorics/Makefile9
-rw-r--r--misc/pear-Services_Weather/Makefile34
-rw-r--r--misc/pear-Text_Figlet/Makefile9
15 files changed, 39 insertions, 133 deletions
diff --git a/mail/pear-Contact_Vcard_Build/Makefile b/mail/pear-Contact_Vcard_Build/Makefile
index f83f54bc6997..ad5b3a71db9f 100644
--- a/mail/pear-Contact_Vcard_Build/Makefile
+++ b/mail/pear-Contact_Vcard_Build/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= mail www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to build (create) and fetch vCard 2.1 and 3.0 text blocks
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Contact_Vcard_Parse/Makefile b/mail/pear-Contact_Vcard_Parse/Makefile
index 05c0aea65798..84dbc5fad082 100644
--- a/mail/pear-Contact_Vcard_Parse/Makefile
+++ b/mail/pear-Contact_Vcard_Parse/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= mail www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to parse vCard 2.1 and 3.0 files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-MIME_Type/Makefile b/mail/pear-MIME_Type/Makefile
index 48554f8b80c5..0e2cfb03878e 100644
--- a/mail/pear-MIME_Type/Makefile
+++ b/mail/pear-MIME_Type/Makefile
@@ -8,20 +8,11 @@ CATEGORIES= mail www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for dealing with MIME types
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
-LATEST_LINK= pear-${PORTNAME}
OPTIONS_DEFINE= PEAR_SYSTEM_COMMAND
PEAR_SYSTEM_COMMAND_DESC= PEAR::System_Command support
-PEAR_AUTOINSTALL=yes
-
-.include <bsd.port.options.mk>
+USES= pear
-.if ${PORT_OPTIONS:MPEAR_SYSTEM_COMMAND}
-RUN_DEPENDS+= ${PEARDIR}/System/Command.php:${PORTSDIR}/devel/pear-System_Command
-.endif
+PEAR_SYSTEM_COMMAND_RUN_DEPENDS= ${PEARDIR}/System/Command.php:${PORTSDIR}/devel/pear-System_Command
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/mail/pear-Mail/Makefile b/mail/pear-Mail/Makefile
index 1ee1909fa3be..f95970d6dfab 100644
--- a/mail/pear-Mail/Makefile
+++ b/mail/pear-Mail/Makefile
@@ -9,20 +9,11 @@ CATEGORIES= mail www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class that provides multiple interfaces for sending emails
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
-PEAR_AUTOINSTALL= yes
-
-LATEST_LINK= pear-${PORTNAME}
OPTIONS_DEFINE= PEAR_NET_SMTP
PEAR_NET_SMTP_DESC= PEAR::Net_SMTP support
-.include <bsd.port.options.mk>
+USES= pear
-.if ${PORT_OPTIONS:MPEAR_NET_SMTP}
-RUN_DEPENDS+= ${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
-.endif
+PEAR_NET_SMTP_RUN_DEPENDS= ${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/mail/pear-Mail_Mbox/Makefile b/mail/pear-Mail_Mbox/Makefile
index f20d6da87a32..aea3d202e32b 100644
--- a/mail/pear-Mail_Mbox/Makefile
+++ b/mail/pear-Mail_Mbox/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= mail www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR Read and modify Unix MBOXes
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Mail_Mime/Makefile b/mail/pear-Mail_Mime/Makefile
index e3dece6e27e9..22f8ba1f631a 100644
--- a/mail/pear-Mail_Mime/Makefile
+++ b/mail/pear-Mail_Mime/Makefile
@@ -11,11 +11,6 @@ COMMENT= PEAR classes to create and decode MIME messages
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Mail_Queue/Makefile b/mail/pear-Mail_Queue/Makefile
index 0d795959539f..5cb86ae305b0 100644
--- a/mail/pear-Mail_Queue/Makefile
+++ b/mail/pear-Mail_Queue/Makefile
@@ -13,26 +13,15 @@ BUILD_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
RUN_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
-PEAR_AUTOINSTALL= yes
+USES= pear
OPTIONS_DEFINE= PEAR_DB PEAR_MDB PEAR_MDB2
PEAR_DB_DESC= PEAR::DB support
PEAR_MDB_DESC= PEAR::MDB support
PEAR_MDB2_DESC= PEAR::MDB2 support
-.include <bsd.port.options.mk>
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/mail/pear-Mail_mimeDecode/Makefile b/mail/pear-Mail_mimeDecode/Makefile
index d85a4c4986de..093b6c18b926 100644
--- a/mail/pear-Mail_mimeDecode/Makefile
+++ b/mail/pear-Mail_mimeDecode/Makefile
@@ -9,15 +9,11 @@ DISTNAME= Mail_mimeDecode-${PORTVERSION}
MAINTAINER= joehorn@gmail.com
COMMENT= Provides a class to decode mime messages
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+RUN_DEPENDS= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
LICENSE= BSD
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Net_Cyrus/Makefile b/mail/pear-Net_Cyrus/Makefile
index 1b12db96afc8..f6f144145788 100644
--- a/mail/pear-Net_Cyrus/Makefile
+++ b/mail/pear-Net_Cyrus/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Net/IMAP.php:${PORTSDIR}/mail/pear-Net_IMAP
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Net_IMAP/Makefile b/mail/pear-Net_IMAP/Makefile
index 0d40bf3f52b8..6162292fa79b 100644
--- a/mail/pear-Net_IMAP/Makefile
+++ b/mail/pear-Net_IMAP/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/pear-Net_LMTP/Makefile b/mail/pear-Net_LMTP/Makefile
index b08ce4fb2eaf..00c8980628e2 100644
--- a/mail/pear-Net_LMTP/Makefile
+++ b/mail/pear-Net_LMTP/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR implementation of the RFC2033 LMTP protocol
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/pear-Math_BigInteger/Makefile b/math/pear-Math_BigInteger/Makefile
index b2fca2b3233b..6a276c3c334a 100644
--- a/math/pear-Math_BigInteger/Makefile
+++ b/math/pear-Math_BigInteger/Makefile
@@ -8,12 +8,7 @@ CATEGORIES= math pear
MAINTAINER= meritus@innervision.pl
COMMENT= Pure-PHP arbitrary precision integer arithmetic library
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
USE_PHP= pcre
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/pear-Math_Combinatorics/Makefile b/math/pear-Math_Combinatorics/Makefile
index 72d3238b719c..df936d62df68 100644
--- a/math/pear-Math_Combinatorics/Makefile
+++ b/math/pear-Math_Combinatorics/Makefile
@@ -9,11 +9,6 @@ CATEGORIES= math pear
MAINTAINER= ports@FreeBSD.org
COMMENT= Package that produces combinations and permutations
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/pear-Services_Weather/Makefile b/misc/pear-Services_Weather/Makefile
index 203b9fd23d8b..7d23833bd03e 100644
--- a/misc/pear-Services_Weather/Makefile
+++ b/misc/pear-Services_Weather/Makefile
@@ -9,13 +9,10 @@ CATEGORIES= misc www pear geography
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR interface to various online weather-services
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
USE_PHP= ctype pcre
-LATEST_LINK= pear-Services_Weather
OPTIONS_DEFINE= PEAR_NET_FTP PEAR_CACHE PEAR_DB PEAR_SOAP PEAR_XML_SERIALIZER
PEAR_NET_FTP_DESC= PEAR::Net::FTP support
PEAR_CACHE_DESC= PEAR::Cache support
@@ -23,29 +20,12 @@ PEAR_DB_DESC= PEAR::DB support
PEAR_SOAP_DESC= PEAR::SOAP support
PEAR_XML_SERIALIZER_DESC= PEAR::XML::Serializer support
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.options.mk>
+PEAR_NET_FTP_BUILD_DEPENDS= ${PEARDIR}/Net/FTP.php:${PORTSDIR}/ftp/pear-Net_FTP
+PEAR_CACHE_BUILD_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
+PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_SOAP_BUILD_DEPENDS= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+PEAR_XML_SERIALIZER_BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-.if ${PORT_OPTIONS:MPEAR_NET_FTP}
-BUILD_DEPENDS+= ${PEARDIR}/Net/FTP.php:${PORTSDIR}/ftp/pear-Net_FTP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CACHE}
-BUILD_DEPENDS+= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_SOAP}
-BUILD_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_XML_SERIALIZER}
-BUILD_DEPENDS+= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/misc/pear-Text_Figlet/Makefile b/misc/pear-Text_Figlet/Makefile
index bb146cc13027..826ba2c76db3 100644
--- a/misc/pear-Text_Figlet/Makefile
+++ b/misc/pear-Text_Figlet/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= misc www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Render text using FIGlet fonts
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>