aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-06 16:57:04 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-06 16:57:04 +0800
commitdb5a4527cdda2af1803b9ad5b359743da03e5670 (patch)
tree3bf38763aefc904de259e12f2726bfba13b6f5b6
parent7479342d2f58c838b4295282d79855f9139adaf2 (diff)
downloadfreebsd-ports-gnome-db5a4527cdda2af1803b9ad5b359743da03e5670.tar.gz
freebsd-ports-gnome-db5a4527cdda2af1803b9ad5b359743da03e5670.tar.zst
freebsd-ports-gnome-db5a4527cdda2af1803b9ad5b359743da03e5670.zip
- Pass environment to the compiler, fixing build with ccache
- Fix WWW: - Unsilence installation Approved by: portmgr blanket
-rw-r--r--devel/godot/Makefile2
-rw-r--r--devel/godot/files/patch-SConstruct9
-rw-r--r--devel/godot/pkg-descr2
3 files changed, 11 insertions, 2 deletions
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index eb4dc55fe96f..bc12a46c15b3 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -79,7 +79,7 @@ post-patch:
# We just want a simple name matching the portname
# This gives us bin/godot for runtime and bin/godot-tools for the IDE
do-install:
- @cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} godot.x11* \
+ cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} godot.x11* \
${STAGEDIR}/${PREFIX}/bin/${GODOTFILE}
do-install-EXAMPLES-on:
diff --git a/devel/godot/files/patch-SConstruct b/devel/godot/files/patch-SConstruct
index 545e84118aa4..5c8981083d67 100644
--- a/devel/godot/files/patch-SConstruct
+++ b/devel/godot/files/patch-SConstruct
@@ -1,5 +1,14 @@
--- SConstruct.orig 2016-08-09 07:52:15 UTC
+++ SConstruct
+@@ -63,7 +63,7 @@ elif (os.name=="nt"):
+ if (os.getenv("VSINSTALLDIR")==None or platform_arg=="android"):
+ custom_tools=['mingw']
+
+-env_base=Environment(tools=custom_tools);
++env_base=Environment(tools=custom_tools, ENV = os.environ);
+ env_base.AppendENVPath('PATH', os.getenv('PATH'))
+ env_base.AppendENVPath('PKG_CONFIG_PATH', os.getenv('PKG_CONFIG_PATH'))
+ env_base.global_defaults=global_defaults
@@ -231,15 +231,17 @@ if selected_platform in platform_list:
if env["extra_suffix"] != '' :
env.extra_suffix += '.'+env["extra_suffix"]
diff --git a/devel/godot/pkg-descr b/devel/godot/pkg-descr
index c2c98d6198da..4046e7f7d0ca 100644
--- a/devel/godot/pkg-descr
+++ b/devel/godot/pkg-descr
@@ -3,4 +3,4 @@ development environment.
Easily deploy your game on IOS, android, OSX, Linux, Steam, Windows or PS3.
-WWW: http://www.godotengine.org
+WWW: http://www.godotengine.org/