aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-06-29 21:13:28 +0800
committerperky <perky@FreeBSD.org>2004-06-29 21:13:28 +0800
commitde6b973dc8e1b2224ec11b4922e90abe4e44ceac (patch)
tree6d380ab215a68bd9d6c1a4787b7f09f1fd43da28
parent35edf27d20a92563371d44a88b8a50532de106b1 (diff)
downloadfreebsd-ports-gnome-de6b973dc8e1b2224ec11b4922e90abe4e44ceac.tar.gz
freebsd-ports-gnome-de6b973dc8e1b2224ec11b4922e90abe4e44ceac.tar.zst
freebsd-ports-gnome-de6b973dc8e1b2224ec11b4922e90abe4e44ceac.zip
- Update to 1.2a1 (port version 1.2.a1)
- Assign maintainership to submitter. PR: 68353 Submitted by: Dryice Liu <dryice@liu.com.cn>
-rw-r--r--www/mod_scgi/Makefile28
-rw-r--r--www/mod_scgi/distinfo4
-rw-r--r--www/mod_scgi/files/patch-apache2-Makefile11
-rw-r--r--www/mod_scgi/pkg-message3
-rw-r--r--www/mod_scgi/pkg-plist2
5 files changed, 37 insertions, 11 deletions
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 84d17f87c349..fbb260065cc5 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -6,20 +6,32 @@
#
PORTNAME= scgi
-PORTVERSION= 0.2
+PORTVERSION= 1.2.a2
CATEGORIES= www
MASTER_SITES= http://www.mems-exchange.org/software/files/scgi/
PKGNAMEPREFIX= mod_
+DISTNAME= scgi-${PORTVERSION:S/.a/a/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dryice@liu.com.cn
COMMENT= Apache module that implements the client side of the SCGI protocol
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+USE_APACHE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${APACHE_DIR}
-do-build:
- cd ${WRKSRC} && ${APXS} -c -o mod_scgi.so mod_scgi.c
+.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/include/apache2/apr.h)
+WITH_APACHE2= yes
+.endif
-do-install:
- cd ${WRKSRC} && ${APXS} -i -a mod_scgi.so
+.if defined(WITH_APACHE2)
+APACHE_DIR= apache2
+PLIST_SUB= APACHE_DIR=apache2
+.else
+APACHE_DIR= apache1
+PLIST_SUB= APACHE_DIR=apache
+.endif
-.include <bsd.port.mk>
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_scgi/distinfo b/www/mod_scgi/distinfo
index 5b2f4aedf9d3..ac9a3388bc6e 100644
--- a/www/mod_scgi/distinfo
+++ b/www/mod_scgi/distinfo
@@ -1,2 +1,2 @@
-MD5 (scgi-0.2.tar.gz) = 586892ad689e31383c21267590474f89
-SIZE (scgi-0.2.tar.gz) = 11251
+MD5 (scgi-1.2a2.tar.gz) = 7ed218368a2dadaf8773cef944faa0bf
+SIZE (scgi-1.2a2.tar.gz) = 17713
diff --git a/www/mod_scgi/files/patch-apache2-Makefile b/www/mod_scgi/files/patch-apache2-Makefile
new file mode 100644
index 000000000000..0fc8186f5111
--- /dev/null
+++ b/www/mod_scgi/files/patch-apache2-Makefile
@@ -0,0 +1,11 @@
+--- ../apache2/Makefile.orig Sat Jun 26 08:54:08 2004
++++ ../apache2/Makefile Sat Jun 26 08:54:56 2004
+@@ -1,6 +1,6 @@
+
+-APXS=apxs2
+-APACHECTL=apache2ctl
++APXS=apxs
++APACHECTL=apachectl
+
+ all:
+ $(APXS) -c mod_scgi.c
diff --git a/www/mod_scgi/pkg-message b/www/mod_scgi/pkg-message
new file mode 100644
index 000000000000..6f5ae41bdc64
--- /dev/null
+++ b/www/mod_scgi/pkg-message
@@ -0,0 +1,3 @@
+********************************************************************
+* If your mod_scgi seg fault, try disable mod_fastcgi *
+********************************************************************
diff --git a/www/mod_scgi/pkg-plist b/www/mod_scgi/pkg-plist
index dbaad310f427..cae167901264 100644
--- a/www/mod_scgi/pkg-plist
+++ b/www/mod_scgi/pkg-plist
@@ -1,3 +1,3 @@
-libexec/apache/mod_scgi.so
+libexec/%%APACHE_DIR%%/mod_scgi.so
@exec %D/sbin/apxs -e -a -n scgi %f
@unexec %D/sbin/apxs -e -A -n scgi %f