aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2017-04-02 18:34:06 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2017-04-02 18:34:06 +0800
commite05e0724089bc6dde75cd7c79c77960bf6e1bab8 (patch)
tree5edd5470fbc3dc8cdc0b547ac3b21a7d73815b4e
parent236af078e105b84ebe110fd7a3910d4b41485eac (diff)
downloadfreebsd-ports-gnome-e05e0724089bc6dde75cd7c79c77960bf6e1bab8.tar.gz
freebsd-ports-gnome-e05e0724089bc6dde75cd7c79c77960bf6e1bab8.tar.zst
freebsd-ports-gnome-e05e0724089bc6dde75cd7c79c77960bf6e1bab8.zip
print/hplip: Improve option logic for X11, QT4, QT5
If X11 option is disabled, the configure args should not enable QT4 or QT5, and their dependencies should not be added. PR: 218213 Reported by: Tom Francis <thomas.francis.jr@pobox.com> Reviewed by: Kevin Oberman <rkoberman@gmail.com>
-rw-r--r--print/hplip/Makefile32
1 files changed, 22 insertions, 10 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 141b8875ebe1..11fdfec27545 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -62,22 +62,34 @@ SCAN_CONFIGURE_ENABLE= scan-build
X11_DESC= Graphical User Interface (Qt)
X11_CONFIGURE_ENABLE= gui-build
-QT4_USES= pyqt:4
-QT4_USE= PYQT=core_run,dbussupport_run,gui_run
-QT4_CONFIGURE_ENABLE= qt4
-QT4_IMPLIES= X11
-
-QT5_USES= pyqt:5
-QT5_USE= PYQT=core_run,dbussupport_run,gui_run,widgets_run
-QT5_CONFIGURE_ENABLE= qt5
-QT5_IMPLIES= X11
-
XSANE_DESC= Install XSane for scanning (implies SCAN)
XSANE_IMPLIES= SCAN
XSANE_RUN_DEPENDS= xsane:graphics/xsane
DOCS_CONFIGURE_ENABLE= doc-build
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQT4} && ${PORT_OPTIONS:MX11}
+USES+= pyqt:4
+USE_PYQT= core_run dbussupport_run gui_run
+CONFIGURE_ARGS+= --enable-qt4
+.else
+CONFIGURE_ARGS+= --disable-qt4
+.endif
+
+.if ${PORT_OPTIONS:MQT5} && ${PORT_OPTIONS:MX11}
+USES+= pyqt:5
+USE_PYQT= core_run dbussupport_run gui_run widgets_run
+CONFIGURE_ARGS+= --enable-qt5
+.else
+CONFIGURE_ARGS+= --disable-qt5
+.endif
+
+.if ${PORT_OPTIONS:MX11} && ! ${PORT_OPTIONS:MQT4} && ! ${PORT_OPTIONS:MQT5}
+BROKEN= The X11 option requires one of the QT4 or QT5 options
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldld||g;' \
-e 's|-ldl||g' \