aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-03-13 05:01:15 +0800
committerswills <swills@FreeBSD.org>2016-03-13 05:01:15 +0800
commite0e272ef3788cdef96efdf60533c177e63d6cf51 (patch)
tree45c8ba97bd4f66f394d34a89308a04e17569cd64
parenteff22f21ddd2fe100716f2c7a85c8f45dd70c49e (diff)
downloadfreebsd-ports-gnome-e0e272ef3788cdef96efdf60533c177e63d6cf51.tar.gz
freebsd-ports-gnome-e0e272ef3788cdef96efdf60533c177e63d6cf51.tar.zst
freebsd-ports-gnome-e0e272ef3788cdef96efdf60533c177e63d6cf51.zip
textproc/jo: create port
jo creates a JSON string on stdout from words given it as arguments or read from stdin. Without option -a it generates an object whereby each word is a key=value (or key@value) pair with key being the JSON object element and value its value. jo attempts to guess the type of value in order to create number (using strtod(3)), string, or null values in JSON. WWW: https://github.com/jpmens/jo
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/jo/Makefile18
-rw-r--r--textproc/jo/distinfo2
-rw-r--r--textproc/jo/pkg-descr7
4 files changed, 28 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 973d69090654..755c974c01f5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -353,6 +353,7 @@
SUBDIR += jdictionary
SUBDIR += jdictionary-int-eng
SUBDIR += jing
+ SUBDIR += jo
SUBDIR += jq
SUBDIR += jrefentry
SUBDIR += jshon
diff --git a/textproc/jo/Makefile b/textproc/jo/Makefile
new file mode 100644
index 000000000000..adb772492d9a
--- /dev/null
+++ b/textproc/jo/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= jo
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://github.com/jpmens/${PORTNAME}/releases/download/v${PORTVERSION}/
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Small utility to create JSON objects
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/jo man/man1/jo.1.gz
+
+.include <bsd.port.mk>
diff --git a/textproc/jo/distinfo b/textproc/jo/distinfo
new file mode 100644
index 000000000000..ff81b6cfd5a3
--- /dev/null
+++ b/textproc/jo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jo-1.0.tar.gz) = d66ec97258d1afad15643fb2d5b5e807153a732ba45c2417adc66669acbde52e
+SIZE (jo-1.0.tar.gz) = 112488
diff --git a/textproc/jo/pkg-descr b/textproc/jo/pkg-descr
new file mode 100644
index 000000000000..327b7274f961
--- /dev/null
+++ b/textproc/jo/pkg-descr
@@ -0,0 +1,7 @@
+jo creates a JSON string on stdout from words given it as arguments or read
+from stdin. Without option -a it generates an object whereby each word is a
+key=value (or key@value) pair with key being the JSON object element and value
+its value. jo attempts to guess the type of value in order to create number
+(using strtod(3)), string, or null values in JSON.
+
+WWW: https://github.com/jpmens/jo