aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-01 22:20:09 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-01 22:20:09 +0800
commite11f8102f68d7be6e91ddb580f4d2c3423f50d96 (patch)
tree03d4fd4661f013ff9791e3a67271b9da65eb4c43
parent9e2b054eff02071b7e35ab4f7f681c9c20954fe8 (diff)
downloadfreebsd-ports-gnome-e11f8102f68d7be6e91ddb580f4d2c3423f50d96.tar.gz
freebsd-ports-gnome-e11f8102f68d7be6e91ddb580f4d2c3423f50d96.tar.zst
freebsd-ports-gnome-e11f8102f68d7be6e91ddb580f4d2c3423f50d96.zip
- Add LICENSE
- Fix build with clang 4.0 by fixing ordered pointer comparisons
-rw-r--r--games/ri-li/Makefile4
-rw-r--r--games/ri-li/files/patch-src_sprite.cc20
2 files changed, 24 insertions, 0 deletions
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index 0fc76c666b1b..712657f7d0c6 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -10,6 +10,10 @@ MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}%20Linux_Unix/${PORTNAME}%20V${PORTVE
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Drive a toy wood train in many levels - snake-like arcade game
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+
USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
USE_SDL= sdl mixer
diff --git a/games/ri-li/files/patch-src_sprite.cc b/games/ri-li/files/patch-src_sprite.cc
new file mode 100644
index 000000000000..b0da5acfcc2c
--- /dev/null
+++ b/games/ri-li/files/patch-src_sprite.cc
@@ -0,0 +1,20 @@
+--- src/sprite.cc.orig 2007-11-02 11:48:20 UTC
++++ src/sprite.cc
+@@ -351,7 +351,7 @@ bool Sprite::Load(unsigned char *Buf,lon
+ // Fabrique la surface
+ Image[i]=SDL_CreateRGBSurface((Dim[i].bpp-3)*SDL_SRCALPHA,Dim[i].L,Dim[i].H,Dim[i].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[i].bpp-3));
+- if(Image[i]<=NULL) {
++ if(Image[i]==NULL) {
+ cerr <<"Impossible de créer une Surface SDL!"<<endl;
+ return false;
+ }
+@@ -485,7 +485,7 @@ bool Sprite::Nouveau(int Lx,int Ly)
+ // Fabrique la surface
+ Image[0]=SDL_CreateRGBSurface((Dim[0].bpp-3)*SDL_SRCALPHA,Dim[0].L,Dim[0].H,Dim[0].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[0].bpp-3));
+- if(Image[0]<=NULL) {
++ if(Image[0]==NULL) {
+ cerr <<"Impossible de créer une Surface SDL!"<<endl;
+ return false;
+ }