aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2010-06-08 04:33:22 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2010-06-08 04:33:22 +0800
commite1f25f5636acf60b7e76cb09bff7759fd86c03ef (patch)
tree5202cc1f5ff6a2bbf6fe737352d2f1a241a36258
parent44da94e71c6ce6ed6bd3d21b24d7014637ef4874 (diff)
downloadfreebsd-ports-gnome-e1f25f5636acf60b7e76cb09bff7759fd86c03ef.tar.gz
freebsd-ports-gnome-e1f25f5636acf60b7e76cb09bff7759fd86c03ef.tar.zst
freebsd-ports-gnome-e1f25f5636acf60b7e76cb09bff7759fd86c03ef.zip
- Utilise common bsd.squirrelmail.mk
- Add LICENSE - No PORTREVISION bump, as there is no change in functionality Requested by: itetcu
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/Makefile66
-rw-r--r--mail/squirrelmail-login_notes-plugin/Makefile10
-rw-r--r--mail/squirrelmail-pupdate-plugin/Makefile64
-rw-r--r--mail/squirrelmail-secure_login-plugin/Makefile8
-rw-r--r--mail/squirrelmail-timeout_user-plugin/Makefile62
-rw-r--r--mail/squirrelmail-websearch-plugin/Makefile76
6 files changed, 26 insertions, 260 deletions
diff --git a/mail/squirrelmail-change_ldappass-plugin/Makefile b/mail/squirrelmail-change_ldappass-plugin/Makefile
index 92b4b2fedad3..bddfae21f284 100644
--- a/mail/squirrelmail-change_ldappass-plugin/Makefile
+++ b/mail/squirrelmail-change_ldappass-plugin/Makefile
@@ -7,75 +7,17 @@
PORTNAME= change_ldappass
PORTVERSION= 2.2
PORTREVISION= 3
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Allows users to change their passwords stored in LDAP Tree
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+LICENSE= GPLv2
-SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-.ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-.else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-.endif
-.endif
-PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
-
-SUB_FILES= pkg-message
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= ldap
-WANT_PHP_WEB= yes
-USE_GETTEXT= yes
+USE_PHP+= ldap
+USE_GETTEXT= yes
.include <bsd.port.pre.mk>
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-login_notes-plugin/Makefile b/mail/squirrelmail-login_notes-plugin/Makefile
index 159b8f1b317c..870cb626e276 100644
--- a/mail/squirrelmail-login_notes-plugin/Makefile
+++ b/mail/squirrelmail-login_notes-plugin/Makefile
@@ -6,21 +6,17 @@
PORTNAME= login_notes
PORTVERSION= 1.2
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Place notes on the login screen
-RUN_DEPENDS= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+LICENSE= GPLv2
-USE_PERL5_RUN= yes
+RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-SUB_FILES= pkg-message
+USE_PERL5_RUN= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
diff --git a/mail/squirrelmail-pupdate-plugin/Makefile b/mail/squirrelmail-pupdate-plugin/Makefile
index cbb1ec32b13c..60c4fb113fc5 100644
--- a/mail/squirrelmail-pupdate-plugin/Makefile
+++ b/mail/squirrelmail-pupdate-plugin/Makefile
@@ -8,74 +8,14 @@
PORTNAME= pupdate
PORTVERSION= 0.7
PORTREVISION= 2
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.2
DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Checks for plugin updates by parsing the SM site
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
-
-SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-.ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-.else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-.endif
-.endif
-PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
-
-SUB_FILES= pkg-message
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
+LICENSE= GPLv2
.include <bsd.port.pre.mk>
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-secure_login-plugin/Makefile b/mail/squirrelmail-secure_login-plugin/Makefile
index d2f0c7baa0d7..cef2b1e55d22 100644
--- a/mail/squirrelmail-secure_login-plugin/Makefile
+++ b/mail/squirrelmail-secure_login-plugin/Makefile
@@ -8,19 +8,15 @@
PORTNAME= secure_login
PORTVERSION= 1.4
PORTREVISION= 1
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.8
DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= This plugin will automatically turn on SSL security during login
-USE_PERL5_RUN= yes
+LICENSE= GPLv2
-SUB_FILES= pkg-message
+USE_PERL5_RUN= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
diff --git a/mail/squirrelmail-timeout_user-plugin/Makefile b/mail/squirrelmail-timeout_user-plugin/Makefile
index 7845ce1acffd..1ef19231ace7 100644
--- a/mail/squirrelmail-timeout_user-plugin/Makefile
+++ b/mail/squirrelmail-timeout_user-plugin/Makefile
@@ -8,72 +8,16 @@
PORTNAME= timeout_user
PORTVERSION= 1.1.1
PORTREVISION= 2
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-0.5
DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Automatically logs a user out if they're idle for a set amount of time
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+LICENSE= GPLv2
-SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-.ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-.else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-.endif
-.endif
-PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
+RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
.include <bsd.port.pre.mk>
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
-
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-websearch-plugin/Makefile b/mail/squirrelmail-websearch-plugin/Makefile
index 9ce8b8a1da8b..786e93ce2788 100644
--- a/mail/squirrelmail-websearch-plugin/Makefile
+++ b/mail/squirrelmail-websearch-plugin/Makefile
@@ -4,73 +4,21 @@
#
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 0.1.6
+PORTNAME= websearch
+PORTVERSION= 0.1.6
PORTREVISION= 1
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
-DIST_SUBDIR= squirrelmail
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
-MAINTAINER= tabthorpe@FreeBSD.org
-COMMENT= Plugin for Websearch
+MAINTAINER= tabthorpe@FreeBSD.org
+COMMENT= Plugin for Websearch
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+LICENSE= GPLv2
-SQUIRREL_PLUGIN_NAME= web_search
-
-SUB_FILES= pkg-message
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
+RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
+SQUIRREL_PLUGIN_NAME= web_search
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>