aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-05-03 10:54:43 +0800
committerswills <swills@FreeBSD.org>2011-05-03 10:54:43 +0800
commite2009d99d193d9714cdb9987d582d69010213f18 (patch)
tree9354ff47a9ace57b69e0ff91e6b78a987376fde6
parente4ac49cd729c5af29a85a2e2b4915e1da1e00c58 (diff)
downloadfreebsd-ports-gnome-e2009d99d193d9714cdb9987d582d69010213f18.tar.gz
freebsd-ports-gnome-e2009d99d193d9714cdb9987d582d69010213f18.tar.zst
freebsd-ports-gnome-e2009d99d193d9714cdb9987d582d69010213f18.zip
State machines make it simple to manage the behavior of a class.
Too often, the state of an object is kept by creating multiple boolean attributes and deciding how to behave based on the values. state_machine simplifies this design by introducing the various parts of a real state machine, including states, events, transitions, and callbacks. However, the api is designed to be so simple you do not even need to know what a state machine is. WWW: http://www.pluginaweek.org/ PR: ports/156672 Submitted by: Eric Freeman <freebsdports at chillibear.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-state_machine/Makefile20
-rw-r--r--devel/rubygem-state_machine/distinfo2
-rw-r--r--devel/rubygem-state_machine/pkg-descr10
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bf22640feb4f..98c5c83cca38 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3263,6 +3263,7 @@
SUBDIR += rubygem-shoulda
SUBDIR += rubygem-soap4r
SUBDIR += rubygem-spruz
+ SUBDIR += rubygem-state_machine
SUBDIR += rubygem-stemmer
SUBDIR += rubygem-stomp
SUBDIR += rubygem-stream
diff --git a/devel/rubygem-state_machine/Makefile b/devel/rubygem-state_machine/Makefile
new file mode 100644
index 000000000000..fd625ca9313a
--- /dev/null
+++ b/devel/rubygem-state_machine/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: rubygem-state_machine
+# Date created: 27 April 2011
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= state_machine
+PORTVERSION= 0.10.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Support for creating state machines for attributes on any Ruby class
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-state_machine/distinfo b/devel/rubygem-state_machine/distinfo
new file mode 100644
index 000000000000..af7d967da3ed
--- /dev/null
+++ b/devel/rubygem-state_machine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/state_machine-0.10.4.gem) = 1ef55ec0817a5af69d5804820c56b141531479ccb856f03f7e6f3b2e1b1efcf9
+SIZE (rubygem/state_machine-0.10.4.gem) = 352768
diff --git a/devel/rubygem-state_machine/pkg-descr b/devel/rubygem-state_machine/pkg-descr
new file mode 100644
index 000000000000..128ebfc2a3a8
--- /dev/null
+++ b/devel/rubygem-state_machine/pkg-descr
@@ -0,0 +1,10 @@
+State machines make it simple to manage the behavior of a class.
+Too often, the state of an object is kept by creating multiple
+boolean attributes and deciding how to behave based on the values.
+
+state_machine simplifies this design by introducing the various
+parts of a real state machine, including states, events,
+transitions, and callbacks. However, the api is designed to be
+so simple you do not even need to know what a state machine is.
+
+WWW: http://www.pluginaweek.org/