aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-12-29 21:08:15 +0800
committerkwm <kwm@FreeBSD.org>2004-12-29 21:08:15 +0800
commite25dd6ad67448783875c6b092762908af1878f91 (patch)
treec67d2c485dace2fbe3babfc0188f86c6ef3a9016
parenta2306aea5cc28e2eae37331be99c5efd75174a9d (diff)
downloadfreebsd-ports-gnome-e25dd6ad67448783875c6b092762908af1878f91.tar.gz
freebsd-ports-gnome-e25dd6ad67448783875c6b092762908af1878f91.tar.zst
freebsd-ports-gnome-e25dd6ad67448783875c6b092762908af1878f91.zip
Remove USE_REINPLACE=yes, we don't use it anymore [1].
Remove USE_PYTHON=yes [1]. Remove optional libgnomeui dependencie. Its only used for the examples. And we don't build those [2]. Discussed with: maintainer [1],[2]. Submitted by: bland [1] Approved by: maintainer (implicit)
-rw-r--r--multimedia/gstreamer/Makefile11
-rw-r--r--multimedia/gstreamer80/Makefile11
2 files changed, 4 insertions, 18 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index ef32908088ef..3ebee5b497aa 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -21,9 +21,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_BISON= yes
USE_BZIP2= yes
-USE_PYTHON= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
WANT_GNOME= yes
USE_GNOME= gnomehack \
gnomeprefix \
@@ -31,6 +29,7 @@ USE_GNOME= gnomehack \
libxml2
USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --disable-tests \
+ --disable-examples \
--disable-docs-build \
--disable-failing-tests
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
@@ -57,10 +56,4 @@ post-install:
-@${PREFIX}/bin/gst-register-${GST_VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mlibgnomeui}!=""
-USE_GNOME+= libgnomeui
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer80/Makefile b/multimedia/gstreamer80/Makefile
index ef32908088ef..3ebee5b497aa 100644
--- a/multimedia/gstreamer80/Makefile
+++ b/multimedia/gstreamer80/Makefile
@@ -21,9 +21,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_BISON= yes
USE_BZIP2= yes
-USE_PYTHON= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
WANT_GNOME= yes
USE_GNOME= gnomehack \
gnomeprefix \
@@ -31,6 +29,7 @@ USE_GNOME= gnomehack \
libxml2
USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --disable-tests \
+ --disable-examples \
--disable-docs-build \
--disable-failing-tests
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
@@ -57,10 +56,4 @@ post-install:
-@${PREFIX}/bin/gst-register-${GST_VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mlibgnomeui}!=""
-USE_GNOME+= libgnomeui
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>