aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-05-12 22:54:19 +0800
committeradamw <adamw@FreeBSD.org>2016-05-12 22:54:19 +0800
commite2fb5d2896a40d1132f446849109683f83874203 (patch)
tree85a7e1037ead1c14eadfb4fc68238ebb7e5ffe35
parentf568ee47253e9e32344d8df0cec5e71e646f44af (diff)
downloadfreebsd-ports-gnome-e2fb5d2896a40d1132f446849109683f83874203.tar.gz
freebsd-ports-gnome-e2fb5d2896a40d1132f446849109683f83874203.tar.zst
freebsd-ports-gnome-e2fb5d2896a40d1132f446849109683f83874203.zip
Fix potion mixing.
From PR: This routine is swapping the potion colors and because only 2/3 of the color swap code is there, many of the potions end up with the same color. PORTREVISION bump. PR: 209310 Submitted by: sjrbulk at verizon dot net
-rw-r--r--games/bsdgames/Makefile1
-rw-r--r--games/bsdgames/files/patch-rogue_inventory.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 1560fd3baba0..39bc7180fd08 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bsdgames
PORTVERSION= 4.4.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= LOCAL/adamw
diff --git a/games/bsdgames/files/patch-rogue_inventory.c b/games/bsdgames/files/patch-rogue_inventory.c
new file mode 100644
index 000000000000..ff3e22d02d11
--- /dev/null
+++ b/games/bsdgames/files/patch-rogue_inventory.c
@@ -0,0 +1,10 @@
+--- rogue/inventory.c.orig 2016-05-12 14:49:52 UTC
++++ rogue/inventory.c
+@@ -417,6 +417,7 @@ mix_colors(void)
+ k = get_rand(0, (POTIONS - 1));
+ memcpy(t, id_potions[j].title, MAX_ID_TITLE_LEN);
+ memcpy(id_potions[j].title, id_potions[k].title, MAX_ID_TITLE_LEN);
++ memcpy(id_potions[k].title, t, MAX_ID_TITLE_LEN);
+ }
+ }
+