aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-03 01:10:39 +0800
committerpawel <pawel@FreeBSD.org>2012-11-03 01:10:39 +0800
commite4179f8c89c76cb7d53c00ec6791d32405045c3f (patch)
treef65187d929755609fcf32f94c83534e87c649620
parent629d1e5748efe7e4b6576fcb3630329751a9251b (diff)
downloadfreebsd-ports-gnome-e4179f8c89c76cb7d53c00ec6791d32405045c3f.tar.gz
freebsd-ports-gnome-e4179f8c89c76cb7d53c00ec6791d32405045c3f.tar.zst
freebsd-ports-gnome-e4179f8c89c76cb7d53c00ec6791d32405045c3f.zip
- Remove DEPRECATED and update to 2.22
- Update MASTER_SITES PR: ports/172252 (based on) Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
-rw-r--r--sysutils/linrename/Makefile47
-rw-r--r--sysutils/linrename/distinfo4
-rw-r--r--sysutils/linrename/files/patch-lib__nls.h42
-rw-r--r--sysutils/linrename/files/patch-misc-utils__rename.138
-rw-r--r--sysutils/linrename/files/patch-misc-utils__rename.c11
-rw-r--r--sysutils/linrename/pkg-descr2
6 files changed, 49 insertions, 95 deletions
diff --git a/sysutils/linrename/Makefile b/sysutils/linrename/Makefile
index c95cf91af729..4c4df57e8bef 100644
--- a/sysutils/linrename/Makefile
+++ b/sysutils/linrename/Makefile
@@ -2,41 +2,40 @@
# $FreeBSD$
PORTNAME= linrename
-PORTVERSION= 2.12r
-PORTREVISION= 2
+PORTVERSION= 2.22
CATEGORIES= sysutils
-MASTER_SITES= http://mirror.linux.org.au/pub/linux/utils/util-linux/ \
- http://debian.csail.mit.edu/pub/linux/utils/util-linux/ \
- http://www.club.cc.cmu.edu/pub/linux.out-of-date/utils/util-linux/ \
- ${MASTER_SITE_KERNEL_ORG}
-MASTER_SITE_SUBDIR= linux/utils/util-linux
+#MASTER_SITES= KERNEL_ORG/linux/utils/util-linux/v${PORTVERSION}
+MASTER_SITES= http://ftp.ntu.edu.tw/ftp/linux/%SUBDIR%/ \
+ http://ftp.sunet.se/pub/Linux/kernel.org/linux/%SUBDIR%/ \
+ http://kernel.org/pub/linux/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,linux/kernel.org/&,}
+MASTER_SITE_SUBDIR= utils/util-linux/v${PORTVERSION}
DISTNAME= util-linux-${PORTVERSION}
-DEPRECATED= No more public distfile
-EXPIRATION_DATE= 2012-11-26
-
MAINTAINER= ports@FreeBSD.org
COMMENT= Rename multiple files using substitution
-PLIST_FILES= bin/linrename
-MAN1= linrename.1
+BUILD_WRKSRC= ${WRKSRC}/misc-utils
+INSTALL_WRKSRC= ${WRKSRC}/misc-utils
+
+USE_XZ= yes
-USE_BZIP2= yes
-USE_GETTEXT= yes
+CPPFLAGS+= -I../include -DHAVE_LOCALE_H -DHAVE_LANGINFO_H \
+ -DPACKAGE_STRING=\"util-linux\ ${PORTVERSION}\"
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -lintl -I${WRKSRC}/lib
-EXTRACT_AFTER_ARGS= | tar -xf - \
- ${DISTNAME}/lib/nls.h \
- ${DISTNAME}/misc-utils/rename.1 \
- ${DISTNAME}/misc-utils/rename.c
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
-.include <bsd.port.pre.mk>
+post-patch:
+ ${LN} -sf rename.1 ${BUILD_WRKSRC}/${PORTNAME}.1
do-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/misc-utils/rename.c
+ (cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o ${PORTNAME} \
+ rename.c ${LDFLAGS})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/misc-utils/rename.1 ${PREFIX}/man/man1/${MAN1}
+ (cd ${INSTALL_WRKSRC} \
+ && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin \
+ && ${INSTALL_MAN} ${PORTNAME}.1 ${MANPREFIX}/man/man1)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/linrename/distinfo b/sysutils/linrename/distinfo
index e459dc4c7a91..cdcd51b058e1 100644
--- a/sysutils/linrename/distinfo
+++ b/sysutils/linrename/distinfo
@@ -1,2 +1,2 @@
-SHA256 (util-linux-2.12r.tar.bz2) = b8e499b338ce9fbd1fb315194b26540ec823c0afc46c9e145ac7a3e38ad57e6b
-SIZE (util-linux-2.12r.tar.bz2) = 1370907
+SHA256 (util-linux-2.22.tar.xz) = 32b329aa72c2ea546378bf81f08e30cf30440196c2edf7777b4f509a3fdbe5a2
+SIZE (util-linux-2.22.tar.xz) = 3183868
diff --git a/sysutils/linrename/files/patch-lib__nls.h b/sysutils/linrename/files/patch-lib__nls.h
deleted file mode 100644
index e8ef01d418ce..000000000000
--- a/sysutils/linrename/files/patch-lib__nls.h
+++ /dev/null
@@ -1,42 +0,0 @@
---- ./lib/nls.h.orig Thu Jul 4 23:03:26 2002
-+++ ./lib/nls.h Mon Dec 25 14:54:11 2006
-@@ -1,7 +1,5 @@
- int main(int argc, char *argv[]);
-
--#include "../defines.h" /* for HAVE_locale_h */
--
- #ifndef PACKAGE
- #define PACKAGE "util-linux"
- #endif
-@@ -10,25 +8,12 @@
- #define LOCALEDIR "/usr/share/locale"
- #endif
-
--#ifdef HAVE_locale_h
--# include <locale.h>
--#endif
-+#include <locale.h>
-
--#if defined MAY_ENABLE_NLS && !defined DISABLE_NLS
--# include <libintl.h>
--# define _(Text) gettext (Text)
--# ifdef gettext_noop
--# define N_(String) gettext_noop (String)
--# else
--# define N_(String) (String)
--# endif
-+#include <libintl.h>
-+#define _(Text) gettext (Text)
-+#ifdef gettext_noop
-+# define N_(String) gettext_noop (String)
- #else
--# undef bindtextdomain
--# define bindtextdomain(Domain, Directory) /* empty */
--# undef textdomain
--# define textdomain(Domain) /* empty */
--# define _(Text) (Text)
--# define N_(Text) (Text)
-+# define N_(String) (String)
- #endif
--
--
diff --git a/sysutils/linrename/files/patch-misc-utils__rename.1 b/sysutils/linrename/files/patch-misc-utils__rename.1
index 58de31e772ea..e5cf9be39591 100644
--- a/sysutils/linrename/files/patch-misc-utils__rename.1
+++ b/sysutils/linrename/files/patch-misc-utils__rename.1
@@ -1,37 +1,45 @@
---- ./misc-utils/rename.1.orig Sun Aug 22 17:14:45 2004
-+++ ./misc-utils/rename.1 Mon Dec 25 14:54:11 2006
-@@ -3,11 +3,11 @@
+--- misc-utils/rename.1.orig 2012-06-11 19:06:53.730196000 +0900
++++ misc-utils/rename.1 2012-09-28 00:43:17.000000000 +0900
+@@ -3,12 +3,12 @@
.\"
- .TH RENAME 1 "1 January 2000" "" "Linux Programmer's Manual"
+ .TH RENAME 1 "June 2011" "util-linux" "User Commands"
.SH NAME
--rename \- Rename files
-+linrename \- Rename files
+-rename \- rename files
++linrename \- rename files
.SH SYNOPSIS
--.BI rename " from to file..."
-+.BI linrename " from to file..."
+-.B rename
++.B linrename
+ .RI [ options ] " expression replacement file" ...
.SH DESCRIPTION
-.B rename
+.B linrename
will rename the specified files by replacing the first occurrence of
- .I from
+ .I expression
in their name by
-@@ -19,8 +19,8 @@
-
+@@ -30,8 +30,8 @@
.RS
+ .PP
.nf
-rename foo foo0 foo?
-rename foo foo0 foo??
+linrename foo foo0 foo?
+linrename foo foo0 foo??
.fi
+ .PP
.RE
-
-@@ -30,7 +30,7 @@
- And
+@@ -41,7 +41,7 @@
.RS
+ .PP
.nf
-rename .htm .html *.htm
+linrename .htm .html *.htm
.fi
+ .PP
.RE
-
+@@ -56,5 +56,5 @@
+ .BR mmv (1),
+ .BR mv (1)
+ .SH AVAILABILITY
+-The rename command is part of the util-linux package and is available from
++The linrename command is part of the util-linux package and is available from
+ ftp://ftp.kernel.org/pub/linux/utils/util-linux/.
diff --git a/sysutils/linrename/files/patch-misc-utils__rename.c b/sysutils/linrename/files/patch-misc-utils__rename.c
deleted file mode 100644
index de69e27ecd23..000000000000
--- a/sysutils/linrename/files/patch-misc-utils__rename.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./misc-utils/rename.c.orig Tue May 9 23:39:03 2000
-+++ ./misc-utils/rename.c Mon Dec 25 14:54:11 2006
-@@ -19,6 +19,8 @@
- #include <errno.h>
- #include "nls.h"
-
-+#define util_linux_version "util-linux-2.12r"
-+
- static char *progname;
-
- static int
diff --git a/sysutils/linrename/pkg-descr b/sysutils/linrename/pkg-descr
index a2a33c8e51af..55ad3d070e41 100644
--- a/sysutils/linrename/pkg-descr
+++ b/sysutils/linrename/pkg-descr
@@ -1,4 +1,4 @@
linrename is a port of the Linux rename utility included with util-linux.
It allows renaming multiple files using substitution.
-WWW: http://freshmeat.net/projects/util-linux/
+WWW: http://freecode.com/projects/util-linux/