aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2016-03-20 23:58:24 +0800
committerolivierd <olivierd@FreeBSD.org>2016-03-20 23:58:24 +0800
commite518c7f660b5edbc3c98bb263abf5d245bfa3666 (patch)
tree01b3f331a22e047ef3deaf1a6b6f8c7ad6da5485
parentaaf176b09436f909b689a99f433d1e65b55e6d32 (diff)
downloadfreebsd-ports-gnome-e518c7f660b5edbc3c98bb263abf5d245bfa3666.tar.gz
freebsd-ports-gnome-e518c7f660b5edbc3c98bb263abf5d245bfa3666.tar.zst
freebsd-ports-gnome-e518c7f660b5edbc3c98bb263abf5d245bfa3666.zip
This package privides the NetSurf shared buildsystem.
WWW: http://www.netsurf-browser.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/netsurf-buildsystem/Makefile25
-rw-r--r--devel/netsurf-buildsystem/distinfo2
-rw-r--r--devel/netsurf-buildsystem/files/patch-Makefile29
-rw-r--r--devel/netsurf-buildsystem/files/patch-makefiles_Makefile.tools39
-rw-r--r--devel/netsurf-buildsystem/pkg-descr3
-rw-r--r--devel/netsurf-buildsystem/pkg-plist9
7 files changed, 108 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3ea4fcdd10e5..2158a12d7314 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1530,6 +1530,7 @@
SUBDIR += ndesk-dbus-glib
SUBDIR += ndesk-options
SUBDIR += netscape-java40
+ SUBDIR += netsurf-buildsystem
SUBDIR += newfile
SUBDIR += newt
SUBDIR += newtonsoft-json
diff --git a/devel/netsurf-buildsystem/Makefile b/devel/netsurf-buildsystem/Makefile
new file mode 100644
index 000000000000..bfcf21b76fa8
--- /dev/null
+++ b/devel/netsurf-buildsystem/Makefile
@@ -0,0 +1,25 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= buildsystem
+PORTVERSION= 1.5
+CATEGORIES= devel
+MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
+PKGNAMEPREFIX= netsurf-
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= NetSurf project buildsystem
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+MAKE_ENV+= COMPONENT_TYPE=lib-shared \
+
+USES= gmake shebangfix perl5
+
+SHEBANG_LANG= perl
+perl_CMD= ${SETENV} perl
+SHEBANG_FILES= testtools/testrunner.pl
+
+.include <bsd.port.mk>
diff --git a/devel/netsurf-buildsystem/distinfo b/devel/netsurf-buildsystem/distinfo
new file mode 100644
index 000000000000..0370ec306838
--- /dev/null
+++ b/devel/netsurf-buildsystem/distinfo
@@ -0,0 +1,2 @@
+SHA256 (buildsystem-1.5.tar.gz) = dbc6afc639f6987b704e6ff4427668787ee7efba77e1bbf76b614699b5daaf71
+SIZE (buildsystem-1.5.tar.gz) = 38196
diff --git a/devel/netsurf-buildsystem/files/patch-Makefile b/devel/netsurf-buildsystem/files/patch-Makefile
new file mode 100644
index 000000000000..f02d5971783b
--- /dev/null
+++ b/devel/netsurf-buildsystem/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2015-03-08 12:05:58 UTC
++++ Makefile
+@@ -19,7 +19,7 @@ usage:
+ @echo ""
+ @echo "Which is where the libraries etc look for it."
+
+-PREFIX?=/opt/netsurf
++PREFIX?=%%PREFIX%%
+
+ BASE=$(DESTDIR)$(PREFIX)/share/netsurf-buildsystem
+
+@@ -33,16 +33,13 @@ TESTTOOLS := testrunner.pl
+ CITOOLS := jenkins-build.sh
+
+ install:
+- mkdir -p $(BASE)/makefiles $(BASE)/testtools $(BASE)/citools
++ mkdir -p $(BASE)/makefiles $(BASE)/testtools
+ for M in $(MAKEFILES); do \
+ cp makefiles/$$M $(BASE)/makefiles/; \
+ done
+ for T in $(TESTTOOLS); do \
+ cp testtools/$$T $(BASE)/testtools/; \
+ done
+- for C in $(CITOOLS); do \
+- cp citools/$$C $(BASE)/citools/; \
+- done
+
+ # Distribution
+ # This constructs a distribution tar from the last git tag. It ensures
diff --git a/devel/netsurf-buildsystem/files/patch-makefiles_Makefile.tools b/devel/netsurf-buildsystem/files/patch-makefiles_Makefile.tools
new file mode 100644
index 000000000000..459214efa3ba
--- /dev/null
+++ b/devel/netsurf-buildsystem/files/patch-makefiles_Makefile.tools
@@ -0,0 +1,39 @@
+--- makefiles/Makefile.tools.orig 2016-02-14 22:21:24 UTC
++++ makefiles/Makefile.tools
+@@ -109,6 +109,18 @@ ifeq ($(BUILD),$(HOST))
+ CFLAGS := $(CFLAGS) -I$(GCCSDK_INSTALL_ENV)/include -I/usr/local/include
+ CXXFLAGS := $(CXXFLAGS) -I$(GCCSDK_INSTALL_ENV)/include -I/usr/local/include
+ LDFLAGS := $(LDFLAGS) -L$(GCCSDK_INSTALL_ENV)/lib -L/usr/local/lib
++
++ PKGCONFIG ?= PKG_CONFIG_PATH="$(PREFIX)/libdata/pkgconfig:$(PKG_CONFIG_PATH)" pkgconf
++ endif
++
++ ifeq ($(findstring dragonfly,$(HOST)),dragonfly)
++ # Building on+for FreeBSD
++ CFLAGS := $(CFLAGS) -I$(GCCSDK_INSTALL_ENV)/include -I/usr/local/include
++ CXXFLAGS := $(CXXFLAGS) -I$(GCCSDK_INSTALL_ENV)/include -I/usr/local/include
++ LDFLAGS := $(LDFLAGS) -L$(GCCSDK_INSTALL_ENV)/lib -L/usr/local/lib
++
++ PKGCONFIG ?= PKG_CONFIG_PATH="$(PREFIX)/libdata/pkgconfig:$(PKG_CONFIG_PATH)
++" pkgconf
+ endif
+
+ ifeq ($(findstring arwin,$(HOST)),arwin)
+@@ -130,7 +142,7 @@ else
+ endif
+
+ # Search the path for the compiler
+- toolpath_ := $(shell /bin/which $(CC__))
++ toolpath_ := $(shell /usr/bin/which $(CC__))
+ ifeq ($(toolpath_),)
+ toolpath_ := /opt/netsurf/$(HOST)/cross/bin/
+ CC__ := $(toolpath_)$(HOST)-gcc
+@@ -141,7 +153,7 @@ else
+ toolpath_ := $(dir $(CC__))
+ toolprefix_ := $(subst :,/,$(dir $(subst -,/,$(subst /,:,$(CC__)))))
+ ifeq ($(origin AR),default)
+- AR__ := $(toolprefix_)-ar
++ AR__ := $(shell /usr/bin/which ar)
+ endif
+ ifeq ($(origin CXX),default)
+ CXX__ := $(toolprefix_)-g++
diff --git a/devel/netsurf-buildsystem/pkg-descr b/devel/netsurf-buildsystem/pkg-descr
new file mode 100644
index 000000000000..27efe1402b00
--- /dev/null
+++ b/devel/netsurf-buildsystem/pkg-descr
@@ -0,0 +1,3 @@
+This package privides the NetSurf shared buildsystem.
+
+WWW: http://www.netsurf-browser.org/
diff --git a/devel/netsurf-buildsystem/pkg-plist b/devel/netsurf-buildsystem/pkg-plist
new file mode 100644
index 000000000000..f617bb2894af
--- /dev/null
+++ b/devel/netsurf-buildsystem/pkg-plist
@@ -0,0 +1,9 @@
+share/netsurf-buildsystem/makefiles/Makefile.clang
+share/netsurf-buildsystem/makefiles/Makefile.gcc
+share/netsurf-buildsystem/makefiles/Makefile.norcroft
+share/netsurf-buildsystem/makefiles/Makefile.open64
+share/netsurf-buildsystem/makefiles/Makefile.pkgconfig
+share/netsurf-buildsystem/makefiles/Makefile.subdir
+share/netsurf-buildsystem/makefiles/Makefile.tools
+share/netsurf-buildsystem/makefiles/Makefile.top
+share/netsurf-buildsystem/testtools/testrunner.pl