aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-02-02 21:06:37 +0800
committerswills <swills@FreeBSD.org>2017-02-02 21:06:37 +0800
commite5e8ebfbe6ec46ad55088e446d2f0485f02e308b (patch)
tree97e64df4b7d380a0e970fcdf6af87f0250f8d019
parent9d1afa884ad376c0d6abf14c6cb99cc80e4c9d3c (diff)
downloadfreebsd-ports-gnome-e5e8ebfbe6ec46ad55088e446d2f0485f02e308b.tar.gz
freebsd-ports-gnome-e5e8ebfbe6ec46ad55088e446d2f0485f02e308b.tar.zst
freebsd-ports-gnome-e5e8ebfbe6ec46ad55088e446d2f0485f02e308b.zip
devel/jfrog-cli: create port
JFrog CLI is a compact and smart client that provides a simple interface that automates access to JFrog Artifactory, JFrog Mission Control, JFrog Bintray and JFrog Xray (through their respective REST APIs). By using the JFrog CLI, you can greatly simplify your automation scripts making them more readable and easier to maintain. Several features of the JFrog CLI makes your scripts more efficient and reliable. WWW: https://www.jfrog.com/getcli/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jfrog-cli/Makefile35
-rw-r--r--devel/jfrog-cli/distinfo3
-rw-r--r--devel/jfrog-cli/pkg-descr8
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 43c383ebbd51..42e3bc739386 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1123,6 +1123,7 @@
SUBDIR += jech-dht
SUBDIR += jenkins
SUBDIR += jenkins-lts
+ SUBDIR += jfrog-cli
SUBDIR += jiic
SUBDIR += jline
SUBDIR += jna
diff --git a/devel/jfrog-cli/Makefile b/devel/jfrog-cli/Makefile
new file mode 100644
index 000000000000..d88614b3e90d
--- /dev/null
+++ b/devel/jfrog-cli/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= jfrog-cli
+PORTVERSION= 1.6.0
+CATEGORIES= devel
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= CLI client for Artifactory
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= JFrogDev
+GH_PROJECT= jfrog-cli-go
+
+PLIST_FILES= bin/jfrog
+
+STRIP= # stripping can break go binaries
+
+post-extract:
+ @${MV} ${WRKSRC}/vendor/ ${WRKSRC}/src
+ @${MKDIR} ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go
+.for src in .gitignore CONTRIBUTING.md Jenkinsfile LICENSE README.md \
+ artifactory bintray getCli.sh jfrog missioncontrol testsdata utils xray
+ @${MV} ${WRKSRC}/${src} ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go
+.endfor
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go ; \
+ ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/jfrog ${STAGEDIR}${PREFIX}/bin/jfrog
+
+.include <bsd.port.mk>
diff --git a/devel/jfrog-cli/distinfo b/devel/jfrog-cli/distinfo
new file mode 100644
index 000000000000..deb95a646d2f
--- /dev/null
+++ b/devel/jfrog-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485889695
+SHA256 (JFrogDev-jfrog-cli-go-1.6.0_GH0.tar.gz) = 5da5e904ee1a46c367652a9df4f4787a63fa9ec5934f44698f3aae7e8bc25680
+SIZE (JFrogDev-jfrog-cli-go-1.6.0_GH0.tar.gz) = 162253
diff --git a/devel/jfrog-cli/pkg-descr b/devel/jfrog-cli/pkg-descr
new file mode 100644
index 000000000000..8f0e7f87701b
--- /dev/null
+++ b/devel/jfrog-cli/pkg-descr
@@ -0,0 +1,8 @@
+JFrog CLI is a compact and smart client that provides a simple interface that
+automates access to JFrog Artifactory, JFrog Mission Control, JFrog Bintray and
+JFrog Xray (through their respective REST APIs). By using the JFrog CLI, you
+can greatly simplify your automation scripts making them more readable and
+easier to maintain. Several features of the JFrog CLI makes your scripts more
+efficient and reliable.
+
+WWW: https://www.jfrog.com/getcli/