aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-27 06:32:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-27 06:32:12 +0800
commite78098a70876765b04bb7d66729d9babff1c3ea2 (patch)
treee70d1629a1dde2c3c84c15ed1f0fc3ca1d854bda
parent097327fc477c334120071a6e5d409515ca62a602 (diff)
downloadfreebsd-ports-gnome-e78098a70876765b04bb7d66729d9babff1c3ea2.tar.gz
freebsd-ports-gnome-e78098a70876765b04bb7d66729d9babff1c3ea2.tar.zst
freebsd-ports-gnome-e78098a70876765b04bb7d66729d9babff1c3ea2.zip
Simplify Makefile: use PY_ENUM34
With hat: python
-rw-r--r--security/py-python-registry/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
index 22e79254a6b5..1b632b3cebb8 100644
--- a/security/py-python-registry/Makefile
+++ b/security/py-python-registry/Makefile
@@ -13,6 +13,8 @@ COMMENT= Read access to Windows Registry files
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+RUN_DEPENDS= ${PY_ENUM34}
+
USE_GITHUB= yes
GH_ACCOUNT= williballenthin
@@ -27,12 +29,6 @@ OPTIONS_DEFINE= DOCS EXAMPLES
PORTDOCS= *
PORTEXAMPLES= *
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>=0:devel/py-enum34@${FLAVOR}
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.TXT ${WRKSRC}/CONTRIBUTORS.TXT ${WRKSRC}/README.MD \
@@ -42,4 +38,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>