aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-06-07 15:48:03 +0800
committergahr <gahr@FreeBSD.org>2016-06-07 15:48:03 +0800
commite788458e31db4ba3b7137d0c018cf376b1fc1e5c (patch)
tree89d6304ac0c1772815f7b5eda959a1e7480354e2
parent565d5485d194a62a3ef2e68414f85d2e49154dcb (diff)
downloadfreebsd-ports-gnome-e788458e31db4ba3b7137d0c018cf376b1fc1e5c.tar.gz
freebsd-ports-gnome-e788458e31db4ba3b7137d0c018cf376b1fc1e5c.tar.zst
freebsd-ports-gnome-e788458e31db4ba3b7137d0c018cf376b1fc1e5c.zip
lang/itcl4: do not strip the stubs lib, consumers need the stubs pointer symbol
Reported by: Peter da Silva <peter.dasilva@flightaware.com>
-rw-r--r--lang/itcl4/Makefile4
-rw-r--r--lang/itcl4/files/patch-Makefile.in9
2 files changed, 4 insertions, 9 deletions
diff --git a/lang/itcl4/Makefile b/lang/itcl4/Makefile
index cfa44dd6d7fd..65ef02cfb701 100644
--- a/lang/itcl4/Makefile
+++ b/lang/itcl4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= itcl4
PORTVERSION= 4.0.4
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= TCLTK/itcl \
SF/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%20${PORTVERSION}/
@@ -16,4 +17,7 @@ CONFIGURE_ARGS+=--includedir=${PREFIX}/include/itcl${PORTVERSION:R}
PLIST_SUB+= PKGVER=${PORTVERSION}
TEST_TARGET= test
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/itcl${PORTVERSION}/libitcl${PORTVERSION}.so
+
.include <bsd.port.mk>
diff --git a/lang/itcl4/files/patch-Makefile.in b/lang/itcl4/files/patch-Makefile.in
index 07bfff8bc7a2..e35eb0087687 100644
--- a/lang/itcl4/files/patch-Makefile.in
+++ b/lang/itcl4/files/patch-Makefile.in
@@ -1,14 +1,5 @@
--- Makefile.in.orig 2013-11-21 20:49:06 UTC
+++ Makefile.in
-@@ -93,7 +93,7 @@ INSTALL_DATA_DIR = ${INSTALL} -d -m 755
- INSTALL_PROGRAM = ${INSTALL} -m 755
- INSTALL_DATA = ${INSTALL} -m 644
- INSTALL_SCRIPT = ${INSTALL_PROGRAM}
--INSTALL_LIBRARY = ${INSTALL_DATA}
-+INSTALL_LIBRARY = ${INSTALL_DATA} -s
-
- PACKAGE_NAME = @PACKAGE_NAME@
- PACKAGE_VERSION = @PACKAGE_VERSION@
@@ -222,11 +222,12 @@ install-doc: doc
@$(INSTALL_DATA_DIR) $(DESTDIR)$(mandir)/mann
@echo "Installing documentation in $(DESTDIR)$(mandir)"