aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-15 06:29:05 +0800
committertijl <tijl@FreeBSD.org>2014-02-15 06:29:05 +0800
commite7be0d4058b52a2033b4d0d8f72e0631fd6da3e3 (patch)
tree6bcbe566d33de8696a7d598aba6e2eadea7054c7
parentc1857cfd8dd8a8ec77bb942be8476bd70379e706 (diff)
downloadfreebsd-ports-gnome-e7be0d4058b52a2033b4d0d8f72e0631fd6da3e3.tar.gz
freebsd-ports-gnome-e7be0d4058b52a2033b4d0d8f72e0631fd6da3e3.tar.zst
freebsd-ports-gnome-e7be0d4058b52a2033b4d0d8f72e0631fd6da3e3.zip
- Also set link_all_deplibs_(CXX|F77|FC)=no.
- In libtool 1.3 set deplibs_check_method=pass_all like it is in later versions. This avoids checking every library with file(1) to see if it's really a library and avoids some incorrect uses of expr(1) ("expr $var" instead of "expr -- $var" where $var can start with -l). The parsing of file(1) output is also tested during configure on /usr/lib/libc.so.* which doesn't exist so configure printed a big (but harmless) warning. Approved by: bapt
-rw-r--r--Mk/Uses/libtool.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index cc215cca48ec..80779d91d6fe 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -19,8 +19,10 @@ _INCLUDE_USES_LIBTOOL_POST_MK= yes
patch-libtool:
@${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \
-type f | ${XARGS} ${REINPLACE_CMD} \
- -e '/link_all_deplibs=/s/=unknown/=no/' \
- -e '/objformat=/s/echo aout/echo elf/'
+ -e '/link_all_deplibs[0-9A-Z_]*=/s/=unknown/=no/' \
+ -e '/objformat=/s/echo aout/echo elf/' \
+ -e "/freebsd-elf\\*)/,/;;/ { \
+ /deplibs_check_method=/s/=.*/=pass_all/; }"
.if ! ${libtool_ARGS:Moldver}
@${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \